Highlighted
badbytes
1 Copper

BMC not responsive after OS Linux boot?

I'm in the process of testing a rebuilding an HPC, and I have a Dell PowerEdge R810 that I rebuilt, and upon boot of the OS, lose connectivity to BMC with ipmitool or web GUI.

The LOM in BMC is configured to shared.

Have tried disabling the ethernet links within Linux to no avail.

Any ideas as to what I can try next?

Thanks

Dan

[user@devhpc ~]$ ipmitool -I lanplus -H 172.16.100.34 -U ***** -P ***** delloem lan get
shared


[danc@devhpc ~]$ ipmitool -I lanplus -H 172.16.100.34 -U ***** -P ***** lan print
Set in Progress         : Set Complete
Auth Type Support       : NONE MD2 MD5 PASSWORD
Auth Type Enable        : Callback : MD2 MD5
                        : User     : MD2 MD5
                        : Operator : MD2 MD5
                        : Admin    : MD2 MD5
                        : OEM      :
IP Address Source       : Static Address
IP Address              : 172.16.100.34
Subnet Mask             : 255.255.0.0
MAC Address             : 14:fe:b5:ca:05:bd
SNMP Community String   : public
IP Header               : TTL=0x40 Flags=0x40 Precedence=0x00 TOS=0x10
Default Gateway IP      : 172.16.100.254
Default Gateway MAC     : 00:00:00:00:00:00
Backup Gateway IP       : 0.0.0.0
Backup Gateway MAC      : 00:00:00:00:00:00
802.1q VLAN ID          : Disabled
802.1q VLAN Priority    : 0
RMCP+ Cipher Suites     : 0,1,2,3,4,5,6,7,8,9,10,11,12,13,14
Cipher Suite Priv Max   : aaaaaaaaaaaaaaa
                        :     X=Cipher Suite Unused
                        :     c=CALLBACK
                        :     u=USER
                        :     o=OPERATOR
                        :     a=ADMIN
                        :     O=OEM
Bad Password Threshold  : Not Available

Tags (2)
0 Kudos
2 Replies
Moderator
Moderator

RE: BMC not responsive after OS Linux boot?

Hello

When the LOM is in shared mode it operates as two independent network ports on the same interface. If the network connection is being lost when the OS comes online then it is likely due to some type of network security. This is not likely an issue with the server. This issue is most likely with your switch or network configuration.

I would suggest bypassing your switch and connecting the system directly to a laptop/desktop to test.

Thanks

Daniel Mysinger
Dell EMC, Enterprise Engineer

Get support on Twitter @DellCaresPRO

0 Kudos
badbytes
1 Copper

RE: BMC not responsive after OS Linux boot?

Thanks for the post and your help Daniel.

I will try what you suggested. I would also point out, that it is a specific OS build where the issue arises. Booting to another live OS image, with networking enabled, albeit settings are somewhat different, then there is no issue.  Also, this sharing of LOM is also a new issue without any network changes. Like I said, it worked before under RedHat 5.7, but now not.

While based on this, there could still be a network issue, wouldn't these indicate something in the OS causing a failure. Or is that just not possible?

Would I get this kind of behavior if LOM is dedicated? Reason being, that while the MC is set to shared, could it be in error. Meaning reporting shared, but actually dedicated?

Thanks

Dan

0 Kudos