PowerEdge Hardware General

Last reply by 01-04-2018 Unsolved
Start a Discussion
2 Bronze
2 Bronze
2876

Dell T20 PowerEdge will only go to Intel Boot Agent and then hangs.

Hi,

I have a PowerEdge T20. It was working fine with a SSD disk for windows 10 and another 1TB WD disk for data. I added another disk on which I wanted to install Linux which initially went OK.

However now I can't see any disks. What ever I do it always goes to the Intel Boot Agent screen and hangs.

At the moment I have just the 1 hard disk in that should be a UEFI Linux Ubuntu boot. (although I get the same results with a SSD with Windows 10).

On power on I get the DELL logo then the Intel Boot Agent screen,

Pressing F2 at boot I get "F12 Boot options" then "preparing to Enter Setup" then it jumps to the Intel Boot Agent Screen.

Pressing F12 it says preparing one time boot and you've guessed it, it jumps to  the Intel Boot Agent Screen.

Nothing seems to stop it jumping to the Boot Agent Screen and then hanging.

Any suggestions anyone?

Thanks in advance.

Jeremy

Replies (10)
Moderator
Moderator
1843

Hello

I would disconnect all of the disks. If you don't have issues booting into <CTL I> when the drives are disconnected then it is either an issue with the drives or a software issue with the boot loader. I would test without the drive that was just added.

Thanks

Daniel Mysinger
Dell EMC, Enterprise Engineer

2 Bronze
2 Bronze
1843

Hello Daniel,

Thanks for the reply.

I disconnected all disks but still have problems. On power on the monitor comes out of standby mode but displays nothing then goes to sleep, no mater whether I press esc, F2 or F12 etc.

I plugged a drive back in, the hard disk access light does blink, but nothing on the monitor which then goes to sleep.

It seems to have got worse. Any other suggestions?

Thanks Jeremy

2 Bronze
2 Bronze
1843

Hello Daniel,

For get my last email. I hadn't plugged the keyboard back in.

I've tried entering CTRL-I but it does nothing. I've not been able to get it to show the list of drives and prompt for the CTRL-I input.

What ever I do it ends up at the Intel Boot Agent screen, with np prompt for CTRL-I on the way there.

Any suggestions?

Best wishes,

Jeremy

Moderator
Moderator
1843

What ever I do it ends up at the Intel Boot Agent screen, with np prompt for CTRL-I on the way there.

The boot agent is coming up because it can't find a valid boot device. Try booting to some form of media like your operating system DVD or a bootable USB drive. If you are able to boot to media then update the system BIOS. Since your operating system is not functioning you will need to use the DOS update method. Instructions are at the bottom of the BIOS download page.

www.dell.com/support/home/product-support/product/poweredge-t20/

Thanks

Daniel Mysinger
Dell EMC, Enterprise Engineer

2 Bronze
2 Bronze
1843

Hello Daniel,

Thanks for the reply, but still no joy. I tried an Ubuntu DVD, Ubuntu on a USB and also tried a UFEI bootable HDD from another DellT20 that was booting Windows 10 OK. But whatever combination of disks and key presses it always goes quickly to the Intel Boot Agent screen.

Is there a way to do a factory reset of the Motherboard?

Best wishes,

Jeremy

Moderator
Moderator
1843

Is there a way to do a factory reset of the Motherboard?

The system board jumpers section starts on page 63 of the manual. There is a jumper to reset the BIOS to defaults.

Thanks

Daniel Mysinger
Dell EMC, Enterprise Engineer

2 Bronze
2 Bronze
1843

Hello Daniel,

Thanks for getting back to me. Unfortunately a BIOS reset hasn't helped.

Is there anything else I can try?

Best wishes,

Jeremy

Moderator
Moderator
1843

Is there anything else I can try?

You can remove all unnecessary hardware by taking the system to minimum-to-POST.

Daniel Mysinger
Dell EMC, Enterprise Engineer

2 Bronze
2 Bronze
1843

Hello Daniel,

I've just two memory boards install with nothing connected to any of the 4 sata connectors and USB mouse and keyboard connected.

On powering up pressing no keys it goes to Initializing Intel Boot Agent

Power up pressing "Esc" I get the dell logo and F12 Boot option in the top right. If I don't press F12 it goes to the Intel Boot Agent. If I press F12 it changes to "Preparing one-time boot menu" and then goes to Intel Boot Agent.

Pressing F2 on power up I get the Dell Logo and "Preparing to enter Setup" followed by the  Initializing Intel Boot Agent.

Are there any other keys I should be pressing?

Best wishes,

Jeremy

Latest Solutions
Top Contributor