Rack Servers

Last reply by 09-06-2020 Unsolved
Start a Discussion
2 Bronze
2 Bronze
40004

IDRAC6 - Connection failed

I recently bought two iDRAC 6 that were refurbished.  Great price and this would really be nice to have - iDRAC Enterprise for my old R710's.  However, after all the config I only can get Connection failed when I try to start a virtual console.  Some of the troubleshooting I have done includes:

  • Windows 10, with Chrome v65.0.3235.181 64-bit, and Firefox v59.0.2 64-bit were tried and behave the same.
  • Windows 7, with Chrome same version but 32-bit, and Firefox same version but 32-bit also behaved the same.
  • IP address of iDRAC is in the server exceptions of Java
  • Java network settings configured for Direct Connect.
  • iDRAC set to use Java plug-in instead of Native. I have also tried it at Native.
  • I have done a cold start on the server.
  • There is no firewalls in use - either between my laptop / desktop and the iDRAC on in the OS of the laptop / desktop.
  • The iDRAC has been updated to 2.90.
  • I also did a reset to default of the iDRAC and reconfigured it.

I have already put an unreasonable amount of time into this.  With my R710s warranty expired I cannot call Dell support.  Is there any suggestions that people might have that would help me out?

I would most appreciate it. Thank you.

Michael

Replies (11)
39010

 

Mwname,

A couple things that I need to confirm, first off is if you can private message me the svc tag so that can tell you if iDrac Enterprise is even installed on the server. Second is if it is installed on the server, then where are you plugging the cable into? Lastly is what port the iDrac is configured to use?

Let me know.

 


Chris Hawk
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#Iwork4Dell

Did I answer your query? Please click on ‘Accept as Solution’
‘Kudo’ the posts you like!
39005

Hi Chris,

I installed the iDRAC 6 enterprise.  And I was able to make it work this morning.  I removed the Java 8, and deleted the java folder in Program Data, and installed Java 7 Update 79.  With no further configuration everything worked great.  I did this on the Windows7 / FireFox - 32 bit.

Michael

2 Bronze
2 Bronze
38677

Hi all,

I will share my solution and it's so easy to fix this problem after that I spent all the night with many suggestions as the others suggest .

 

the best way just uninstall the java and install an older version as Java 7

 

 

2 Bronze
2 Bronze
38664

In my experience, this all has to do with the java version. I uninstalled Java 8_171 and installed 7_79 and now my iDrac console works perfectly. This is not ideal because the older versions of Java are not secure. Not really sure what else we can do it about it when the iDrac6 doesn't work with newer versions. 

I have a separate VM that I run the older Java version in. I shut it down when not in use. 

38248

I, too, have the issue where I cannot connect to iDrac6 Enterprise consoles under Win10/Java8 Release 181.

As I cannot 'downgrade' Java for security reasons, is there an update to iDRAC6 (ie. firmware) which will allow/fix the problem?

 

 

37110

The same here. The only solution so far is uninstall updated Java 8 (u181, in my case) and re-install Java 7u79. Thanks for the info.

35676

According to the following Japanese website, the situation is because newer Java does not accept SHA-1 signed certificates. Installing SHA-2 certificate on iDRAC works with newer Java 8.

https://nyacom.net/?p=486

35600

Is Dell going to release an update(firmware etc.) for iDRAC 6 so that it will work with the current Java? If anyone knows, please share as I have a bunch of test systems still using iDRAC 6.  If you have a workaround please share as well.

2 Bronze
2 Bronze
17003

Here is the quick solution.

1. Add IP or hostname of iDRAC on exception site list from Java Control Panel.
2. Comment out these two lines at C:\Program Files (x86)\Java\jre1.8.0_251\lib\security\java.security and save with administrator privilege (important!).
jdk.jar.disabledAlgorithms=
jdk.tls.disabledAlgorithms=

Windows 10 1909 Version 10.0.18363.836
iDRAC Firmware Version 2.92 (Build 05)
java version "1.8.0_251"

Latest Solutions
Top Contributor