Storage, Drives & Media

Last reply by 10-01-2009 Unsolved
Start a Discussion
2 Bronze
2 Bronze
16966

Can't get desktop to recognize CD/DVD drive on boot

I've got an old Dimension 4100 that's still running pretty dang good... except for this:

I can't get it to recognize any media I place into my CD/DVD drive when booting. The floppy drive (hey, remember those?) works fine when a boot/ghost floppy is put in. Placing the CD version of the same thing is not recognized. I've updated my BIOS to the latest version. The boot sequence is as follows:

Floppy, ATAPI CDROM, IDE-HDD (taking the floppy out entirely makes no difference)

And, yes, it says "ATAPI", not IDE - could this be the problem? I would think the terms are interchangeable based on the age on my system.

Additional info: have a dual boot currently setup between Windows ME (yeh, another oldy, but moldy) and XP. The CD/DVD drives work fine in Windows. Discovered this problem when updating from Ghost 2003 to Acronis. Acronis uses CDs as their rescue media (but, it's not doing me any good as the desktop doesn't even see the CD). Have tried pretty much every procedure I've found at Dell support. Any help would be greatly appreciated.

Replies (12)
10 Diamond
791

Hi, CuJoe:

That's funny! I just reinstalled a Ghost image on my old 4100 (which is currently sitting in the basement).

ATAPI is the same thing as IDE, so that's

A couple ideas. First, disable both the FDD and HDD in the BIOS. Second, make sure you're using the top drive. Only the master device will boot. 

2 Bronze
2 Bronze
791

Hey, Osprey:

That is funny... you're messing with a restore on an old 4100 and that's what I'm also trying to do. I'd like to get into a side discussion about your experience with the 4100. I have found this machine to be exceptionally reliable and give Dell mucho thanks and kudos for the quality of this desktop.

Anyway to get back to the problem at hand: your suggestion of using only a specific drive to boot was very much in the ballpark. I discovered the solution from another post in the forum. Here's what I found out:

My top/master drive is a CD/DVD combo with a CD-RW on bottom/slave. I had to eliminate the CD/DVD drive and leave only the CD drive. So I resolved my problem by going into BIOS and disabling my CD/DVD drive and placing the boot CD into my CD-RW drive. And, that did the trick - the 4100 then recognized the media in the CD drive. When I was all done, I just went back into BIOS and re-enabled my CD/DVD drive.

Below is the link to the posting that helped me resolve this. Thanks to users "zerkked" and "The_Namek" (and osprey). I couldn't figure out how to get the ID(?) number of their particular responses, but they're at the very bottom of the page. There are other ways to get this to work, but I chose what was I believe is the easiest method.

http://en.community.dell.com/forums/p/19253627/19414567.aspx#19414570

(I'll "tag" this posting as a solution as soon as I figure out how)

10 Diamond
790

Way to go, Joe.

So here's the history. We got our 4100 back in 2001, I believe. It was the first new computer we ever bought and ran just great. I upgraded to XP and it was even better. Added RAM, a DVD burner and a USB 2.0 card. About three years ago, I inherited my son's 4550 and we gave the 4100 to our pastor for his kids to use. He's recently upgraded so I've just got the 4100 back. It still runs reasonably well, so I'm trying to figure out what to do with it.

It's funny that fixing computers is my hobby, since none of the Dells I've owned ever have any problems.

2 Bronze
2 Bronze
790

Hey fellas I'm having 4100 problems of my own in the boot from CD department. I got this system refurbed in 2001 and it has been solid (once I got ME off of it!), I upgrade drives and video cards on it but it keeps on keeping on.  However I recently decided to load a new version of XP on it and I can't boot from the CD Drive. I have two CD drives also, much like you. However, my BIOS does not have a selection to turn one or the other off. At least I don't think it does.  Where would that be?  My BIOS is old also, A07 or something and I think it went up to A10, so maybe I should start with that!

2 Bronze
2 Bronze
790

Well I downloaded A11 BIOS but I guess I have to install that with a floppy, and my floppy drive doesn't seem to work because it won't read any floppies I have.  So I'm kind of in a Catch 22 here.  Could I just unplug the DVD drive and hope it reads the CD drive on boot?

7 Thorium
790

CondoCowboy,

The 4100 system has IDE optical drives.  Both are on the
same cable.  The boot drive (when the system is set to boot
from a CD) is the one on the end of the cable.  The drive on
the end of the cable is the Master drive.  There is no BIOS
selection for which one to boot from. 

2 Bronze
2 Bronze
790

First off, I didn't need to update my BIOS to get this to work. I'm running on A06. Try the stuff below first and if you still want to upgrade to A11, go for it (you can also read the A11 "Release.txt" file to see what the new version gets you). I also didn't have to pull any cables off to get this to work.

Anyway, you may have 2 problems here. First, go into BIOS and make sure you have your boot sequence set up properly.

On the BOOT page, look at your "Boot Devices" and make sure they're set up as follows:
1st Boot Device    [Floppy]
2nd Boot Device    [ATAPI CDROM]
3rd Boot Device    [IDE-HDD]

If yours currently isn't showing the "Floppy" drive or it's after the HDD, that's why you're having problems booting from the floppy (you can take/keep the floppy out if you want, but you might want to make sure it works first).

Now, the place to disable/turn-off the CD drives is:

ADVANCED->IDE Configuration - select whichever drive you want out (temporarily) and change "Type" to "NONE". Then hit F10 to exit and save your changes. You can add it back later. Try this and let me know if you're successful.

2 Bronze
2 Bronze
790

Thanks for the replies.  on the BOOT page in my BIOS I do have it as you recommend:

1st Boot Device    [Floppy]
2nd Boot Device    [ATAPI CDROM]
3rd Boot Device    [IDE-HDD]

 

I actually even tried [ATAPI CDROM] to be the first thing to try to boot from. I have tried the disc in both the top drive (CD/DVD) and the bottom drive (CDRW).  I can't get it to boot from either.

What I haven't done yet is to go to the ADVANCED->IDE Configuration and de-select one of the drives.  I was looking for something like this earlier in the BIOS and couldn't find it.  I will try this first thing when I get home in a few hours if I can find that in the BIOS.

As far as updating the BIOS if my floppy doesn't work, would it be possible to copy the A11.exe BIOS to an empty HDD, and swap that drive in as the Master drive?  Wouldn't it try to boot up off this HDD just like it would try to boot off a floppy so I could update the BIOS?  I thought I could do that to update my BIOS without having to buy a floppy drive.

Thanks for all the help.

 

2 Bronze
2 Bronze
790

Still no luck on my end. I double checked the boot configuration in BIOS and it is floppy, cd, then HDD.   I even tried skipping floppy, so it was either CD then IDE.   I also disabled the CD drive that was the slave on the primary IDE.  So I just have one formatted IDE HDD that is secondary master, and one CD/DVD drive that is on the primary master.  Whenver I try to boot in this configuration I get the "Invalid Boot Diskette.  Insert BOOT diskette into A:"  This is crazy because I have told it to skip over the floppy when booting, and I can hear the CD spinning in the drive. It just can't get past this floppy drive somehow.

Any suggestions welcome.

Latest Solutions
Top Contributor