Highlighted
yurri
Bronze

Smart Response caching: HDD+SSD on Inspiron 15R SE, mSATA set to SRT, still no "Accelerate" button

Jump to solution

Hi,

This is probably a common problem which has been explained earlier but I didn't manage to find an answer here yet - I've found threads describing almost the same issue, but still not the same one.

So I have a fresh Inspiron 15R SE with pre-installed Windows 8, 1Tb HDD and 32Gb SSD on mSATA included for caching purposes. The problem is that as far as I can see, no acceleration/caching is actually happening with my SSD acting as just another drive.

In BIOS my mSATA operation mode is set to "Intel Smart Response Technology" which seems to be a correct option for caching. It looks like on this screenshot I took from another thread, in my system the option highlighted with yellow is selected:

But when I boot in Windows 8 and run Intel Rapid Storage Technology application, I see no "Acceleration" button / tab - as if my drive is not eligible or is in an incorrect mode. This is the screenshot of my Intel utility for you to see there is no option to enable caching:

If that is relevant, my SSD drive appears in my Disk Management console and is also accessible as a usual drive in Explorer and other file managers with a drive letter assigned (guess that indicates the acceleration is not in use).

There is also a hibernation partition (8Gb) on that drive, but the free space is still enough for caching (min 16Gb required, 20Gb left). Should I try disabling the hibernation? My hiberfil.sys file is on HDD though so that probably won't help. Here is a screenshot of another pre-installed Intel utility, Intel Rapid Start Technology Manager, if that could be relevant:

Any ideas are much appreciated, I was very keen on trying that additional drive and that was actually the main reason for me to choose that particular laptop model. It's a shame I can't use it for some reason.

Many thanks!

0 Kudos
6 Replies

Re: Smart Response caching: HDD+SSD on Inspiron 15R SE, mSATA set to SRT, still no "Accelerate" button

Jump to solution

Hi yurri,

It appears that SSD caching has been disabled as Link Power Management is active. I would suggest you to disable the Link Power Management in Performance tab of Intel Rapid Storage Technology console and restart the computer. Upon restart you may follow the steps below to verify the status of SSD and HDD association and reassociate them if needed :

If the issue persists, I would suggest you to uninstall the Intel Rapid Storage Technology utility from control panel, restart the computer. Once restarted, you may download Intel Rapid Storage Technology Driver from Here -> Type the Service Tag of computer -> Select Correct OS -> Expand Serial ATA -> Download Intel Rapid Storage Technology Driver. Follow the onscreen instructions to install the driver, restart the computer when prompted. Upon restart try to configure SSD caching by following steps given above.

Hope this helps.

Thanks & Regards,
Sundeep B
#iworkfordell
To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USA;India For helpful Dell Support Videos, you may click Here.

0 Kudos
yurri
Bronze

Re: Smart Response caching: HDD+SSD on Inspiron 15R SE, mSATA set to SRT, still no "Accelerate" button

Jump to solution

Hi Sundeep,

Thanks for your feedback.

I have tried disabling Link Power Management, but that didn't help. I also tried uninstalling and then re-installing the RST drivers and utility, and still I can't see the "Accelerate" button.

I have tried that with both unallocated space on my SSD and with an NTFS partition on it.

It still doesn't work. What else can I try?

0 Kudos
yurri
Bronze

Re: Smart Response caching: HDD+SSD on Inspiron 15R SE, mSATA set to SRT, still no "Accelerate" button

Jump to solution

I have found the answer. In order to enable acceleration there must be NO PARTITIONS on the SSD even if there is still enough unallocated space.

So the Rapid Start Technology partition my laptop came with was preventing Rapid Storage from accelerating.

After I have removed all the partitions from the drive, it worked.

If you still need the partition for Rapid Start or for other purposes you can specify less space for acceleration when setting it up and create your partition afterwards.

Re: Smart Response caching: HDD+SSD on Inspiron 15R SE, mSATA set to SRT, still no "Accelerate" button

Jump to solution

Hi yurri,

Glad the issue is fixed. Thank you for sharing the knowledge; appreciate it.

Do reply if you have any further questions. I would be happy to assist you.

Thanks & Regards,
Sundeep B
#iworkfordell
To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USA;India For helpful Dell Support Videos, you may click Here.

0 Kudos
Shane.S
Bronze

RE: Smart Response caching: HDD+SSD on Inspiron 15R SE, mSATA set to SRT, still no "Accelerate" button

Jump to solution

Does the SATA controller have to be on RAID? I have it on ACHI and I can't get my SSD to work As a cache drive.

0 Kudos
ramparc
Copper

RE: Smart Response caching: HDD+SSD on Inspiron 15R SE, mSATA set to SRT, still no "Accelerate" button

Jump to solution

Lets make sure the SSD is exactly as we want it

  1. Make sure your BIOS is set to “Intel Rapid Response Technology” as the SATA/Disk Operation mode
  2. If you don’t already have the Intel Rapid Storage Technology software installed then you will need to download “SetupRST.exe” software from Intel’s website chose the latest drive in the search should be 12.9 or higher.
  3. Chose the SetupRST.exe download.
  4. Install and run the software, you will have to reboot after the install.
  5. Next we need to check to make sure our SSD is not configured at all in Intel Rapid Storage Manager software
  6. Open the Intel Rapid Storage Manager software and go to the acceleration section and make sure you reset the SSD to available. You should see your entire SSD listed in the diagram on the right top with no partitions. Note, you might not have to do this, the option will only be there if you had a configuration from before.
  7. You will receive an dialog about resetting the cache to available. Just say yes.
  8. Once we know the SSD is clean of any Intel partitions we need to re-initialize it.
  9. Open a command prompt and type “diskpart”
  10. Type “list disk”
  11. Look at the list of disks one of them will be your SSD (You can tell by looking at the size, for me its 32 GB)
  12. You will want to select the disk by its disk number that is to the left.
  13. Type “select disk 1″ (for my case it’s disk 1 for you it could be a different number)
  14. You should get a response that “Disk 1 is now the selected disk”
  15. To verify you have the right disk type “list disk” and you should see a “*” in the left margin beside your SSD to show it is the one that is selected. Make sure you do this to makes sure you have the right disk selected because the next step will wipe the device!!
  16. If you are sure you have the correct disk selected type “clean”
  17. You should receive a message that “DiskPart succeeded in cleaning the disk.”
  18. What this did was make sure the that SSD is set to uninitialized and no partitions exist on it.
  19. You can close DiskPart window
  20. Open Disk Management to initialize the disk. You can open it from Control Panel > Administrative Tools
  21. You should get a popup stating that you need to initialize the disk first before you can use it. If not you can right click on the label for the disk it and chose Initialize Disk.
  22. Make sure you select MBR (Master Boot Record) as the style of partition and click okay.
  23. You should now see your SSD listed in Disk Manager

 

Setting up Smart Response

  1. In Disk Manager right click on the very last partition on the HDD (Not the SSD but the HDD) and chose “Shrink Volume…” from the menu
  2. You can shrink the volume by any size from what I have read but I normally do it by 1 GB.
  3. Seclect “Shrink”
  4. Once you have shrunk the partition you can Right click on it again and chose “Extend Volume”.
  5. You will then use all the space up to extend it to the end of the drive again.
  6. You can then run the Intel Rapid Storage Technology software and go to the “Accelerate” section
  7. click “Enable Acceleration”
  8. In the dialog that comes up it will ask how big you want your Caching memory to be. For me I have a 32 GB SSD and 8 GB of memory so I need 8 GB for my Rapid Start partition so just subtract that from the total size of the SSD to find out how big you can make your Memory Cache. So in my case I made a  custom 21.8 GB partition. Worse case you get it wrong you can come back and play with the numbers to make it right.
  9. I chose maximized mode as I want the best speed form my machine! Make sure you read the warning for your to make sure this is the setting for you! This option is a your choice.
  10. You should then see that your disk is accelerated and everything is marked as working and in good health in the software.

 

Setting up Rapid Start

Now that the Smart Response is up and running we can create our Rapid Start Partition. Intel recommends making this partition the same size or more as the amount of memory that is installed in your computer.  They recommend just making a 8192 GB partition as this will always work for all configurations but you can play to see what works best for you!

  1. Open a command prompt and run “Diskpart”
  2. Type “list disk” you should see a list of disks. Note that your SSD will now show up as a smaller disk as the step before has created a partition for memory cache. Remember the Disk Number that is listed beside it.
  3. Select the disk by typing “select disk 1″ for me it’s disk 1 for you it could be a different number
  4. Verify that you have selected the correct disk by typing “list disk” and you will see an “*” beside the disk you have selected
  5. Now we are going to create the partition type “create partition primary size=8192″
  6. You should see a success message “DiskPart succeeded in creating the specified partition”
  7. We need to now set the ID of the disk “set id=84 override”
  8. Again you should see a message that  it succeeded, if you get an error “The specified type is not in the correct format.” then this is because when you initialized the disk you did not set it to MBR you set it to “GPT” you will have to go back to the beginning and follow each set and make sure you set it to a MBR when you initialize the SSD.
  9. Once you are done you can reboot your computer for the EFI or BIOS to see the new partition.
  10. You can enter your setup to see that Intel Rapid Start is now enabled. Once you have verified this you can go back into Windows.
  11. Download and install the Rapid Start Software from Intel’s site
  12. You should receive no error now when installing
  13. You are finished!!!!!

0 Kudos