Highlighted
physikos
1 Copper

RE: XPS8700 32Gb SATA SSD

Jump to solution

Bump

0 Kudos
physikos
1 Copper

RE: XPS8700 32Gb SATA SSD

Jump to solution

What is going on here? Can none of you explain the steps that Roverduck used to fix his system?

Bumped again..

0 Kudos
physikos
1 Copper

RE: XPS8700 32Gb SATA SSD

Jump to solution

Bumping again for answer.

0 Kudos
Dee Aitchess
1 Copper

RE: XPS8700 32Gb SATA SSD

Jump to solution

GDay physikos

I found IRST showing the SSD as incompatible and the machine slowed right down so the HDD wasn't being cached.

This is how I fixed the problem on my XPS8700

The BIOS showed the SSD was still there but Windows 10 couldn't see it, neither Disk Management nor the command line utility Diskpart.  I read somewhere that the BIOS Secure Boot option was incompatible with IRST caching so I turned it off in the BIOS and restarted.  Bingo! The Intel BIOS utility came up during the boot sequence and I was able to use it to remove the SSD, this is a different utility to the normal BIOS options.  This is not risky to your data or OS as it is all on your HDD.  After this Windows Disk management showed the SSD but it was uninitialised.  Leave it that way, don't format it or give it a letter, that allows you to use it as a drive on its own but not as a cache.

After restarting IRST showed the SSD with a green flag and it was no longer incompatible.  But caching still didn't work.  There was no option to accelerate the HDD in the performance button of IRST.  So I re-checked the BIOS and found that the disk controller had somehow got into AHCI mode, it has to be in RAID mode so I changed it to that and re-started.

The boot threw an error so I reverted to AHCI in the BIOS.  Back in windows I used msconfig to set windows to start in safe mode with networking, restarted and reset the BIOS to RAID.  Once in safe mode I checked the disk drivers and found I was using RAID drivers, so I updated them and restarted in normal mode this time without error.

At this stage I found the Intel RST process was not running and IRST still didn't allow me to accelerate the drive.  So I uninstalled IRST and reinstalled the original version from Dell.  After another restart IRST was running OK and gave me the option to accelerate the HDD.  At this stage all was well except during boot the Intel BIOS utility came up each time.  It was now showing the HDD as non RAID and the SSD as a cache.  I didn't want this showing as somebody might incautiously use it to change something so I re-enabled Secure Boot in the BIOS and the Intel utility no longer showed up during the boot sequence.  IRST still works and the HDD is now cached as it should be.  It seems the secure boot option doesn't actually interfere with caching but hides the utility that lets you clean up the incompatible SSD.

Some of the suggestions around to fix this problem such as creating the SSD as a hibernation partition and leaving the BIOS disk controller in AHCI mode are quite wrong in my experience.  I hope your fix runs smoother than mine as this took about 6 hours to figure out with lots of red herrings about other issues with IRST and Windows. 

 

Good luck

Syncretic

0 Kudos
Dee Aitchess
1 Copper

RE: XPS8700 32Gb SATA SSD

Jump to solution

GDay Roverduck

 

You may have cleaned up the SSD so that it no longer throws a warning but if the BIOS has the disk controller set to AHCI the SSD is not caching.  Look at the icon for the SSD in RST and compare with the examples in RST help, I think you will find it is just an uninitialised drive that is not caching your HDD, the icons are different.  Can you see acceleration options in RST?  If not the drive is not caching.  You have to see the acceleration options and the choice of which HDD to cache.

0 Kudos