SupportAssist for PCs

Last reply by 10-12-2022 Solved
Start a Discussion
3 Silver
19941

SA, can't get past loading PC Optimization Tools screen

I know this has been exhausted, but it isn't if I still can't get what used to work a week ago but won't now, SupportAssist. If I tell you that in two days, I've read what I would say is almost literally every article and tried it all, I am being honest with you. Things that you'd never dream of doing I have done. And no, no major changes except as a result of this, like doing a Windows Update. I'm current now. I am stumped! I've removed every file suggested to be removed, including leftover files via Revo. I've uninstalled, rebooted, looked for files that shouldn't be there and deleted them, regedit search and remove, changed settings in Services, just everything.
I cannot get past the splash screen below. PLEASE, help me. I am 100% stumped. Oh, and I renamed the name of the logo in Resources, with and without the .png, and I deleted and reinstalled a million times. And no, I don't have Malwarebytes installed.

Thanks for any ideas you can offer.

Dell Latitude E7440
Windows 10 64x

Stuck here ...Stuck here ...

Labels (4)
Replies (53)
2232

@ctg 

I really don't know. I'm not in on that. All I know is that my SA is v 3.4.5.

It is supposed to be offered, if I'm not mistaken, this coming week. Fingers crossed.

6827

@JanPutBe 

I am a female, if you were directing that last comment to me. My first name is Lori. 

17909

Well, the wonderful tech I've been working with, who did this of his own free time, got the new version to me today (it's been released) and it works. It's version 3.5.0.

Please see if you can get it at the website now. I'm sure it will correct your issues too.

I want to, for now, sing his praises without naming him. Don't know if I can say who he is. But he spent a lot of time with me, remotely taking over my computer, trying everything he could to get SA to work and collecting logs to help them figure out what was wrong so they could make this new version effective. He was successful, and I really appreciate the time spent to make this work.

Let me know if you were able to get the new download and if it solved your problems too. Good luck!

17888

Thank you for persisting with this quest.  I just downloaded Dell Support Assist Version 3.5.0 and it worked for me as well.  Success!

6757

@Penybont 

I'm so happy for you! And you're so welcome. I owe a lot of the help I got to the Dell tech who has helped me out. Just paying it forward. Enjoy! 

6731

I wish this was the case for me.... completely uninstalled and reinstalled 3.5.0 and I still can't get past the start screen.

10816

Kudos to Dell Loaded version 3.5 and all seems to work fine..

6695

@SD314 

I'm sorry to hear that. You can try the Revo uninstaller app. It is great because it finds files left behind after the uninstall of a program (and more) left behind on your computer and gives you the option to delete them. I use the advanced button and delete everything it finds. There were so many of them when I uninstalled the nonworking SupportAssist from my computer.

Wishing you luck.

10727

Version 3.5.0 solved the problem.

3 Silver
11030

Whenever I try and load SA (SupportAssist) it just spins and spins then shows the "unexpected error" message and tell you to reboot and try again later. (not helpful)

I did some more digging this morning and finally found the culprit in my case. In the Killer Control Center, if "Killer DoubleShot Pro" is enabled, then SA won't start. As soon as I disabled it, SA starts fine. This was repeatable. Since I use Killer DoubleShot Pro, I consider this a problem/bug and I'd like someone to take a look. @jbilinski Can you pass this up the chain?

Latest Solutions
Top Contributor