Highlighted
CoS2
1 Nickel

Dell Support Assist, latest version not working

Dell SupportAssist versions 3.1.30.0 (Microsoft Store) and 3.1.0.142 (Dell) don't function properly.

Up to this latest Dell version, SupportAssist functioned properly on my Optiplex 960 SFF with Windows 10 Pro (32 bit).
I especially like the "optimize" function.
When I started SupportAssist yesterday it first ran an update (146 MB installed) after which it did not function anymore: upon starting it it very shortly shows a blue window with a wrench, sometimes not noticeable at all.

Note 1: I saw this recently on another family Optiplex 960 SFF with Windows 10 Pro (32 bit) where I also have not yet been able to resolve it.

So I completely uninstalled the Dell version, restarted the PC and installed the Microsoft Store version (50.9 MB installed). Exactly the same behaviour as with the Dell version.
Uninstalled the app, restarted the PC and went to the US Dell site.
There I had it detect my PC and for that it needed SupportAssist which was not installed. I agreed to the terms and conditions and started the download and had SupportAssist installed.
But it failed to continue and detect my PC.
I went back to detect my PC and again it came with a message that SupportAssist was not installed.
So again I agreed to the terms and conditions and started the download but running it generated a Dutch language message that the installation had been cancelled because the latest version of SupportAssist was already installed.
I tried this several times with PC restarts in between and everything else I could think of.
Note 2: sometime during the installation process the SupportAssist shortcut appears on the Desktop but lateron it disappears.
Note 3: on the other family PC I once saw during the installation the Dell folder appear that used to be in the Start menu (containing a shortcut SupportAssist and a folder SupportAssist with the Desktop Configuration settings) and then I could run SupportAssist once. Thereafter the folder was gone and it behaved as described earlier.

But there are more strange things.
When I have the Dutch DellEMC site (logged in) detect my System configuration, that functions flawlessly: it finds SupportAssist, SupportAssist detects my PC and finds my operating system to be Microsoft Windows 10 Pro etc.
But when I select Diagnostics on the Dutch site, it generates a message that it cannot do that because it functions only for operating systems Windows 10, Windows 8.1 and Windows 7 (so what's the problem?). On the US site the System configuration cannot be detected because of the SupportAssist problem.


So the responses of the Dell Support sites seem not to be identical making it difficult to get hold of the problem.

Maybe the apps are fine but there is a communications problem with the Dell servers (the previous SupportAssist shortcut pointed to the SupportAssist Installer, so it probably first starts with checking for updates).

Does anyone know what's going on and know how to fix this?

0 Kudos
6 Replies
CoS2
1 Nickel

Re: Dell Support Assist, latest version not working

Addition 1: When I look for System configuration data, I refresh it as the data shown may be data having been stored earlier.

0 Kudos
Moderator
Moderator

Re: Dell Support Assist, latest version not working

Thanks for the post, I haven’t used the dellemc site. Ideally the SA versions for MS Store and Dell web-site should be the same. There is a reason why MS Store shows a different version but don’t know off the top of my head, either way the same version number will display in the control panel.

When I have issues with upgrades or installations I’ll go back to a clean install. The basic clean install would consist of:

Under Control Panel, the initial install will show about 10 MB, in the end after a successful install for version 3.1.0.142 should be 149 MB, could be higher.

We’ve also used the Use Microsoft tool to uninstall as well if having issues - https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being-installed...

Services used and All should be running are:

Dell Data Vault Collector

Dell Data Vault Processor

Dell Data Vault Service API

Dell Hardware Support

Dell SupportAssist

If the following doesn’t work then something else may be going on and would need to view the Event Logs and SupportAssist logs but it may be best to contact support so they can remote into the system.

C:\ProgramData\SupportAssist\Client\Agent\logs\ApplicationLogs

If would be helpful to also have the event logs to view the errors on install

Event logs are available at –

Open Event Viewer -

Windows Logs - Application

Event Source = msiinstaller and SupportAssistAgent 

DELL-Joe B
Social Media and Community Professional
#iwork4Dell

0 Kudos
CoS2
1 Nickel

Re: Dell Support Assist, latest version not working

Hi Joe B,

Thanks for your elaborated advice.
I tried all possibilities, unfortunately none of them helped: when I launch the program the blue window with the SupportAssist wrench very shortly shows.
Note: Installing SupportAssist via the Dell EMC site -when it finds that I need to install it- is no longer possible as it blocks the tic mark (red stop sign) that I have read and agree to all terms and conditions. There are however notable differences between the Microsoft Store installation and your Dell links.

Additionally the Windows System log shows an interesting event each time I launch the service.

When Dell SupportAssist for PCs is installed from the Microsoft Store:
- its installed size is 51.0 MB (Settings\Apps & Features);
- the 5 services you mentioned are not available;
- the 3 folders/files you mentioned are not present;
- it is not found by the Microsoft tool to install/uninstall.
This may explain the difference in installed size for the different sources.

When Dell SupportAssist is installed from either of the Dell sources after the version from the Microsoft Store has been removed:
- its installed size is 146 MB for Dell SupportAssist and also 16.0KB for an additional SupportAssist Dell Inc app;
- the 5 services you mentioned are available and running;
- the 3 folders/files you mentioned are present;
- it is found by the Microsoft tool to address install/uninstall problems.

Each time I launch the service it generates a DistributedCOM error with event ID 10010 as shown below:
Note: I deleted my Security UserID from this listing.

Log Name: System
Source: Microsoft-Windows-DistributedCOM
Date: 13-2-2019 17:05:19
Event ID: 10010
Task Category: None
Level: Error
Keywords: Classic
User: OPTIPLEX-960-SF\Gebruiker
Computer: Optiplex-960-SFF
Description:
The server DellInc.DellSupportAssistforPCs_3.1.30.0_x86__htrsf667h5kn2!App did not register with DCOM within the required timeout.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
<EventID Qualifiers="0">10010</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8080000000000000</Keywords>
<TimeCreated SystemTime="2019-02-13T16:05:19.645275600Z" />
<EventRecordID>6897</EventRecordID>
<Correlation />
<Execution ProcessID="996" ThreadID="6332" />
<Channel>System</Channel>
<Computer>Optiplex-960-SFF</Computer>
<Security UserID="Deleted for privacy reasons" />
</System>
<EventData>
<Data Name="param1">DellInc.DellSupportAssistforPCs_3.1.30.0_x86__htrsf667h5kn2!App</Data>
</EventData>
</Event>

I also have the SupportAssist log available but can't include it in this posting because the total will exceed 20,000 characters.

Does this help?

Note: Before started this posting, I contacted Dell Support and gave them my service tag # but they said they could not support my system.

That is a bit strange because SupportAssist supports Optiplex PCs with Windows 10.

Thank you again,

Kind Regards,

CoS2

 

 

0 Kudos
Moderator
Moderator

Re: Dell Support Assist, latest version not working

I'm not familiar with the DistributedCOM error

Could you try to open a cmd prompt as Administrator, navigate to the appropriate SupportAssist install path bin folder (example: “C:\Program Files\Dell\SupportAssistAgent\bin”)

type

cd\

cd C:\Program Files\Dell\SupportAssistAgent\bin

and execute command “SupportAssistUI.exe Launch”, no quotes

Did you look in Event Viewer with these event source

Open Event Viewer -

Windows Logs - Application

Filter on Event Source = msiinstaller and SupportAssistAgent

Are there any error messages in the logs

C:\ProgramData\SupportAssist\Client\Agent\logs\ApplicationLogs

Search for ERROR, call caps

DELL-Joe B
Social Media and Community Professional
#iwork4Dell

0 Kudos
CoS2
1 Nickel

Re: Dell Support Assist, latest version not working

Hi Joe B,

Thanks for your rapid response.

Unfortunately I will not be at home tomorrow and need tonight to prepare for that so I can't gather all data right now.

But you hit the nail on the head using the cmd prompt to start SupportAssist, that does the job!

But it only works using the cmd prompt, when I launch it directly from the File Explorer (even as Administrator), as I have tried many times before, it does not work.

Anyway, it looks promising.

I will upload the other data on Friday when I am back.

Kind Regards,

CoS2

 

0 Kudos
CoS2
1 Nickel

Re: Dell Support Assist, latest version not working

Hi Joe B,

Just uploaded the requested data, answered your private mail and included my findings (for what they are worth..).

Seems there is a relation between 2 interesting items in the Windows System Log and the SupportAssist Log.

If you need more information, please let me know.

Regards,

CoS2

0 Kudos