Highlighted
2 Bronze

Venue 8 Pro upgraded to Windows 10 .. Camera does not work

Jump to solution

I wanted to take a photo today and opened the Camera app. I received an error message .. "Something went wrong. Make sure your camera is connected and not being used by another app."

I checked the Device Manager and found no camera listed, but I did find an "Imaging Device" - listed as working. "Intel (R) Imaging Signal Processor 2400"  and under "System Devices" I found "Camera Sensor MT9M114" and "Camera Sensor OV5693".

I looked all over the Dell Support site and could find no driver for a camera.

Also, when I was at the Dell site, I tried the "Run a quick test for common hardware problems"  and checked "Camera". At the end of the test, I received this "We were unable to find the selected device" and it went on to suggest I look for driver updates. I did check and found nothing for a camera.

0 Kudos
3 Solutions

Accepted Solutions
Highlighted
1 Copper

RE: Venue 8 Pro upgraded to Windows 10 .. Camera does not work

Jump to solution

The best way to fix this is to install the Atom Chipset Drivers listed on the Dell Support site.  They are the newer ones listed as being compatible with Windows 10.  This will overwrite all of the Intel drivers with ones that work with the DVP, including the camera.

Once you have done that, there will be a DRIVERS folder on the C: drive that contains the expanded drivers from that package.  If you need to go back in and update a certain driver (due to an errant Windows Update) you can manually switch to the original driver from Device Manager and selecting "Have Disk."

View solution in original post

Highlighted
1 Copper

RE: Venue 8 Pro upgraded to Windows 10 .. Camera does not work

Jump to solution

well, my camera's are finally working.  I think I found the key step, or at least this is what worked for me after dozens of trials.  I had to uninstall teh driver for the webcamera and while doing so I said delete, using the device manager.  I beleive I tried this a bunch of times, but maybe I didn't.  Next, and probablly the necessary step, unless the driver failed overwriting (which would make the deleting of the driver important), I rebooted.  Then I installed the dell driver pack again for the intel chipset.  Then rebooted again.  and now I can see the cameras.

View solution in original post

Highlighted
1 Copper

RE: Venue 8 Pro upgraded to Windows 10 .. Camera does not work

Jump to solution

Hi,

1- Install Intel Atom Z3000 Series Driver from www.dell.com/.../advanced

2- Go to Device Manager, then find "Imaging Devices" right click on "Intel(R) Imaging Signal Processor 2400" and click on Update driver Software to Update your driver to this Version 603.9600.1948.31252

View solution in original post

23 Replies
Highlighted
2 Bronze

RE: Venue 8 Pro upgraded to Windows 10 .. Camera does not work

Jump to solution

I still have this issue and need to bump it to the top again. Sorry for the bump, but I hope to get an answer soon.

0 Kudos
Highlighted
1 Copper

RE: Venue 8 Pro upgraded to Windows 10 .. Camera does not work

Jump to solution

when I upgraded to win 10 I also had the same  problem , what I did is this: under device manager I double clicked camera (imaging device), clicked driver tab, update driver, I let the computer search for it and it found it on the hard drive and installed it. hope it works for you

0 Kudos
Highlighted
2 Bronze

RE: Venue 8 Pro upgraded to Windows 10 .. Camera does not work

Jump to solution

Thanks, Marc, for your excellent advice, but it does not work for me, I still get the error message "Something went wrong. Make sure your camera is connected and not being used by another app."

I'm not quite sure how to see if another app is using the camera, but I doubt that is the case as this problem occurs immediately after boot. In addition, going into the Task Manager for App History, I see it has used no memory at all

By the way, in the Device Manager > Imaging devices, the device is called "Intel(R) AVStream Camera". Is this the correct device?

0 Kudos
Highlighted
2 Iron

RE: Venue 8 Pro upgraded to Windows 10 .. Camera does not work

Jump to solution

I got that driver when I did a Driver "Check for updates" on what was the "Intel (R) Imaging Signal Processor 2400". It did not work. Through the repeated deletion of the AVStream and subsequent automatic installs of 2400 along with the Intel Atom Z3000 chipset drivers, my camera started working. The 2400 driver dates in 2013, details in this discussion.

0 Kudos
Highlighted
2 Bronze

RE: Venue 8 Pro upgraded to Windows 10 .. Camera does not work

Jump to solution

More information...

Going into the Device Manager a little further and clicking on the Properties of the Camera, under the Events Tab, I find the latest event  to be 8/9/2015. It's description "Device install requested" with the following information: "Device DISPLAY\INTOF38\4&7BE4425&0&UID134968requires further installation"

I have no idea on how to do the further installation. Any ideas?

0 Kudos
Highlighted
1 Copper

RE: Venue 8 Pro upgraded to Windows 10 .. Camera does not work

Jump to solution

The best way to fix this is to install the Atom Chipset Drivers listed on the Dell Support site.  They are the newer ones listed as being compatible with Windows 10.  This will overwrite all of the Intel drivers with ones that work with the DVP, including the camera.

Once you have done that, there will be a DRIVERS folder on the C: drive that contains the expanded drivers from that package.  If you need to go back in and update a certain driver (due to an errant Windows Update) you can manually switch to the original driver from Device Manager and selecting "Have Disk."

View solution in original post

Highlighted
1 Copper

RE: Venue 8 Pro upgraded to Windows 10 .. Camera does not work

Jump to solution

Thanks 1,000 times. My cam was just dark when I reinstalled the driver then the black screen messages started coming up. I've been on this every day for a week...nothing works. It happened after I REloaded windows 10 (venue 5055 came with 10).

Dell would do nothing. Intel said they could do nothing because they sold it to Dell so Dell had responsibility.

The Dell "pay for service" said they couldn't work on it. Dell used to be best for help BUT CERTAINALY NO MORE!!

Loaded the chipset and the camera came right back up fine.

0 Kudos
Highlighted
2 Bronze

RE: Venue 8 Pro upgraded to Windows 10 .. Camera does not work

Jump to solution

Thanks, Jimmy, but I still have the same problem "Something went wrong", so I suspect that it is not a driver problem. 

However, going back into the driver properties and the latest event, under information at teh end of a long Driver Management report, I see that the camera driver status is listed as "0x0". I do not know what that means, but suspect it is telling me that the camera doesn't work.

0 Kudos
Highlighted
1 Copper

RE: Venue 8 Pro upgraded to Windows 10 .. Camera does not work

Jump to solution

This is a driver issue.  The crash I get after upgrading my Venue 8 Pro to 10 is this new BSOD crash collector with the error code of ATTEMPTED EXECUTE OF NOEXECUTE MEMORY. I updated the driver and now have the  intel  driver version 20.10154.5740.705, released on 7/4/2015.  Now the system has an entry of Intel AVStream Camera under the Imagine Devices, but no application sees it.

Dell - please figure out what's wrong with the camera drivers and issue a fix.

0 Kudos