Vostro

Last reply by 08-31-2019 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Vostro 1720 touchpad won't scroll--can't install driver

Hi all,

Since reformatting and reinstalling Windows 10 (v.1903), my old Vostro 1720 touchpad won't scroll any more.

I can't install this driver either, it failed:

https://www.dell.com/support/home/ie/en/iebsdt1/drivers/driversdetails?driverid=t94p1

In my Device Manager no touchpad/mousepad is listed under 'Mice and other pointing devices.'

When I went through the installation of the above driver, it seemed to install, only to be followed by an error message saying it had failed.

Any tips (apart form buying a new laptop)?

John

 

Labels (4)
Replies (9)

...and (further to my previous reply) I just checked on this Lenovo Win 10 laptop, with a fully working touchpad, and the touchpad isn't listed in its Device Manager either!

 

Fair enough.

I can point and click on it, and drag things (holding down the left touchpad button).

I find it odd that the Touchpad doesn't show up as a device in the device manager.

John

@Johniwhite 

This has got me stumped???

Since it worked before, then reinstalling W10 should not have had any effect???

And it should not be the "ZIF" connector under the keyboard???

I do not know of any setting in the BIOS that would disable the "TouchPad"

Sorry but I just don't know where to go from here???

Regards,

U2

There is indeed.

Can't see anything useful in there though.

@Johniwhite 

Go to "Settings" then "Devices"

Is there a "Tab" for "TouchPad" ???

Regards,

U2

EDIT: Until the "eClerx" team approves the image only you can see it.

Yep, as I said earlier, I checked 'Mice and other devices'. I even stumbled across the 'show hidden devices' option. No sign of the touchpad.

I've disabled lots of 'services' on this PC, could any of those be related to the touchpad, and if so, could that make it disappear from the device manager?

Annotation 2019-08-31 154023.png

@Johniwhite 

Did you check under "Mice and other Pointing Devices" 

In "Device Manager" go up to the "View" tab and click on "Show Hidden Devices"

Regards,

U2

Hi again,

(you must be a legend here)

I tried to install that driver and got:

'Alps touchpad cannot be installed on Windows. Check for an updated version' (or something like that)

As for the Hardware ID, I can't find it because the touchpad isn't listed in the Device Manager (weird).

Running Windows 10 v.1903, 64bit.

Hi again @Johniwhite 

Let's start with giving this one a try???

https://www.dell.com/support/home/us/en/04/drivers/driversdetails?driverid=r252187&oscode=w764&produ...

If that does not work then post the "Hardware ID" of the touchpad???

https://m.wikihow.com/Find-Hardware-ID

Regards,

U2

Top Contributor
Latest Solutions