Don Stiletto
1 Copper

Dell XPS L702X - unable to deactivate touchpad

Although there are already quite a few drivers for Windows 8, I can't find an updated version fo the touchpad-driver /-software. I don't want to seem impatient, I'd just like to know if DELL is aware of this and if an ipdated version is planned.

Thanks and regards

0 Kudos
19 Replies
Moderator
Moderator

Re: Dell XPS L702X - unable to deactivate touchpad

Hi Don Stiletto,

Press ‘Fn’ + ‘F3’ key to disable or enable the Touchpad on your computer. You can download the touchpad drivers for your system from the link below.

http://dell.to/PznzIw

Please reply for any queries.

0 Kudos
Don Stiletto
1 Copper

Re: Dell XPS L702X - unable to deactivate touchpad

Hi DELL-Ravi Ch,

and thanks for the quick reply.

It probably didn't come out clearly in my opening: with Win 7 it works this way, the LED indicates it's deactivated and it actually IS deactivated.

With Win 8 it also indicates the touchpad is deactivated, but it simply isn't.

It's just a bit troublesome when writing and accidentally touching the touchpad. I had hoped to also be able to deactivate it in BIOS, but wasn't able to find an option there.

So I guess that a  driver- / software-update will solve this issue sometime soon.

Thanks again and best regards

0 Kudos
kirkd
5 Rhenium

Re: Dell XPS L702X - unable to deactivate touchpad

Don't hold your breath waiting for a Dell upgrade. Go to the site of whatever pad you have and look for newer drivers, These drivers often work in most computer brands. A newer driver may have better controls for pad sensitivity.

An easy answer is to download the freebe, TouchFreeze. It works very well, shutting off the pad as soon as you begin typing.

XPS M1530, Win 10 CU Pro 32-bit
Inspiron E1705, Win 10 CU Pro 32-bit
Dimension 9100, Win 10 AU Pro 32 bit
Inspiron 660, Win 10 CU 64 bit
Inspiron 3668, Win 10 CU 64 bit
Asus T100 Tablet, Windows 10 CU 32 bit

0 Kudos
Not applicable

Re: Dell XPS L702X - unable to deactivate touchpad

Sadly no .. it doesn't work like that.

Dell uses a propriotary WMI code to detect when touchpad has to be disabled (when you press Fn+F3). This code is declared in ACPI tables so it's hardcoded by Dell and Synaptics drivers have no idea how to treat it.. same with the LED action.

It used to work with Dell's original driver in Windows 7, however if you were to install the driver from Synaptics (I hated Dell's scrolling implementation so I tried installing the original driver) then only LED gets activated above the touchpad but the cursor still moves. Now with new Dell drivers in Windows 8 touchpad cannot be disabled from Fn+F3, LED come one but the cursor remains active. The only option to disable it would be going into the driver by having the mouse connected and setting the option to off:

I must say however that new driver at least support Windows 8 related function such as calling for charm bars and such .. also palm detection is superb, the cursor hardly moves when you type.

0 Kudos
Don Stiletto
1 Copper

Re: Dell XPS L702X - unable to deactivate touchpad

Dear KirkD, until reading Dolnor's reply I was hopeful that your tip might be what I was looking for. 😞

Dear Dolnor: I didn't even have this settings-window in Win 7 (or at least never saw it or had it open...). Is your screenshot one of the Windows 7 - application or already Windows 8? If the latter already, could you please be so kind to post a download-link?

Thanks in advance and best regards

0 Kudos
Not applicable

Re: Dell XPS L702X - unable to deactivate touchpad

In Windows 8, much like in Windows 7 you go to Control Panel > Mouse and the first tab you see is Dell Toucpad

http://puu.sh/1o7Yb

There's a huge toucphad button on this tab which when pressed opens up the driver's GUI.

In windows 7 the driver looked like this:

http://puu.sh/1o7Xr

In Windows 8 they have upgraded the GUI to a more sleek one that I had posted above and I quite like it actually.

But .. the Fn+F3 combination doesn't work with it .. only way to disable touchpad is choosing that On/Off feature you  see on the screenshot.

There's no driver posted for our machines (I have a Vostro 3450) so I had to look up a driver from another machine - Inspiron 5423.

Also while attempting to provide you the link I have just stumbled upon a driver of same version and same name over at Dell's support which has these changes noted in the Enchantments section:

Fix Fn+Fn3 cannot disable touchpad

Here is the link for your convenience:

www.dell.com/.../inspiron-14z-5423

I will be installing this shortly to see if it indeed fixes the Fn+F3 issue!

0 Kudos
Not applicable

Re: Dell XPS L702X - unable to deactivate touchpad

Sadly it didn't fix the issue. Probably because the driver is not meant for my (and your) laptop in the firs place so the WMI code it expect to disable the surface is somewhat different from ours, hence it doesn't work..

But what else Dell expects me to use if they haven't released anything new in term of Input drivers for my machine .. and yours equally supporting Windows 8 ? Pathetic..

0 Kudos
Don Stiletto
1 Copper

Re: Dell XPS L702X - unable to deactivate touchpad

Thanks for the link, although you're right that it doesn't fix the "Fn + F3"-issue. Nonetheless, I can at least now deactivate the touchpad, even if it's the longer and less comfortable way. That makes waiting for an update easier.

Best regards

0 Kudos
Not applicable

Re: Dell XPS L702X - unable to deactivate touchpad

Turns out the touchpad's PID (product id) for my Vostro  is missing from this driver's ini, so it explains why it's not supported properly (ie 3-finger gestures are not functional and no disable feature from the hotkey)  because driver has no idea how to treat devices with IDs of

http://puu.sh/1ox4J

Will try adding this ID into the driver's config file .. maybe this will enable the Fn+F3 feature.

0 Kudos