Highlighted
N4TT
1 Copper

XPS 15 9560 Laptop not detecting windows installation, windows installer not detecting drives.

Jump to solution

Hi,

I am having trouble with my windows installation after attempting to install windows 10 a second time on the same machine, but different partition.

I have used a bootable USB device with the windows 10 installation (created with the same machine and the same settings for OS).

After pressing F12 and selecting the USB as the boot device, i started the installation process and got to the stage where you select which drive / partition to install windows. But the list only contained the USB device i used to start the installation process, and the SSD did not appear when tried to refresh / reload drives (or unchecked the "hide incompatible drives" checkbox). 

After canceling the installation process, i was met with the following message when rebooting windows:

"Your PC/Device needs to be repaired.

The Boot Configuration Data file is missing some required information.

File: \BCD

Error code: 0x0000034

You'll need to use recovery tools. If you dont have..."

Before the error occured:

I have tried many different things BEFORE i got to the step above where I was able to start the USB stick and consequently ended up with the error.

However when the error occured the BIOS was reset to factory settings and i was able to log in to windows (and listen to spotify for an hour or so) before i tried the install that gave the error:

  • I tried installing windows 10 with a stick created from another computer. That time I got to the installation process. But when I tried to select a drive to install windows I got an an error saying the stick was MBR to install but the partition was GPT. So the drive was incompatible with windows (or something like that).

  • I tried installing the USB sitck with the program "Rufus" to partition it for compatability with GPT drives and UEFI BIOS. That did not work and the drive did not turn up in UEFI BIOS as a bootable device (not very relevant for the issue, but im including it just in case).

  • I tried setting a few settings in the UEFI BIOS in the hopes that it was just a settings issue:

    • I tried setting the SATA mode to AHCI (and changed it back to Raid On after testing without any issues occuring). Changing this gave me a warning however, saying i might have to reinstall the OS if i changed these settings, But the options i switched between (AHCI and Raid On) was apparently supported and should not cause an issue as far as i could understand from the warning.

    • I tried turning Secure Boot off (on and off a few times actually).

    • I tried to enable legacy boot to detect the installer USB stick.

    • I reset the BIOS to factory settings a few times (without it causing any issues for the booting process).
    • I tried reordering the boot sequence so that "Windows Boot Manager" was not on top, but the internal drive of the PC. This was also changed back and forth a few times without it causing any problems. I switched back the ordering before the problem occured.

After the error occured:

I can not see the "Windows Boot Manager" in the list of bootable devices anymore. Im guessing this is the main issue.

I tried startup repair, system restore and system recovery image from the troubheshoot dialog on the USB stick, but i dont have an image and the restore / startup repair fails.

The main SSD drive is still detected in the boot sequence (now on top). And it is also detected in the boot sequence UEFI interface.

I did a Dell diagnostic scan of the system and it did not give me any errors with the hardware. Everything seems to work just fine (only got a warning that the power cable was not plugged in).

I followed a guide after googling the red error text above and tried the following commands in the command prompt:

Bootrec /fixmbr

Bootrec /fixboot

Bootrec /scanos

Bootrec /rebuildbcd

but no windows intallations are detected after running those commands. 

Total identified Windows installations: 0

Link: http://www.laptopmag.com/articles/fix-0xc0000034-error-windows-10

So then i figured i would follow this guide: www.lifewire.com/how-to-rebuild-the-bcd-in-windows-2624508 

to rebuild the bcd. But when i tried the first command: 

bcdedit /export C:\bcdbackup

I get an error saying: 

The store export operation has failed.
The requested system device cannot be found.

And if i scan for disks (i thought the C letter might be wrong), i get two disks: C and X

however running

bcdedit /export X:\bcdbackup

(with X instead of C) gives me the same error.

This is as far as I have gotten. Maby i simply dont have a bcd device to back up? (i dont really know what that means). 

Questions

  1. Could this be an issue with the hardware?
    1. The installer shouldn't wipe the boot like that right? Specially since it was booting fine before the attempted install, and since i did not go through with the install (or even begin copying / modifying files). As far as I know windows 10 should suopport dual installations of windows on the same computer.

  2. Maby there is a driver for the SSD that I need to reinstall?
    1. In the windows installer I can load a driver if I understand it correctly, but I dont know what driver that should be. If anyone could point me in the right direction that would be very helpful.

  3. Does anyone have an idea of what I can do next?
    1. Go on with the BCD rebuid without the export perhaps? I dont know if that is risky or not.

Note

I dont expect to get my data back, all im hoping for is a clean install again.

Thanks for any and all replies.

0 Kudos
1 Solution

Accepted Solutions
N4TT
1 Copper

RE: XPS 15 9560 Laptop not detecting windows installation, windows installer not detecting drives.

Jump to solution

Hi everyone,

I downloaded and ran the dell recovery media from a usb stick and reformatted / reinstalled windows 10 on the machine. So the ssue is resolved 🙂

I experienced a weird bug in the process tho, when installing the recovery tool on the usb drive.

The tool is called "Direct Key creator" and when i startet it up, all texts and headlines in the program was just placeholder texts:

And since the drives were all named IDS_DISK_DESC i had to unplug all my other external drives in order to  be sure i installed the software on the correct one. 

And another thing,

When i booted the recovery tool i got to a step where i was told that the disk was locked and i had to provide one of three options to unlock it:

  1. select a key from a dropdown
  2. input a numeric code to unlock it - 
  3. input a passphrase

I figured this is because of the bitlocker encryption on the drive and that I had to provide the bitlocker key to unlock it.

The dropdown was empty, so no luck there. The numeric code i figured was the bitlocker key, so i provided that key, with and without the dash in between each segment of numbers, but no luck. I also tried inputting my user password for the administator account i usually use to unlock the drive when i log on. But that did not work either. I kept getting a prompt saying something along the lines of "drive is still locked, abort?

Instead of aborting I skipped the step and continued with the process. The recovery tool allowed me to completely wipe the drives with the encryption, and i didnt have anything of value so that was ok. 

I know that it might have been possible to decrypt the drives through the windows troubleshooting command promt, but thats not an issue now. 

1 Reply
N4TT
1 Copper

RE: XPS 15 9560 Laptop not detecting windows installation, windows installer not detecting drives.

Jump to solution

Hi everyone,

I downloaded and ran the dell recovery media from a usb stick and reformatted / reinstalled windows 10 on the machine. So the ssue is resolved 🙂

I experienced a weird bug in the process tho, when installing the recovery tool on the usb drive.

The tool is called "Direct Key creator" and when i startet it up, all texts and headlines in the program was just placeholder texts:

And since the drives were all named IDS_DISK_DESC i had to unplug all my other external drives in order to  be sure i installed the software on the correct one. 

And another thing,

When i booted the recovery tool i got to a step where i was told that the disk was locked and i had to provide one of three options to unlock it:

  1. select a key from a dropdown
  2. input a numeric code to unlock it - 
  3. input a passphrase

I figured this is because of the bitlocker encryption on the drive and that I had to provide the bitlocker key to unlock it.

The dropdown was empty, so no luck there. The numeric code i figured was the bitlocker key, so i provided that key, with and without the dash in between each segment of numbers, but no luck. I also tried inputting my user password for the administator account i usually use to unlock the drive when i log on. But that did not work either. I kept getting a prompt saying something along the lines of "drive is still locked, abort?

Instead of aborting I skipped the step and continued with the process. The recovery tool allowed me to completely wipe the drives with the encryption, and i didnt have anything of value so that was ok. 

I know that it might have been possible to decrypt the drives through the windows troubleshooting command promt, but thats not an issue now.