Highlighted
2 Iron

XPS 8300 - USB issues: mouse, drives

Jump to solution

Three days ago I ran into a curios problem with my USB mouse and USB drives: they are no longer detected upon Windows startup. The USB keyboard and some other USB devices (Huion tablet, Asus wireless adapter, Brother printer) work as expected.

It went down unexpectedly while I was working on my XPS 8300 on Dec 5: the USB optical mouse cursor disappeared. I checked the Windows update history and noticed that two driver updates had recently been installed:

  Intel - Other hardware - Intel 6 Series/C200 Series Chipset Family USB Enhanced Host Controller - 1C2D

  Intel - Other hardware - Intel 6 Series/C200 Series Chipset Family USB Enhanced Host Controller - 1C26

The system had made two unsuccessful attempts to install these updates on Dec 4 and Dec 5, and then one successful attempt on Dec 5. No other updates have been installed since Dec 3.

I restored the system to a restore point dated Dec 3 and restarted the system: the issue persisted. Then I reinstalled the two driver updates using Windows update: the issue still persists.

I opened Device Manager and noticed un "Unknown device" under Other devices. Upon trying to update the driver for this device, I got an error message reading that the driver installation file for this device is missing a necessary entry:

scr1.png

I uninstalled this "Unknown device" and scanned for hardware changes. Under "Human Interface Devices" I got a new entry with a yellow exclamation mark: "Microsoft Basic Optical Mouse v2.0".

scr5.png

 

I tried updating the driver for this item using option "Search automatically for updated driver software" and I got the same error message as above; at the same time the entry under HID disappeared and the previous "Unknow device" entry popped up again under "Other devices".

If instead of choosing to search automatically for updated driver software I choose "Let me pick from a list...", I can pick one of the mouse drivers that are currently installed on my machine:

scr2.png

However, no matter which one I pick I still get the error message shown in the first screen shot.

Interestingly, if I try to troubleshoot Windows in command prompt mode, the USB mouse works. It doesn't if I restart Windows in Safe Mode or Safe Mode with Networking though.

USB drives and a wireless mouse that uses a USB port also don't work (icons with yellow exclamation marks show in Device Manager).

Luckily, the USB keyboard works and I can use the tablet pen as a temporary mouse replacement.

I ran a "missing driver" seeking program and it seems that four important drivers may be missing or corrupt (see screen shot below). I downloaded recent versions the second (basic optical mouse) and fourth (SMBus) ones from a Microsoft site but they are only available as .cab files, which I was unable to install.

scr4.png

Any idea what is going on? Anybody experienced similar USB mouse issues recently?

 

——
XPS-8300
500 GB RAID-1 7200 rpm
16 GB DDR3 1333 MHz
i7-2600 Quad-Core 3.4/3.8 GHz
H67 Express
GeForce GTX 1050 Ti
BIOS A06
Windows 10 Home x64 v.1909

Inspiron N411z
750 GB SATA 7200 rpm
8 GB DDR3 1333 MHz
i5-2410M Dual-Core 2.3 GHz
HM67 Mobile Express
HD Graphics 3000
BIOS A06
Windows 10 Pro x64 v.1909
0 Kudos
1 Solution

Accepted Solutions
Highlighted
2 Iron

Re: XPS 8300 - USB issues: mouse, drives

Jump to solution

Yay! Just installed today's updates and the problem is now gone, I guess the fix was in cumulative update KB4530684.

——
XPS-8300
500 GB RAID-1 7200 rpm
16 GB DDR3 1333 MHz
i7-2600 Quad-Core 3.4/3.8 GHz
H67 Express
GeForce GTX 1050 Ti
BIOS A06
Windows 10 Home x64 v.1909

Inspiron N411z
750 GB SATA 7200 rpm
8 GB DDR3 1333 MHz
i5-2410M Dual-Core 2.3 GHz
HM67 Mobile Express
HD Graphics 3000
BIOS A06
Windows 10 Pro x64 v.1909

View solution in original post

0 Kudos
7 Replies
Highlighted
7 Thorium

Re: XPS 8300 - USB issues: mouse, drives

Jump to solution

A mouse is plug and play so doesn't need additional drivers. KB's are plug and play too. Microsoft mice and keyboards use the MS Mouse and KB Center for setting up the mouse and KB and changing settings. The unknown item in the list of Devices is unrelated to the mouse. Every mouse you ever used will be listed in Device Mgr. You might not have that usb wired mouse anymore. If you have a MS wired or wireless mouse and/or KB now go here to download the utility. There is a new version of the utility available now.--

https://support.microsoft.com/en-us/help/4051843/accessories-mouse-keyboard-center-download 

 Also-- Check Dell Downloads and Drivers for your model computer to see if you need any updated drivers for the unknown device. Try using a diff usb port for the mouse. Try a new mouse if it still doesn't work. Mice are cheap so you should always have an extra. The old mouse might have failed not the usb port.

0 Kudos
Highlighted
8 Krypton

Re: XPS 8300 - USB issues: mouse, drives

Jump to solution

Try clearing BIOS:

  1. Reboot and immediately press F2 to open BIOS setup
  2. Copy down all current BIOS settings, to be safe
  3. Power off, unplug
  4. Press/hold power button for ~15 sec
  5. Open case and remove motherboard battery (check Service Manual for details)
  6. Press/hold power button for ~30 sec
  7. Reinstall the battery (Time for a fresh CR2032 3-volt coin cell battery? ~$2)
  8. Close up and connect mouse, monitor and keyboard
  9. Reboot

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
Highlighted
2 Iron

Re: XPS 8300 - USB issues: mouse, drives

Jump to solution

@Mary G 

Both the wired and wireless mice work as expected on another Dell computer. Trying different USB ports or reinstalling the MS mouse & kbd center x64 didn't seem to help.

Dell doesn't provide driver updates for XPS-8300 running Windows 10, but I think that's not the cause of the problem here as everything was working fine until four days ago and there have been no MS updates since then other than the two Intel chipset drivers that I mentioned.

——
XPS-8300
500 GB RAID-1 7200 rpm
16 GB DDR3 1333 MHz
i7-2600 Quad-Core 3.4/3.8 GHz
H67 Express
GeForce GTX 1050 Ti
BIOS A06
Windows 10 Home x64 v.1909

Inspiron N411z
750 GB SATA 7200 rpm
8 GB DDR3 1333 MHz
i5-2410M Dual-Core 2.3 GHz
HM67 Mobile Express
HD Graphics 3000
BIOS A06
Windows 10 Pro x64 v.1909
0 Kudos
Highlighted
8 Krypton

Re: XPS 8300 - USB issues: mouse, drives

Jump to solution

Did you try clearing BIOS like I said above..?

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
Highlighted
2 Iron

Re: XPS 8300 - USB issues: mouse, drives

Jump to solution

@RoHe Yes, I cleared the BIOS as per instructions and it didn’t fix the problem.

——
XPS-8300
500 GB RAID-1 7200 rpm
16 GB DDR3 1333 MHz
i7-2600 Quad-Core 3.4/3.8 GHz
H67 Express
GeForce GTX 1050 Ti
BIOS A06
Windows 10 Home x64 v.1909

Inspiron N411z
750 GB SATA 7200 rpm
8 GB DDR3 1333 MHz
i5-2410M Dual-Core 2.3 GHz
HM67 Mobile Express
HD Graphics 3000
BIOS A06
Windows 10 Pro x64 v.1909
0 Kudos
Highlighted
2 Iron

Re: XPS 8300 - USB issues: mouse, drives

Jump to solution

Yay! Just installed today's updates and the problem is now gone, I guess the fix was in cumulative update KB4530684.

——
XPS-8300
500 GB RAID-1 7200 rpm
16 GB DDR3 1333 MHz
i7-2600 Quad-Core 3.4/3.8 GHz
H67 Express
GeForce GTX 1050 Ti
BIOS A06
Windows 10 Home x64 v.1909

Inspiron N411z
750 GB SATA 7200 rpm
8 GB DDR3 1333 MHz
i5-2410M Dual-Core 2.3 GHz
HM67 Mobile Express
HD Graphics 3000
BIOS A06
Windows 10 Pro x64 v.1909

View solution in original post

0 Kudos
Highlighted
8 Krypton

Re: XPS 8300 - USB issues: mouse, drives

Jump to solution

Glad it got resolved.

Send a "thank-you" note to Bill Gates... 😋

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos