Highlighted

D6000 dock, 6 year old Microsoft wireless mouse not working

Jump to solution

Hi,

I have a new XPS 15 and a D6000 docking station. It all works quite well. But sometimes, my 6 year old Microsoft wireless mouse does not work when I turn my laptop on. The mouse is a wireless mouse and the receiver is plugged into the docking station. This happens regardless of what USB port the receiver is plugged in, I've tried all of them. What is strange, is if i change the receiver to any of the other ports once the laptop is on, it starts working. But if I leave the receiver in this new port, next time the laptop comes on, the mouse doesn't work. And as I mentioned, sometimes the mouse does work though. And if I connect my mouse directly to the laptop it always works. Also, I've had this mouse for 6 years with my previous laptop and this never happened. It's a microsoft wireless mouse. All my drivers are up to date. I have a brand new Dell XPS 15 and D6000. I am running windows 10, also with latest updates installed. I connect the D6000 using the USB-C port to my laptop. Why is my mouse not working on startup?

Labels (3)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Moderator
Moderator

Re: D6000 dock, 6 year old Microsoft wireless mouse not working

Jump to solution

Hi QuintonnRothmann,

Dell never tested this 6 year old Microsoft wireless mouse. You will need to post the issue on the Microsoft Forums to get assistance. Do you have a newer wireless device to test on the D6000?


DELL-Cares
Social Media Support
#IWork4Dell

View solution in original post

0 Kudos
1 Reply
Highlighted
Moderator
Moderator

Re: D6000 dock, 6 year old Microsoft wireless mouse not working

Jump to solution

Hi QuintonnRothmann,

Dell never tested this 6 year old Microsoft wireless mouse. You will need to post the issue on the Microsoft Forums to get assistance. Do you have a newer wireless device to test on the D6000?


DELL-Cares
Social Media Support
#IWork4Dell

View solution in original post

0 Kudos