Highlighted
1 Copper

XPS 13 7390 2-in-1, WiFi issues

Jump to solution

Hello,

I bought the brand new Dell XPS 2 in 1 7390 on December 1, 2019. I was really excited to finally buy an XPS device after hearing so many good things about the XPS line. For the past week or so, I have been having issues with connecting to my home wifi. The laptop keeps disconnecting and reconnecting to my wifi network. After looking at a bunch of online discussion forums, I am seeing A LOT of people with the same issue. 

I have an old ASUS device with a broken screen that can still connect and remain connected to a wifi network. I have spent more dollars on this device than any other, so I really hope to get this issue resolved as soon as possible. I have seen others recommend to uninstall and then reinstall the Killer wireless drivers but that seems to have a 50/50 chance of working. If someone can provide a resolution that has consistently worked for others, I would really appreciate that.

Thank you

Best,

Bill

0 Kudos
1 Solution

Accepted Solutions
Highlighted
5 Iridium

Re: Dell XPS 7390 2 in 1 WiFi issues

Jump to solution

Dell has a support page that addresses the issues here. It may help. Also look at this video here. And if the problem persists and you get frustrated have a look here.




-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built with MSI B450-A Pro Max with Ryzen 7 2700X
Real work on an Inspiron 15 5575 and Latitude E5430

View solution in original post

0 Kudos
3 Replies
Highlighted
5 Iridium

Re: Dell XPS 7390 2 in 1 WiFi issues

Jump to solution

Dell has a support page that addresses the issues here. It may help. Also look at this video here. And if the problem persists and you get frustrated have a look here.




-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built with MSI B450-A Pro Max with Ryzen 7 2700X
Real work on an Inspiron 15 5575 and Latitude E5430

View solution in original post

0 Kudos
Highlighted
5 Rhenium

Re: Dell XPS 7390 2 in 1 WiFi issues

Jump to solution

Would you be willing to describe your situation as far as environment and devices involved in your wireless connections?

Such as, what Wi-Fi router do you use, how old and firmware updates?  Local environment, many devices on the network with different Wi-Fi abilities?  Interference from neighbors or companies?

Hopefully, the support page will help and recommend using the uninstaller then reinstalling.

I would like to know what Dell uses to setup these systems.  I assume Killer Wireless supplies the software and if that is the case, why are the Dell setups using that software, having problems.. 

With that being said, Windows 10 does have a situation where going from one build version to another can introduce problems for drivers that are not fully updated.

I keep waiting for someone to send me one of those devices so I can test it..  ;))

_____________________________________
XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720
0 Kudos
Highlighted
8 Krypton

Re: Dell XPS 7390 2 in 1 WiFi issues

Jump to solution

Could also be the Power settings in Win 10...

Open Device Manager and double-click the entry for your WiFi card. Click its Power Management tab and UNcheck the box "Allow PC to turn off...". Exit Device Manager.

Now open the Windows Power & Sleep screen. Click Additional power settings on right side of screen. On next screen, identify the active power plan and click Change plan settings. On next screen click Change advanced power settings.

On left side of this last screen:

  • Set WiFi adapter settings to Max Performance
  • Change or disable Sleep>Sleep after...  to suit your needs
  • Disable Sleep>Hybrid Sleep
  • Disable Hibernation
  • Disable USB settings > Selective Suspend
  • Disable PCI Express > Link State Management

Save the changes to the power plan and reboot. See if that helps...

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos