XPS

Last reply by 03-08-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
4720

XPS 13 9300 (2020) drops ethernet

Have tried two different USB-C hubs (Belkin and HooToo, links below) but ethernet (and internet) keeps dropping every half-hour to an hour.  The network/internet icon on task bar would show "Not Connected" all of a sudden, even though the ethernet RJ45 jack LED light on the USB-C hub still flashes green (normal and connected).  It's very troublesome especially during Zoom meetings! 
 
Unplugging the USB-C hub and re-plugging it in would bring the ethernet back but the frequent needs to re-connect is unbearable. 
 
Unfortunately this is the part of the home office without WiFi signal so need to use physical cable.
 
Does anyone have same experience / have solution?
 
I actually have two XPS 13 (2020) at home and connection is stable for the other one (using Belkin USB-C hub)
 
Appreciate your help on this.
 
USB-C hubs:
 
 
 
 

 

Replies (19)
Moderator
Moderator
3515

Thank you! We have received the required details. We will work towards a resolution via private messages to ensure the security of your information. In the meanwhile, you may receive assistance or suggestions from the community members as well.


Social Media Support

#IWork4Dell
Find your Service Tag


If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

Moderator
Moderator
3486

Hello

Awaiting a response to our previous message.


Dell-SimranC
Social Media Support
#IWork4Dell

3471

Hi SimranC,

Have replied to your PM twice already.  Please let me know if you have trouble receiving the messages.

 

Thanks,

3470

Hello, we sent you a private message.

 

Thanks


Social Media Support

#IWork4Dell
Find your Service Tag


If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

2 Bronze
2 Bronze
3448

Hi,

yes I had the same problem on both my XPS laptops. I solved it by going to Device Manager/Network Adaptors and altering the Advanced Properties. In my case the network adaptor is a Realtek USB FE Family Controller. Scroll down the advanced properties list and disable Energy-Efficient Ethernet. Scroll down further to speed & Duplex and set it manually to 100 Mbps Full Duplex so that Auto Negotiation is switched off. Since doing this I have had no further problems even when using a non Dell Ethernet to C-Port adaptor from China.

Good luck

Ian 

3439

Thank you, will give that a try and report back soon

3434

Sadly, Zoom worked for 10mins then same issue came back.

-Energy Efficient Ethernet set to "Disable"

-Speed & Duplex set to "100 Mbps Full Duplex" 

3376

Did you ever find a solution? I had the same problem and have just been using Wifi instead

3358

Unfortunately, still no solution. That said, after implementing the changes Shedi posted above, situation did improve - from a few times an hour to once every 1-2 hours. " In my case the network adaptor is a Realtek USB FE Family Controller. Scroll down the advanced properties list and disable Energy-Efficient Ethernet. Scroll down further to speed & Duplex and set it manually to 100 Mbps Full Duplex so that Auto Negotiation is switched off. Since doing this I have had no further problems even when using a non Dell Ethernet to C-Port adaptor from China."
Latest Solutions
Top Contributor