Last reply by 12-26-2019 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 13-9370, mouse cursor lagging and stuttering

Having an issue with my new XPS 9370. Using the touchpad (haven't tried using a mouse with it at all), the mouse cursor sometimes stutters/freezes for a second then keeps going. Happens quite a lot actually. Sometimes it actually stutters multiple times in one swipe on the touchpad but other times it works fine..any ideas on what to do? I don't see any specific touchpad options in windows settings or anything either.. Thanks

Replies (137)

Well, I still have the same problems even with updating the BIOS, the Drivers for the IGP and the SSD.

Also tried the disabling C-state and Speedstep same behaviour.
During the problem the CPU load is low and the temps are in the 44 - 50 degrees celsius range.

Ill be asking for a refund, to bad because I like this little thing...
Just don't have the time to be messing around with a new laptop.


Same here, no time to wast doing what Dell should have done prior to launch. Was in doubt on a refund ou replacement unity but after receiving Dell's position that my case (3 days old computer) is under evaluation by management to see if I can be refunded or replaced (something granted by Brazilian consumer laws) things are pretty much decided. After sales also matters Dell!


Day 4 of using the replacement device and it is flawless without having done anything. I am getting the feeling that internally they have addressed the issue, but just not made it public. The only way you will solve this issue is by replacing. I didn´t ask for a refund, because this machine´s specs is still far superior than others. 


Potential solution (until Intel or Dell will officially solve this problem), but I need at least one more volunteer to verify that:

  1. Right click on your Windows desktop and select Intel Graphics Settings (you can also run it from tray area if you did not disabled it from running at startup)
  2. Go to Power tab (second icon at the bottom right side)
  3. Disable "Panel Self-Refresh" option and hit Apply
  4. Shutdown your device (do not just restart since problem is more likely to happen on fresh start and you want to test that it's "fixed") and turn it on back again.

NOTE: If your freezing problem will occur once again, double check that "Panel self-refresh" is still disabled (I saw in some other threads that sometimes options in the Intel graphics settings Panel tends to revert back to defaults).

DRAWBACKS: Theoretically shorter up time when running on battery.

TESTED ON: XPS 13 9370, BIOS v1.2, i7, with non-touch FHD screen and latest ( drivers from Intel site.




Dear perpetoomMy XPS was already back to the box when I read your Potential Solution, unboxed to give it another try since it is a nice machine (when it is not frozen).

Searching google I found that Intel Panel-Self-Refres is causing  screens freezes on several computer models (Surface 4, Lenovo Yoga...). The best description to this problem we are facing is from a Surface Pro 4 forum: "Some people are experiencing a weird problem where their SP4's screen would randomly freeze for a couple of seconds. It's not the system locking up, everything seems to continue to run in the background and it doesn't happen when watching videos or running applications, where there's a lot of motion on the screen." Exactly what we are facing since everything besides the screen is working (being CAPS LOCK light on/off a good indicator).

All the solutions I read are: DISABLE Panel Self-Refresh. That is just another of these tools to make your battery last longer and your life harder...

Well my XPS 9370, i7, 16GB, BIOS v1.2, Touch UHD with latest Dell driver (not Intel's latest).

I will give my conclusion by tomorrow after a work day (actually working with the computer) but so far it seems that you have found the solution. The screen freeze was largely noticed under Google Chrome and now it is (so far) working flawless. Maybe The Samsung can check if its newly shipped XPS is disabled by default.


I checked my settings and the Panel Refresh is on. So that isn't affecting my system at this time. I did not have a single stutter and it is day 5. 


Early days but the panel refresh setting appears to be helping. I've also logged this with Dell who've linked me to a newer 1.2.1 bios version which I'm trying.

Nothing helps (Sppedstep, C-State, Intel Panel Self Refresh and even the latest BIOS1.2.1). The only logical solution seens to ask for a replacement. This must be something related to a defective production batch.


To give you all an update. Dell is switching my XPS. But since for at least some days I am stuck with this one I have been doing some research and found a solution that has gone through a work day without issues (as always ask The Samsung if any of these alternatives are being shipped as default by Dell).

I have the following changes applied: BIOS 1.2.1:

  1. C-States is DISABLED;
  2. Both Virtualization support (Virtualization and VT for Direct I/O) are DISABLED

On Windows 10 under Intel Graphic Settings: Self Refresh and Gamming Battery Life are both DISABLED.

One might try different combinations to get to the ROOT issue (or combination). I personally will keep these setting not only because the machine is running flawless but also because it is a personal preference it makes the machine faster and safer (Virtualization does pose some risks).


So I am into day 7 besides the killer wifi which looses connection from waking up (I have updated the latest driver, so I am crossing my finger on this), everything is running smooth. To verify, everything is on by default, c-state, and the other virtual settings are all on. Even the Video power settings. If this is a solution for some of you so be it, but my take is that we shouldn't be looking for solutions by sacrificing optimal settings for a brand new computer. 

Please get a new replacement while you can, even if you solve the issue, there will be an uneasiness in the back of your mind. I am very sure there was an issue with the first batch of the units.  Best of luck everyone. This will be my last post.

Latest Solutions
Top Contributor