XPS

Last reply by 09-26-2020 Unsolved
Start a Discussion
2 Bronze
2 Bronze
704

XPS 15 9500 doesnt boot after ram upgrade (crucial recommended list)

Hi my xps 15 9500 doesnt boot anymore after i have made a memory upgrade.

i bought the crucial CT2K16G4SFD8266 32GB Kit.

It is a 2666 kit with a cl of 19 and 1.2v.

This kit is recommended on the website of crucial to work with this machine.

is there some trick like holding the power button for a long time to get the new ram detected?

I only geht an RGB screen an bootup, when i place the old ram in the machine boots up normal.

Thanks for your help.

Replies (3)
Moderator
Moderator
700

Thank you! We have received the required details. We will work towards a resolution via private messages to ensure the security of your information. In the meanwhile, you may receive assistance or suggestions from the community members as well.


Social Media Support

#IWork4Dell
Find your Service Tag


If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

689

I have found a solution:

it is mandatory to unplug the battery before the upgrade.

after unplugging the batterie and plugging it back in the notebook boots with the new ram kit and all 32Gb are shown in Windows

687

Thank you for keeping us informed.

We are glad to hear that the RAM is working now.

Feel free to drop in a message if you need any further assistance.
We'll be glad to assist you.

 

Prajwal


Social Media Support

#IWork4Dell
Find your Service Tag


If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

Latest Solutions
Top Contributor