XPS

2 Bronze

XPS 15 9560, Alert! TPM device is not detected

Having followed these steps & those provided on the Dell support page, I'm still receiving an error during bootup "Alert! TPM device is not detected."
The TPM is not visible in the bios or Windows device manager.
Installing V2.0 firmware was not successful.
TPM Management states, "Compatible TPM cannot be found".
Bios has been updated to the current version. 

My warranty has just conveniently lapsed & not service agents are available until tomorrow.
I've even tried to pay for further support & warranty extension, but to no avail.


What now Dell?

 

XPS 15 9560

Labels (1)
Solution (1)

Accepted Solutions
2 Bronze

I too had this problem for a long time on several computers at work but managed to solve it.

During my quest to find a solution I tried everything but it never occurred to me that I never shut down my computer and unplugged to power cord. I have always shut it down with the power cord still in, just restarted the computer or have it gone in sleep mode. I bet most corporate do this using sleep mode or have the AC plugged in when shut down.

Well how stupid did I feel when I shut down my computer completely, unplugged it from the AC and let it be for 30 second. When I plugged in the AC again and turned on the computer the magic happened. LOL The TPM alert was gone. For some reason shutting down the computer and unplugging the AC for 30 seconds seems to do something allowing the bios to find the tpm again.

So I tried the same on a second computer and the same stupid fix worked on that one. Well in the end we did this on all the computers encountering this and the same fix applied for all of them. So after this we are now upgrading the bios on all computers and any computer getting this error is easily fixed by shutting it down, removing the AC for 30 second and then firing up again. lol

So if you havent tried this then please try it and see if it works for you. Im not saying it is the fix but worth trying

 

Additional Info on TPM:

View solution in original post

Dell Accepted Solution
Replies (18)
6 Indium

Try the following information from this thread.

https://www.dell.com/community/XPS/DELL-XPS-9560-TPM-not-available/td-p/7352627




-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built with MSI B-450M Pro-VDH Max budget build with an Athlon 3000G
Real work on a Latitude E5430

My error is not due to a bios update. I cannot roll it back as I have not updated it.

I will note that my bios version is listed as 10.0.18362.1 & not 1.15 as is referenced in the linked thread.

As an experiment, I just updated to 1.16 to see what would happen when I rolled back. No help. Rolled back to 10.0.18362.1

Should I be looking for a way to source 1.15?

Same problem on my XPS 9560 with the 1.16 system bios update !! 

I Can use it but i have every Time "alerte Tpm device is not detected" at the beginning 

Dell precision 5520 here... 1.16.0 had this issue and now the JUST RELEASED 1.18.0 has the same issue... ugh...

I updated to the new 1.80 bios and I have the same issue.  Going to roll back my bios to one that did not have this issue.

Not that this is an option for everyone but luckily the laptop was still under warranty and a motherboard swap did the trick for me.  TPM showed up in BIOS and works in Windows.

Best of luck.

Hi,
Could you type tpm.msc in run command & check the status of TPM. Let me know if it says TPM ready for use.

Dell-ArunV

I have the same problem.

Xps 15 9550

BIOS 1.13.1

The tpm will not be found!

 

It's a problem for many users, I see. How can we easy fix it?

Exactly the same computer and same BIOS issue. Rolled back to 1.15. I was hoping that 1.18 would fix it. I guess they want us to buy new machines. 

Top Contributor
Latest Solutions