XPS

Last reply by 02-19-2020 Solved
Start a Discussion
2 Bronze
2 Bronze
60158

XPS 15-9570, Windows 10, high DPC latency, acpi.sys

Hello,

I have a dell XPS 15 9570, and I have big issues with on board and external audio.

HW Spec:

Dell XPS 15 9570, i7 8750H, 4K screen, 16g ram /512g ssd, qualcomm Killer wifi and then intel AC-9260, nVidia 1050 Ti with latest WHQL drivers, bios v1.2.2, all drivers to date as of 2018/15/07

Symptoms:

- audio cracks and pops with system audio when watching videos, listening to mp3/flac, playing games with built-in card,

- audio cracks and pops with  external ASIO soundcard (focusrite scarlett 18i8 2nd gen) when running pro DAW software with 256 samples buffer @48Khz or 512 buffer @96Khz

This can damage external speakers and makes the machine unusable for live audio or even standard multimedia use.

What I did:

- applied all tweaks recommended by my external audio card's manufacturer https://support.focusrite.com/hc/en-gb/articles/207355205-Optimising-your-PC-for-Audio-on-Windows-10

- ran LatencyMon and found that TCPIP.sys and ndis.sys were causing 4ms DPC latency spikes, followed by ACPI.sys 2ms and dxgkrnl.sys 1.7 ms

- swapped  the qualcom card for an intel AC-9260 which eliminated totally the TCPIP.sys and ndis.sys spikes

- now ACPI.sys and dxgkrnl.sys are still causing 2ms DPC latency spikes

- audio glitches are still present

- disabled all peripherals except for keyboard, integrated graphics, trackpad, screen and storage (I disabled wifi, bluetooth, webcam, nvidia graphics, fingerprint reader, ACPI battery manager, cardreader, fall accelerometer, screen touch, etc.)

- disabled Speed-Step/ SpeedShift and Turbo-Boost, disabled virtualisation support in the BIOS to try to minimize randomness in the behaviour

- disabled fastboot

- ACPI.sys latency is still culminating at 1.7ms and causing audio dropouts with either built-in or external USB asio interface

- I've opened a support ticket over at dell with my premium support, the ticket was automatically closed a week later without anyone getting in touch with me.

 

I've run out of options and am looking for help.

 

Solution (1)

Accepted Solutions
38476

Hey everybody !

I changed my computer and still got this problem. So the error doesn't come from the laptop, but I found the issue. It comes from Intel Turbo Boost Technology!

Try this:
* Click Start
* Type power
* Click Edit power plan
* Click Change advanced power settings
* Change the Power option to Balanced
* Open Processor power management
* Change the Maximum processor state to 99% instead of 100%

Capture.JPG

This will avoid the Turbo Boost activation. Windows will no longer get peak from only one processor. It will synchronize all the processors and make the music more stable! It should be fine, then.

Cheers ! 

 

View solution in original post

Replies (114)
2 Bronze
2 Bronze
40701

Hi, I am using DELL 9560 with DJing and music production (Traktor and Ableton). And I have had similar problems still do honestly just to a lesser extent. What I did was uninstalled completely realtek audio drivers and installed default windows High Definition Audio Device driver. Also made sure MaxxAudio is not present on the system by deleting it and stopping all related processes.

Its a pity that such a cool laptop which has so much trouble regarding music production.

2 Bronze
2 Bronze
40503

I may have found a workaround for this issue.

1. Run Windows Performance Tools to determine which of your CPU cores is affected by DPC issues. In my case, ACPI.sys is causing Core 0 to have DPC interrupts of 1700 microseconds or longer.

2. Set your audio application (Ableton Live in my case) to stay off of that CPU core. You can use Task Manager's CPU affinity setting, or use Process Lasso.

I've been through a couple of rehearsals and live performances, and no issues so far.

Note that you still need to follow all of the other good advice - uninstall or disable Dell software, turn off Intel Speedstep, turn off Wifi, close all other programs, etc.

I realize that this is just a workaround. Dell should really fix the DPC interrupt issues.

40161

Thanks, Jerry37, for the Process Lasso idea. I have spread the word a bit on that, and a few people, including myself, are finding Process Lasso helps.

I am also glad that you have had some success with Ableton. That is a very good program for live performances.

On my XPS 15 9570, 16 GB, 1 TB SSD I get a maximum Latency of around 1600, and that usually occurs within 10 to 30 seconds. It made me nervous, but ultimately I am still able to do music recording, using Presonus Studio One 3.5.  Studio One has a special secondary Latency reducing feature, which allows a small buffer (256, for recording) and a special setting Processing tab for Dropout Protection (I use High, 1024 samples). The result is no pops or crackles. Whew!

It might be that Ableton has a similar Dropout Protection feature.

I updated the BIOS to 1.3.0 and (unfortunately) found that increased my latency by about 30%. 

I tried every solution I could find for the XPS 15 9570, and found these things worked the best for me. They are a combination of process/CPU management and good olde fashioned buffer sample sizing in my DAW.

- Used LatencyMon to find the worst Driver/DPC and Processes/PageFault offenders. Used LatencyMon's CPUs Option menu to ignore CPU 0 and 1, then 2 and 4 as well. That reduced some latency. 

- I then used those CPU Affinity values in Process Lasso for Studio One, which latency greatly affects.

- I temporarily disable the Killer wifi in the Device Manager (after I start Studio One, since it needs the Internet to validate the licence).

- I keep Bluetooth and the Camera disabled.

Here is a link to the Presonus latency article, including a thorough description of latency issues, and a bit about their Dropout Protection: https://www.presonus.com/learn/technical-articles/Digital-Audio-Latency-Explained

Cheers and thanks!

 

40081

Same issue here, ACPI.sys causes high latency, something not right with the 9570 drivers/bios. Dell wont care obviously, not understand the issue.

2 Bronze
2 Bronze
20462

Looking for similar.  Also have a focusrite, also getting pops.  I'm a sound engineer - some help here would be appreciated

19896

I have huge DPC latency  due to to ACPI.SYS as well on my XPS 9570.
This is a shame, a major drawback of this computer.
Please Dell, deal with this DPC latency problem, I spent 2 000 euros!

19732

I am facing exactly the same issue high DPC Latency caused by ACPI.sys. Have anybody found any solution to this problem?

19713

Same problem, come on Dell, fix this please !!! Acpi.sys causes Dpc latency and prevents doing any serious audio production :( 2000 euros 9570 !!!!!  :(  :(  :(

18483

If it is of any consolation, Frank Azor says "it was just reported a few weeks ago and teams are on it"

https://twitter.com/AzorFrank/status/1044479012389703680

Except that audio crackling and high DPC latency has been and ongoing issues with the 9560, 9550 ;(

Latest Solutions
Top Contributor