XPS

Last reply by 12-14-2021 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 9380 boot to thunderbolt drive

I have a Samsung X5 SSD that I want to boot from. This is a thunderbolt only (USB not supported) drive.

I was able to boot on a linux live USB drive, and the X5 drive was visible, so I was able to create a linux partition and install a fresh linux mint install on the X5 drive.

But the X5 drive is not visible on the boot menu.

I've set these options in the BIOS :

Enable USB support : selected.
Enable Thunderbolt Boot Support : selected.
Enable Legacy Option ROMs : selected.
Enable UEFI Network Stack : selected.
Fast boot : thorough
Secure Boot : disabled

I've also installed the latest BIOS update (1.12.1).

Any help is appreciated.
Thank you.

Replies (2)
2 Bronze
2 Bronze

Hi !

I have an issue using Samsung SSD X5 on Linux. The drive is correctly detected on Windows, but on linux Mint, and Ubuntu, it just say

[ 308.516987] thunderbolt 0-1: new device found, vendor=0x175 device=0x4000
[ 308.516989] thunderbolt 0-1: SAMSUNG ELECTRONICS CO., LTD Portable SSD X5

 

It do not show the storage at all (no partition or anything)

 

Which version of Linux did you use ?

 

Thanks

2 Bronze
2 Bronze

Ok, so I formatted the partitions on drive in an ms-dos format and reinstalled linux mint. And it worked!

I was able to boot into the thunderbolt drive. I guess the drive was formatted in GPT format by default ?

As to why it wouldn't boot on a GPT formatted partition, I have no clue.

Case closed.

Community Accepted Solution
Top Contributor
Latest Solutions