XPS

Last reply by 08-13-2022 Solved
Start a Discussion
2 Bronze
2 Bronze
894

XPS 9520 5Ghz connection

XPS 15 9520

Hello,

I got a brand new XPS 15 9520 and I have some issues when I want to connect to 5ghz wifi. 

The router works perfectly and the new XPS is in the same place as my previous laptop (which works on 5ghz very well)

I tried to install the latest wifi driver, bios update etc but without luck. When trying to connect to my 5ghz wifi I get an error "can't connect to this network". And that's it. Nothing else happens. 

I saw that many XPSs had WIFI card problems. Could this be the same issue? 
Any ideas? Thanks!

 

PS: I have the AX211 network card.

Solution (1)

Accepted Solutions
2 Bronze
2 Bronze
662

Try the drivers from Intel website, always used them over manufacturer drivers and work's perfectly Intel® Driver & Support Assistant.  In fact I'm impress how the connection is good, even on wifi 5

View solution in original post

Replies (14)
2 Bronze
2 Bronze
594

Also, it works on 5ghz mobile hotspot or if I move next to my router. Even if I do move next to it, I have to press connect a few times before it connects. 

2 Bronze
2 Bronze
600

bitbandit_0-1659207659658.png

The 5ghz WIFI can be seen, so it's not like "oh, where is my 5ghz wifi"

551

You might verify what type of security you are using for the 5 GHz network.  Try setting it to WPA2/WPA3. 

_____________________________________
XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720, AW3423DW
System fully Win 11 compliant
558

Do you mean what type of security I have set up on my router? 
It's WPA2-PSK.

554

The setting on your router may need to show WPA2-Personal and WPA3-Personal (WPA2/WPA3) since my 5 GHz network uses WPA3-Personal.  The both setting allows it to pick which one it needs.

Check mine is also using AES not PSK but that might depend on your situation.

 

Saltgrass_0-1659302478262.png

 

_____________________________________
XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720, AW3423DW
System fully Win 11 compliant
546

bitbandit_0-1659333513337.png

bitbandit_1-1659333526862.png

These are the settings I have. Looking good for me tho.

2 Bronze
2 Bronze
534

I hade the same issue. Roll back driver and 5ghz worked instantly. I believe they fixed it in the latest driver update.

2 Bronze
2 Bronze
531

I'm on this driver now: 

bitbandit_0-1659346083051.png

I had the latest one (22.150) from Intel's website. Should I install an older one? 
PS: The 22.130 is from Dell's website. 

518

The folks with the XPS 9520 are complaining because they cannot use the 6 GHz radio.   The AX211 card is a Wi-Fi 6e card but the specs on the system only show Wi-Fi 6.  Maybe this is all tied together.  

The bottom line is the 5 GHz radio has been around for a long time and should work normally.  The AX211 card was only released the third quarter of last year so maybe it is having a problem.

With the Insider program, I am on the 22.160.0.1 driver which may be released to the public in the near future.  Just make sure your chipset drivers are up to date.  My current system with an AX201 is on 22.140..0.1 and it has never had a problem with 5 GHz.

You might even take a look at the Advanced settings for the card in Device Manager to make sure it is set for 802.11ax and any other settings you think might be involved.

_____________________________________
XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720, AW3423DW
System fully Win 11 compliant
Latest Solutions
Top Contributor