XPS

Last reply by 08-16-2021 Unsolved
Start a Discussion
2 Bronze
2 Bronze
4063

XPS13 9360 i7-8550U - CPU speed and temperature in BIOS

Hey all,

when I cold boot my laptop on battery, I see that the Current Clock Speed of my CPU is 1,800 MHz. Everything normal.

However, when I cold boot with the AC plugged in, the Current Clock Speed of the CPU is 3,700 MHz. It's quite fast, and indeed, after a few minutes, the laptop gets very hot.

If I reboot, it doesn't matter if the AC is plugged in or not, the Current Clock Speed of the CPU is always set to 3,700 MHz.

Tried with firmwares 2.5.1 (18 Feb 2018) and 2.4.2 (12 Dec 2017).

Notice that the OS doesn't kick in here, I talk about booting and pressing <F2> to stop immediately at the BIOS setup page.

Is it the expected behavior ? Or is it a bug somewhere in the BIOS firmware or something ?

Regards

  Arnaud

Replies (3)
3 Argentum
4029

Restore default settings in Bios.
And yes you will experience a speed difference while running system on Ac adapter and battery.
Same can be managed in Windows Control panel, Power option
4020

Thanks for your reply

> Restore default settings in Bios.

Tried that, both reset to BIOS Defaults and Factory. I doesn't change anything, the CPU is still stuck at 3,700 MHz when I'm in the BIOS.

BTW, I noted that some BIOS values are still preserved after doing a Factory Reset. I purposefully tried to change some values, reset to Factory, change again, reset to Factory... And I witnessed that these values were blissfully unconcerned by the reset. Quite amazing for a so-called "Factory" reset...

> And yes you will experience a speed difference while running system on Ac adapter and battery.

That's not at all what I'm talking about. I'm talking about a CPU idle in the BIOS running at its maximum pace and getting hot, for absolutely no reason. The base frequency of this CPU is 1,8 GHz, and the Max Turbo Frequency is 4 GHz according to the spec. So here the CPU seems to be in turbo mode, while doing nothing.

Once again, let me remind you that I'm only talking about the BIOS here.

When a boot a Linux kernel, one of the first lines I get on the screen is something like "CPU too hot, throttling down frequency...". So the hardware works, and Linux works, that's not the problem.

I'm more concerned about the BIOS software that is running on my laptop.

Anyone else experiencing a similar behavior when in BIOS ?

2 Bronze
2 Bronze
682

I'm having a similar problem.

XPS 13 9310, i7-1185G7. In the BIOS > Overview screen, showing Max Clock Speed 3.0 Ghz / Min Clock Speed 0.4 Ghz / Current Clock Speed 4.3 Ghz. Literally sitting on the BIOS screen (v2.1.1), plugged in, doing nothing. From a cold boot, this machine then starts to get extremely hot, to the point after an hour it will freeze (irony?) and be unbootable due to being too hot. Oddly, no thermal issues noted in Thermal log.

Latest Solutions
Top Contributor