
Attachment uploads are currently disabled. This is a temporary situation and will resume as normal in the coming days.
Solved!
Go to SolutionUnity CSI Driver error question
Received following question
To sum it up, we need you to help us to fix the following error:
* ls: cannot access '/var/lib/kubelet/plugins/unity.emc.dell.com/csi_sock': No such file or directory
So provisioning new PVC is not a problem and works as expected but the wan't to know if this is a Bug or error that should be fixed.
During our last provision of storage via CSI Unity Driver we encountered the following error:
Please take a look at the following commands:
k get pvc
NAME STATUS VOLUME CAPACITY ACCESS MODES STORAGECLASS AGE
pvol1 Bound csivol-dev-it-7d480819bd 12Gi RWO unity-iscsi 9m55s
pvol2 Bound csivol-dev-it-bc9921b234 10Gi RWX unity-nfs 9m55s
k get pods
NAME READY STATUS RESTARTS AGE
unitytest-0 0/1 Pending 0 10m
CSI Unity Driver Node and Controller pods are working as expected...
k get pods -n unity
NAME READY STATUS RESTARTS AGE
unity-controller-77fd49d8c6-bjdb4 5/5 Running 7 20d
unity-controller-77fd49d8c6-fgxk2 5/5 Running 0 20d
unity-controller-77fd49d8c6-mrdgx 5/5 Running 0 20d
unity-node-6528n 2/2 Running 0 18m
unity-node-9t7b9 2/2 Running 6 60d
unity-node-bt2gw 2/2 Running 4 60d
but after troubleshooting logs we found the following error:
Endpoint unix:///var/lib/kubelet/plugins/unity.emc.dell.com/csi_sock
ls: cannot access '/var/lib/kubelet/plugins/unity.emc.dell.com/csi_sock': No such file or directory
time="2021-04-28T11:49:51Z" level=info runid=start msg="Driver Mode:node"
time="2021-04-28T11:49:51Z" level=info runid=start msg="X_CSI_UNITY_NODENAME:rzk8qaitw02"
time="2021-04-28T11:49:51Z" level=info runid=config-0 msg="*************Synchronizing driver config**************"
csi-unity logger initiated. This should be called only once.
time="2021-04-28T11:49:51Z" level=info msg="configured csi-unity.dellemc.com" ArrayId=c************** Insecure=false IsDefaultArray=true RestGateway="**************" password="*******" username=+++++++++
time="2021-04-28T11:49:51Z" level=info runid=node-0 msg="Starting goroutine to add Node information to storage array"
time="2021-04-28T11:49:51Z" level=info arrayid=c**************runid=config-1 msg="Dynamic config load goroutine invoked"
time="2021-04-28T11:49:51Z" level=info runid=config-0 msg="configured csi-unity.dellemc.com"
time="2021-04-28T11:49:51Z" level=info msg="identity service registered"
time="2021-04-28T11:49:51Z" level=info msg="node service registered"
time="2021-04-28T11:49:51Z" level=info msg=serving endpoint="unix:///var/lib/kubelet/plugins/unity.emc.dell.com/csi_sock"
time="2021-04-28T11:49:52Z" level=error arrayid=c************** runid=node-2 msg="Cannot read directory: /sys/class/fc_host Error: open /sys/class/fc_host: no such file or directory"
time="2021-04-28T11:49:52Z" level=info arrayid=c************** runid=node-2 msg="'FC Initiators' cannot be retrieved."
time="2021-04-28T11:49:52Z" level=info arrayid=c**************runid=node-2 msg="URI/api/instances/host/name:rzk8qaitw02?fields=id,name,description,fcHostInitiators,iscsiHostInitiators,hostIPPorts?fields"
time="2021-04-28T11:49:52Z" level=info arrayid=c************** runid=config-1 msg="Node initiators are synchronized with the Host Wwns on the array"
time="2021-04-28T11:49:54Z" level=info runid=1 msg="NodeGetInfo success"
time="2021-04-28T11:49:54Z" level=error runid=2 msg="Cannot read directory: /sys/class/fc_host Error: open /sys/class/fc_host: no such file or directory"
time="2021-04-28T11:49:54Z" level=info runid=2 msg="iSCSI/FC package found in this node proceeding to further validations"
time="2021-04-28T11:49:54Z" level=info arrayid=c************** runid=4 msg="URI/api/instances/host/name:rzk8qaitw02?fields=id,name,description,fcHostInitiators,iscsiHostInitiators,hostIPPorts?fields"
time="2021-04-28T11:49:54Z" level=info runid=2 msg="Got iSCSI Initiators, Checking health of initiators:[{HostInitiator_81}]"
time="2021-04-28T11:49:55Z" level=info runid=2 msg="iSCSI health is good for array:c**************, Health:ALRT_COMPONENT_OK"
time="2021-04-28T11:51:31Z" level=info runid=6 msg="Executing NodeGetCapabilities with args: {XXX_NoUnkeyedLiteral:{} XXX_unrecognized:[] XXX_sizecache:0}"
The CSI Socket file (/var/lib/kubelet/plugins/unity.emc.dell.com/csi_soc) does exist on the Nodes and gets mounted into the container (as an excerpt from docker inspect shows):
"Binds": [
"/var/lib/kubelet/plugins/unity.emc.dell.com:/var/lib/kubelet/plugins/unity.emc.dell.com",
"/var/lib/kubelet/plugins/kubernetes.io/csi:/var/lib/kubelet/plugins/kubernetes.io/csi:rshared",
"/var/lib/kubelet/pods:/var/lib/kubelet/pods:rshared",
"/dev:/dev",
"/:/noderoot",
"/var/lib/kubelet/pods/14807e17-afa3-448e-8162-99e074041833/volumes/kubernetes.io~projected/certs:/certs:ro",
"/var/lib/kubelet/pods/14807e17-afa3-448e-8162-99e074041833/volumes/kubernetes.io~secret/unity-config:/unity-config:ro",
"/var/lib/kubelet/pods/14807e17-afa3-448e-8162-99e074041833/volumes/kubernetes.io~secret/unity-node-token-fnvkc:/var/run/secrets/kubernetes.io/serviceaccount:ro",
"/var/lib/kubelet/pods/14807e17-afa3-448e-8162-99e074041833/etc-hosts:/etc/hosts",
"/var/lib/kubelet/pods/14807e17-afa3-448e-8162-99e074041833/containers/driver/4e01c69e:/dev/termination-log"
],
T
Responses (0)
Solutions (0)
