Announcement Banner

Marco22

updated

19 years ago

M

Marco22

13 Posts

0

9488

March 4th, 2008 08:00

Error using ¿NetWorker Module for MS SQL Server¿

I need to backup a test database created in SQLExpress 2005 installed on WinXP.
In this client is installed ¿NetWorker Module for MS SQL Server¿ v5.1, the Networker Server is running Networker 7.4 on Win2003 R2.

The backup from the client to the server using the manual backup feature of ¿NetWorker Module for MS SQL Server¿ works fine.

The scheduled backup in Networker Server doesn¿t work, it return me many errors.
According to this Article:
http://support.microsoft.com/kb/914277
I have already enabled the remote connections on SQL Server 2005.

On Networker Server the ¿save set¿ is:
MSSQL:
and the ¿Backup command¿ is:
nsrsqlsv -s NetworkerServer -U sa -P mypassword MSSQL:

This is the daemon log:

SQLpc.dhcp.yyy.company.corp Start time: Tue Mar 04 16:55:29 2008 End time: Tue Mar 04 16:55:35 2008 --- Unsuccessful Save Sets --- * SQLpc.dhcp.yyy.company.corp:MSSQL: 1 retry attempted SQLpc.dhcp.yyy.company.corp:MSSQL:: No full backups of this save set were found in the media database
SQLpc.dhcp.yyy.company.corp:MSSQL:: No full backups of this save set were found in the media database; performing a full backup
* SQLpc.dhcp.yyy.company.corp:MSSQL: 29377:nsrsqlsv:SQL database file name contained unexpected delimiting character: "company.corp"
* SQLpc.dhcp.yyy.company.corp:MSSQL: 29118:nsrsqlsv:SQL database parsing error: "NetworkerServer.yyy.company.corp"
* SQLpc.dhcp.yyy.company.corp:MSSQL: 43709:nsrsqlsv:Stop time: Tue Mar 04 16:55:31 2008
* SQLpc.dhcp.yyy.company.corp:MSSQL:
* SQLpc.dhcp.yyy.company.corp:MSSQL: 1 retry attempted
SQLpc.dhcp.yyy.company.corp:MSSQL:: No full backups of this save set were found in the media database; performing a full backup
* SQLpc.dhcp.yyy.company.corp:MSSQL: 29377:nsrsqlsv:SQL database file name contained unexpected delimiting character: "company.corp"
* SQLpc.dhcp.yyy.company.corp:MSSQL: 29118:nsrsqlsv:SQL database parsing error: "NetworkerServer.yyy.company.corp"
* SQLpc.dhcp.yyy.company.corp:MSSQL: 43709:nsrsqlsv:Stop time: Tue Mar 04 16:55:33 2008
* SQLpc.dhcp.yyy.company.corp:MSSQL:
12662 1204646135 2 0 0 3624 3620 0 NetworkerServer nsrd 39 runq: %s %s exited with return code %d. 3 0 9 NSR group 0 8 companyTestX 1 1 1
0 1204646159 2 0 0 3720 3716 0 NetworkerServer nsrmmdbd 4 %.*s 2 1 2 39 0 38 pools supported: companytest;
42506 1204646167 2 0 0 3624 3620 0 NetworkerServer nsrd 9 %s %s: %s 3 0 16 write completion 0 6 notice 49 57 9132 29 Writing to volume %s complete 1 22 11 companyTest_003



Do you have suggestions to fix this problem?


Many Thanks
Marco
  • smora1

    253 Posts

    4549

    0

    Posted March 6th, 2008 03:00

    Please Marco, try to put this on Save Set field:

    MSSQL$SQLEXPRESS:

    and run a new MSSQL backup.
  • dpinink_silva

    2 Intern

    •

    724 Posts

    4549

    0

    Posted March 4th, 2008 09:00

    Marco,

    WinXP is not supported for this module. It's strange that manual backup worked, but it's not strange to have a lot of errors when running from backup server.

    It may work with some adjustments, but I would not walk this path, you'll have no support from EMC and it's something bad, specially if you start to have errors on restores also. But you could try to use only "nsrsqlsv" on Backup Command, using MSSQL as the Saveset field, and Access field to set User/Password.

    But instead, you could think about dumping the database to a directory and having this backed up, without using the module.
  • Marco22

    13 Posts

    4549

    0

    Posted March 5th, 2008 08:00

    I have installed SQL 20005 Express updated to SP2 on Win2003Server but I receive the same error.
    I try whit a different syntax:

    Save set: MSSQL:
    Remote user: myuser
    Password: *****
    Backup command: nsrsqlsv

    But I receive a different error:

      SQLserver.YYY.company.corp:MSSQL:: No full backups of this save set were found in the media database; performing a full backup
    * SQLserver.YYY.company.corp:MSSQL: 43708 1204729126 1 0 0 1288 3440 0 SQLserver nsrsqlsv 14 Start time: %s 1 35 25 Wed Mar 05 15:58:46 2008
    * SQLserver.YYY.company.corp:MSSQL:
    * SQLserver.YYY.company.corp:MSSQL: 43621 1204729126 1 0 0 1288 3440 0 SQLserver nsrsqlsv 35 Computer Name: %s     User Name: %s 2 12 8 SQLserver 13 8 myuser
    * SQLserver.YYY.company.corp:MSSQL: 29085 1204729138 5 0 0 1288 3440 0 SQLserver nsrsqlsv 36 Microsoft SQL Server Provider error: 0
    * SQLserver.YYY.company.corp:MSSQL: 38006 1204729138 5 0 0 1288 3440 0 SQLserver nsrsqlsv 3 %s. 1 24 69 Named Pipes Provider: Could not open a connection to SQL Server [2]. 
    * SQLserver.YYY.company.corp:MSSQL: 38006 1204729138 5 0 0 1288 3440 0 SQLserver nsrsqlsv 3 %s. 1 24 221 An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections.
    * SQLserver.YYY.company.corp:MSSQL: 38006 1204729138 5 0 0 1288 3440 0 SQLserver nsrsqlsv 3 %s. 1 24 21 Login timeout expired
    * SQLserver.YYY.company.corp:MSSQL: 37955 1204729138 5 0 0 1288 3440 0 SQLserver nsrsqlsv 32 \nCannot login to SQL Server %s. 1 12 4 null
    * SQLserver.YYY.company.corp:MSSQL: 43709 1204729138 1 0 0 1288 3440 0 SQLserver nsrsqlsv 13 Stop time: %s 1 35 25 Wed Mar 05 15:58:58 2008
    * SQLserver.YYY.company.corp:MSSQL:
    


    On the MS SQL the SQLBrowser service is up and running, the SQL Remote Connection are enabled for TCP/IP and named pipes and no firewall is running, I can¿t understand these login problems.

    Please see also the fourth row of the log, the username contain extra word like SQLServer, is this normal?

    Many Thanks
    Marco
  • smora1

    253 Posts

    4549

    0

    Posted March 5th, 2008 08:00

    Marco,

    Try with Remote User: domain\myuser

    Have you run a server-initiated filesystem backup of MSSQL Server machine? It could be a network resolution issue from NW Server to MSSQL Server...
  • Marco22

    13 Posts

    4549

    0

    Posted March 5th, 2008 09:00

    Thank You for the quick reply, the authentication method of MS SQL is mixed (SA+Windows authentication).

    I try with the following users:

    Domain\Myuser
    Myuser@Domain.corp
    Myuser
    SA
    sa


    With first,second and third user I receive the same error:
    Microsoft SQL Server Provider error: 0
    Named Pipes Provider: Could not open a connection to SQL Server [2]. 
    An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections.
    Login timeout expired
    \nCannot login to SQL Server 
    


    With the fourth and the fifth user, or if I write a wrong password with the 1-2-3th user, I receive this error:
    Probe job had unrecoverable failure(s)
    



    P.S.
    If I run a manual backup from the SQL machine to Networker server it runs fine.
    If I run a scheduled backup from Networker server to backup various directory on SQL machine it runs fine.
    The name resolution between the servers is ok.


    Many Thanks
    Marco
  • smora1

    253 Posts

    4549

    0

    Posted March 6th, 2008 01:00

    Have Marco tried to do this:

    http://support.microsoft.com/kb/914277/en-us

    Nevertheless can you run on MSSQL Server the following command:

    net start

    and put here the outcome?
  • Marco22

    13 Posts

    4549

    0

    Posted March 6th, 2008 02:00

    Hello Sergio, according to my first post I have already check the MS Article ID 914277.

    There are the services running on SQLserver:

     These Windows services are started:
     
       Altiris Agent
       Application Experience Lookup Service
       Application Layer Gateway Service
       Automatic Updates
       COM+ Event System
       Computer Browser
       Cryptographic Services
       DCOM Server Process Launcher
       DHCP Client
       Distributed Link Tracking Client
       Distributed Transaction Coordinator
       DNS Client
       Error Reporting Service
       Event Log
       File Server Resource Manager
       Help and Support
       IPSEC Services
       Logical Disk Manager
       McAfee Framework Service
       Net Logon
       Network Associates McShield
       Network Associates Task Manager
       Network Connections
       Network Location Awareness (NLA)
       NetWorker Power Monitor
       NetWorker Remote Exec Service
       Plug and Play
       Print Spooler
       Protected Storage
       Remote Access Connection Manager
       Remote Procedure Call (RPC)
       Remote Registry
       Secondary Logon
       Security Accounts Manager
       Server
       Shell Hardware Detection
       SQL Server (SQLEXPRESS)
       SQL Server Browser
       SQL Server VSS Writer
       Symantec Ghost Configuration Server
       Symantec Ghost Database Service
       System Event Notification
       Task Scheduler
       TCP/IP NetBIOS Helper
       Telephony
       Terminal Services
       Windows Audio
       Windows Firewall/Internet Connection Sharing (ICS)
       Windows Management Instrumentation
       Windows Time
       Wireless Configuration
       Workstation
     
    The command completed successfully. 
    


    This is the result of a port scan from Networker Server to SQL server:
    TCP ports (5) 111,135,139,445,3389
    UDP ports (8) 111,123,137,138,445,500,1025,1434


    This is the local port of SQL Server:
    nwmssql.exe:2904 TCP 10.29.128.21:29261 10.29.128.15:8485 ESTABLISHED
    sqlbrowser.exe:1936 UDP 0.0.0.0:1434 *:*
    sqlservr.exe:1504 TCP 0.0.0.0:1057 0.0.0.0:0 LISTENING


    According to this MS Article:
    http://support.microsoft.com/kb/287932
    The standard post is 1433, but in my server the port is 1434, it¿s normal?

    Message was edited by:
    Marco2
  • Marco22

    13 Posts

    4549

    0

    Posted March 6th, 2008 04:00

    Great, with this syntax the backup works fine :-)
    Thank you for your help, this syntax isn¿t present in the manual.

    Many Thanks
    Marco
  • Finnigan1

    1 Message

    4549

    0

    Posted March 6th, 2008 08:00

    FYI, this is in the manual (at least for SQL 4.1). "Syntax for a Named Instance Configuration for SQL 2000". The default (un-named) instance is what's saved when you specific MSSQL: , but if you have named instances (which is what your version of SQL Express installed), then it installs a named instance, named SQLEXPRESS