Announcement Banner
UNSOLVED

Kaiser_Kamal

updated

10 years ago

K

Kaiser_Kamal

1 Rookie

•

46 Posts

0

8088

April 30th, 2015 01:00

Hyper V Backup Failing

Hyper v CSV Backup failing on 2012 R2 Networker 8.2.1

ERROR:

APPLICATIONS:\Microsoft Hyper-V: Backup of [APPLICATIONS:\Microsoft Hyper-V] failed

ormation parameter: NSR_SAVE_FROM_SAVEGRP_NSRSNAP, may not be supported

102345:nsrsnap_vss_save:Data mover host name not specified. Assuming local host: asd-host-hv6.asd.com

102338:nsrsnap_vss_save:Backup is level FULL. Set GLR compatibility to YES.

85460:nsrsnap_vss_save:NMM .. Valid snapshot policy for Federated backup. Group: "HYPERV ASD DR" Snapshot Policy: "RolloverOnly" Snapshots Per Day: "1"  Retain: "0" Backup Snapshots: "All" Level: "full".

This is a federated backup for Hyper-V CSV.

Non-CSV VMs, Application savesets and other File System savesets will be skipped from the backup operation.

The list of Modified Proxy Server are:

asd-host-hv6.asd.com

Starting slave backup job on host : asd-host-hv6.asd.com.

51340:nsrsnap_vss_save:jobhandler(305): Created Job ID: 163060

  Save command: nsrsnap_vss_save.exe -s afg-nw-dr.asd.com -g "HYPERV ASD DR" -m ASD-HV-CLS.asd.com -l full -W 78 -LL -z ASD-HV-CLS.asd.com -A optype=conventional -A NSR_SAVE_FROM_SAVEGRP_NSRSNAP=Yes -A NSR_SNAP_TYPE=vss -A NSR_FEDERATED_BACKUP=yes -A NSR_PARENT_JOBID=163055 -A snap_sessionid=1430334074 -A NSR_SAVE_FROM_SAVEGRP_NSRSNAP=Yes -A NSR_PS_DEBUG_ID=1430334070 -A NSRSNAP_JOBID=163057 -A *GLR_OFFSET_MAP=Yes -A NSR_INDEX_CLIENT=ASD-HV-CLS.asd.com -c asd-host-hv6.asd.com "APPLICATIONS:\\Microsoft Hyper-V\\MSALES-RDB-

Signal message recieved from : asd-host-hv6.asd.com.

95937:nsrsnap_vss_save:A slave job failure has been identified, stopping all slave jobsNMM...Hyper-V CSV backup failed on Node '', Please check NMM.raw file for more details.

96821:nsrsnap_vss_save:NMM...Hyper-V CSV backup failed on Node '', Please check NMM.raw file for more details.

Internal error.

102333 1430334406 3 0 0 7104 3892 0 asd-host-hv6.asd.com nsrsnap_vss_save NSR error 21 Exiting with failure. 0

  • CarlosRojas

    1 Rookie

    •

    1693 Posts

    2365

    0

    Posted April 30th, 2015 02:00

    Hi @Kaiser_Kamal,

    This indicates a failure on the other node:

    nsrsnap_vss_save:A slave job failure has been identified, stopping all slave jobsNMM...Hyper-V CSV backup failed on Node '', Please check NMM.raw file for more details.

    Can you please check the nmm.raw file (rendered) in all nodes?

    Also, can you please give us some more details on the environment?

    Thank you,

    Carlos

  • CarlosRojas

    1 Rookie

    •

    1693 Posts

    2365

    0

    Posted April 30th, 2015 02:00

    This is a permissions issue:

    NMM enabling the Automount feature failed with Error(ASD-HOST-HV8.ASD.COM : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))).

    As a test you can add *@* in the physical nodes and virtual node client entries under remote access, however I believe that the user you added into remote user has not the right permissions.

    In fact, have you added any user name under remote user field in the clients configuration?

    If so please make sure that user has the right permissions.

    Thank you,

    Carlos

  • Kaiser_Kamal

    1 Rookie

    •

    46 Posts

    2365

    0

    Posted April 30th, 2015 02:00

    Hi Carlos

    Nmm Attached from the active node .

    Please let me know what more details is required.

    Best Regards

    Kaiser Kamal

    1 Attachment

  • CarlosRojas

    1 Rookie

    •

    1693 Posts

    2365

    0

    Posted April 30th, 2015 03:00

    Hi,

    The NMM Hyper-V CSV backup and recovery requires an account with privileges beyond the normal NetWorker privileges for backup and recovery of the Hyper-V CSV components.  You must create a Domain User for Hyper-V CSV backups and recoveries and during client resource configuration for NMM Hyper-V backups, provide this Domain User account and password for backup and recovery. 
    The procedure below provides an overview of the requirements and the following sections provide details about the steps to establish the account.

    Procedure

    1. Create a Domain User for Hyper-V backups and recoveries.  The account only needs login name and password.
    2. The Domain User account must be added to the these Active Directory Users and Computers Builtin security groups:
      1. Backup Operators
      2. Hyper-V Administrator
      3. Windows Authorization Access Group
      4. Users
      5. Remote Desktop Users
    3. Also add the Group
      Policy Creator Owners
      security group to the Domain User account
    4. On each cluster node, log in and perform steps to add the Domain User account to the local node’s
      1. Users group
      2. Administrators group
      3. Hyper-V Administrators group
    5. Provide access for cluster management to the Domain User account, using the Grant-ClusterAccess PowerShell command.

    Thank you,

    Carlos

  • Kaiser_Kamal

    1 Rookie

    •

    46 Posts

    2365

    0

    Posted April 30th, 2015 03:00

    @ is already added

    under remote user it is blank.

    I have a permissions as a backup admin.

    Best Regards

    Kaiser Kamal

  • Kaiser_Kamal

    1 Rookie

    •

    46 Posts

    1472

    0

    Posted April 30th, 2015 03:00

    Hi Carlos

    What type of permissions I should have.

    Best Regards

    Kaiser Kamal

  • Kaiser_Kamal

    1 Rookie

    •

    46 Posts

    2365

    0

    Posted April 30th, 2015 09:00

    Hi Carlos

    I will contact with AD admin and come back to you on Monday ,

    Best Regards

    Kaiser Kamal

  • sddc_guy

    159 Posts

    2365

    0

    Posted April 30th, 2015 11:00

    I would recomment using this posts from me for Troubleshooting guidelines:

  • CarlosRojas

    1 Rookie

    •

    1693 Posts

    1874

    0

    Posted May 5th, 2015 02:00

    Excellent.

    Thank you,

    Carlos

  • Kaiser_Kamal

    1 Rookie

    •

    46 Posts

    2365

    0

    Posted May 5th, 2015 02:00

    Hi Carlos

    We have applied the permission today and update you .

    Best Regards

    Kaiser Kamal

    From: Kaiser Kamal

    Sent: Thursday, April 30, 2015 7:12 PM

    To: 'jive-1315396178-amr0-2-iwsf@emc-ecn.hosted.jivesoftware.com'

    Subject: RE:  - Hyper V Backup Failing

    Hi Carlos

    I will contact with AD admin and come back to you on Monday ,

    Best Regards

    Kaiser Kamal