Announcement Banner
UNSOLVED

Gcm111

updated

13 years ago

G

Gcm111

5 Posts

0

996

June 24th, 2013 01:00

VSS SYSTEM FILESET

Hi,

I am stuck with this issue about missing files for VSS SYSTEM FILESET, I have googled around and found that the easiest way to resolve this is to create dummy files.

Other than running the job and waiting for the error messages on the missing files, is there a way to list down the missing files?

Have tried going to the pnplockdownfiles but it seems like not all missing files are there. Any help is very much appreciated as I have potential over 20 servers to fix.

Another issue, most of my clients with missing files for the VSS are flagged as successful under NMC, running 7.5.2, with a couple of clients flagged as failed.

I have upgraded to 7.6.5 on another backup with all clients(7.6.5) and they all flagged as failed till I created all dummy files. Is there any issue with 7.5.2?

Best regards,

CM

  • christopher_ime

    6 Operator

    •

    1962 Posts

    550

    0

    Posted June 26th, 2013 00:00

    CM,

    Please consider moving this question to the proper forum for maximum visibility.  Questions written to the users' own "Discussions" space don't get the same amount of attention and questions can go unanswered for a long time.  You can do so by selecting "Move" under ACTIONS along the right.  Then search for and select: "NetWorker Support Forum" which would be the most relevant for this question.  There is also a recent post demonstrating the steps to do the same:

    EMC Community Network Frequently Asked Questions

  • Gcm111

    5 Posts

    550

    0

    Posted June 26th, 2013 01:00

    Thanks

  • Gcm111

    5 Posts

    550

    0

    Posted June 26th, 2013 04:00

    Hi Carlos,

    Thanks for replying.

    I have added the backup command previously but still encounter the same issue.

    Best regards,

    Chi Meng

  • CarlosRojas

    1 Rookie

    •

    1693 Posts

    550

    0

    Posted June 26th, 2013 04:00

    Hi gcm11,

    This is a known issue with VSS.

    After for example uninstallation of a piece of software, the files get removed, however the registry doesn't get cleaned up and there are still pointers to those files in the registry so, when the System Writer tries to backup those files, it fails as the files are no longer there.

    The easiest fix is to set the following backup command (in NW client):

    save -a '"ignore-all-missing-system-files=yes"'

    Please note that this is single quote, double quote, command, double quote, single quote.

    Thank you,

    Carlos

  • CarlosRojas

    1 Rookie

    •

    1693 Posts

    550

    0

    Posted June 26th, 2013 05:00

    Hi Chi Meng,

    I guess most likely you are hitting the problem described in EMC KB esg115382 and MS KB  http://support.microsoft.com/kb/980794

    Please apply those changes and let us know how it goes.

    Thank you,

    Carlos

  • bingo.1

    1 Rookie

    •

    2430 Posts

    550

    0

    Posted June 26th, 2013 07:00

    It could be that there is an issue with the VSS System Writer not working correctly. May i suggest that you run "vssadmin list writers" and check the output.

    In case of an error, you want to re-register the writer on the client as follows:

    Windows 2003

    cd /d %windir%\system32
    Net stop vss
    Net stop swprv
    regsvr32 ole32.dll
    regsvr32 oleaut32.dll
    regsvr32 vss_ps.dll
    vssvc /register
    regsvr32 /i swprv.dll
    regsvr32 /i eventcls.dll
    regsvr32 es.dll
    regsvr32 stdprov.dll
    regsvr32 vssui.dll
    regsvr32 msxml.dll
    regsvr32 msxml3.dll
    regsvr32 msxml4.dll      (might fail if not installed)

    net stop cryptsvc
    net start cryptsvc

    net stop nsrexecd
    net start nsrexecd

    worst case you might need to restart the client

    Windows 2008

    takeown /f %windir%\winsxs\filemaps\* /a
    icacls %windir%\winsxs\filemaps\*.* /grant "NT AUTHORITY\SYSTEM:(RX)"
    icacls %windir%\winsxs\filemaps\*.* /grant "NT Service\trustedinstaller:(F)"
    icacls %windir%\winsxs\filemaps\*.* /grant BUILTIN\Users:(RX)
    net stop cryptsvc
    net start cryptsvc

    net stop nsrexecd
    net start nsrexecd