
Attachment uploads are currently disabled. This is a temporary situation and will resume as normal in the coming days.
UNSOLVED
Poweredge 1950 drac5 web interface not working
Hi,
Problem is same as descripted in here:
http://en.community.dell.com/support-forums/servers/f/956/t/19273095
"Drac module doesn't respond to http or https requests"
I scanned servers IP with nmap and only ports 22 and 5900 are open.
So it is answering to ssh and telnet but not hosting web service.
Tried everything that was suggested in this thread.
http://community.spiceworks.com/topic/318572-drac-5-issue-not-responding-to-http-https
- soft reset (racadm racreset)
- hard reset (racadm racresetcfg)
- clearing RAC logs (racadm clrraclog)
- clearing SEL (racadm clrsel)
- updating firmware (RACADM FWUPDATE -g -p -a IP_ADDRESS)
So is there command to start web service or something else i should try before giving up and buying external kvm?
Responses (5)
Solutions (0)
DELL-Shine K
6 Operator
•
3042 Posts
2027
0
Posted May 17th, 2015 22:00
Taddu,
Can you also check the output of below command and make sure web server is enabled on iDRAC.
racadm getconfig -g cfgRacTuning
Reply Here is output semmes like webserver is enabled.
$ racadm getconfig -g cfgRacTuning
cfgRacTuneRemoteRacadmEnable=1
cfgRacTuneWebserverEnable=1
cfgRacTuneHttpPort=80
cfgRacTuneHttpsPort=443
cfgRacTuneTelnetPort=23
cfgRacTuneSshPort=22
cfgRacTuneConRedirEnable=1
cfgRacTuneConRedirPort=5900
cfgRacTuneConRedirVideoPort=5901
cfgRacTuneConRedirEncryptEnable=0
cfgRacTuneLocalServerVideo=1
cfgRacTuneIpRangeEnable=0
cfgRacTuneIpRangeAddr=192.168.1.1
cfgRacTuneIpRangeMask=255.255.255.0
cfgRacTuneIpBlkEnable=0
cfgRacTuneIpBlkFailCount=5
cfgRacTuneIpBlkFailWindow=60
cfgRacTuneIpBlkPenaltyTime=300
cfgRacTuneTimezoneOffset=0
cfgRacTuneDaylightOffset=0
cfgRacTuneAsrEnable=0
cfgRacTuneCtrlEConfigDisable=0
cfgRacTuneLocalConfigDisable=0
cfgRacTunePluginType=0Also tested on chrome and IE.
Getting ERR_CONNECTION_REFUSED
Reply DELL-Shine K
6 Operator
•
3042 Posts
2027
0
Posted May 19th, 2015 10:00
What is the firmware version installed on iDRAC.
One thing you can try is disabling and enabling web server and see whether that fixes the issue
racadm config -g cfgRacTuning -o cfgRacTuneWebserverEnable 0
racadm config -g cfgRacTuning -o cfgRacTuneWebserverEnable 1
Reply ethanvanmatre
1 Message
1586
0
Posted December 19th, 2018 13:00
I've been working this issue as well and not found anything useful on the web. However I did find a solution that worked for me.
Using "racadm racdump" I noted that the webserver process was not running. On a hunch I thought that the webserver was failing due to a configuration issue so I issued a "racadm sslresetcfg" to Restores the web-server certificate to factory default and restarts the web-server. From there restart the DRAC with "racadm racreset" and all is well.
So the commands are:
racadm racdump
racadm sslresetcfg
racadm racreset
Might work for you.....
Reply

DELL-Chris H
7 Practitioner
•
9682 Posts
•
48046 Points
2027
0
Posted May 15th, 2015 09:00
Taddu,
The issue will likely be due to the ports that are open. Below you will see the Drac 5 Listening Ports, as well as the Client Ports.
* Configurable port
and
Please verify that the necessary ports, such as 80 and 443 are open.
Also, what are you seeing when you attempt to connect, and on what browser?
Let me know.
DELL-Chris H
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#IWork4Dell
Did I answer your query? Please click on ‘Mark as Accepted Answer’. ‘Thumbs up’ the posts you like!