
Attachment uploads are currently disabled. This is a temporary situation and will resume as normal in the coming days.
UNSOLVED
VNX Replicator and Usermapper
I'm trying to get a firm understanding of where usermapper actually comes into play.
I totally understand the need for usermapper in multiprotocol environments and with quotas which explicitly reference the unix UID. However, in a windows only environment, standard access checking with no quotas, which is replicated, is there a compelling reason to do this?
I see in the user mapping PDF:
"For connections from Windows users, file access checking is performed by using SIDs only. This is done to prevent errors due to UID mismatches and to reduce dependency on the Usermapper database."
So it is not possible e.g. that I am userid 40000 on primary VNX and joe is userid 40001, and on the secondary VNX I happen to be user 40001 and get access to all of Joe's files, right?
Standard windows domain only with no quotas represents a massive portion of the environments I work in, and unless I see the benefit of configuring primary/secondary usermappers I feel like it just adds an additional layer of complexity/potential failure point if there is an actual disaster and you have to failover.
Am I missing something in this standard but replicated scenario? I'm weighing my observations against a lot of documentation which seems to greatly encourage the usermapper setup in Windows only environments, and just find myself confused.
Responses (0)
Solutions (0)
