Start a Conversation

Solved!

Go to Solution

Closed

18 Posts

85326

January 24th, 2019 09:00

Can't Install Alienware OC controls

Hi.

Before I state my issue I just wanna say that I already contacted the technical support and they refused to help me because I moved to another country after I bought my laptop in the US and I was told that my hardware warranty was basic and I needed to upgrade it even though I was contacting them for a software related issue.

Anyway, my problem was that after I opened Alienware Command center, It told me that some additional component needed to be downloaded. I pressed OK and it downloaded a OC controls version. While trying to install it it refused, saying that I already had a version of OC controls and it needs to be uninstalled using windows apps uninstall. So I did that and I went back to install the new version but I kept having the same error. I also uninstalled Alienware control center ( not command center ) and I does not want to install too. I also tried to install them via windows store but they won't.

I really need to fix this problem because I can't track my temperature access my overclocking anymore and it really bothers me..

Thank you for all of you out there who are willing to help.

PS: I shared a link for the log file of the installation.

https://drive.google.com/open?id=1O9Pz6M1Ja3A7ZvyLHmE0RfdhtaYS07mQ

18 Posts

January 25th, 2019 07:00

Reinstalling does not help.

But I fixed the problem by uninstalling Microsoft Visual C++ 2017. Found somewhere that it does not allows C++ 2015 to run and AWCC needs it.

So to summaries, I uninstalled MV C++ 2017 and I managed to install OC controls.

I don't really understand a thing at this but i am glad it worked.

Thank you all.

1 Message

June 5th, 2019 13:00

Had the same issues (Command Center reports need to update OC Controls and update fails).

Uninstalled Alienware OC Controls and installed the earlier linked version, which at least brought back the update notification.

Instead of letting it update when notified, I chose the option to extract the update to a folder.

Rebooted and installed the extracted file manually (success), and rebooted.

Command Center now works normally, detects temps, etc.

1 Message

July 16th, 2019 06:00

I had the same problem with my Aurora R8....tried and tried.  No thermal or OC controls. Finally, I tried the simplest way last (I have a tendency for that....lol).  Anyway, I went to add/remove program and to Alienware OC. I removed that program, and restarted.  I did not go to Alienware update to d/l the program.  I opened up the AW Command center (took about 30 sec or so to load).  When it opened, it stated I had missing components and asked if I wanted to download.  I said yes, it installed, and I restarted.  Works like a charm again!

10 Posts

January 24th, 2019 13:00

Personal experience has shown that the software is complete and total garbage!

I suggest using the BIOS to set any OC settings you may want. It is under advanced/performance on most.

If this isn't the case for you, sorry!

3 Apprentice

 • 

4.4K Posts

January 24th, 2019 14:00

Hi @Kiraness,

Try the following steps:

  1. Uninstall 'Alienware Command Center Suite' and 'Alienware OC Controls' from the 'Apps & features'
  2. Restart system
  3. Download AWCC 5.2.1.0 and OC Controls 1.1.11.1110 from eSupport site. Here are the download links.
    AWCC
    OS Controls
  4. Install AWCC 5.2.1.0 then OC Controls 1.1.11.1110.

1 Rookie

 • 

1 Message

19-05-2024 04:51 AM

@Alienware-Eimy​ Thank you! I nearly reverted back to the older Windows 11 version... I spent hours looking for a solution, and I finally found it.

1 Message

April 22nd, 2019 14:00

I don't appear to have MV C++2017 installed.  I have....

Microsoft Visual C++2010 x86 Redistributable - 10.0.30319

Microsoft Visual C++2012 Redistributable (x64) - 11.0.61030

Microsoft Visual C++2012 Redistributable (x86) - 11.0.61030

Microsoft Visual C++2013 Redistributable (x64) - 12.0.30501

Microsoft Visual C++2013 Redistributable (x86) - 12.0.30501

Microsoft Visual C++2015 Redistributable (x64) - 14.0.24215

Microsoft Visual C++2015 Redistributable (x86) - 14.0.24212

I still can't update the AWOC controls.  Can anyone help?

1 Message

April 27th, 2019 15:00

Uninstall the Alienware OC Controls application and you will be able to do the update. I just uninstalled the Alienware OC Controls application in "Programs and Features" and I was able to update. 

 

I hope that helps. 

Thanks! 

1 Message

April 30th, 2019 17:00

I was able to install Alienware OC controls but i cant find it anywhere to run the program now.  any help ?

3 Apprentice

 • 

4.4K Posts

May 1st, 2019 08:00

Hi @SmokedNaga

 

Alienware OC controls are part of the Alienware Command Center. There's no standalone OC Control Software.

 

1 Message

May 6th, 2019 07:00

hi, thanks for posting this. I have a few questions.

I can install and use Alienware command center, and change the thermal settings, and battery settings. Keyboard works fine to. My only problem is OC.

I have OC just installing. It will install, send me a notification that its been updated, but I can't still can't OC.

I do not have "Mircosoft visual c++" Installed. please help asap. Ive also been having some performance issues.

Brand new laptop. Alienware M15, Nividia GeForce gtx1060. Running at like 30 fps. Super annoying

7 Technologist

 • 

4.4K Posts

May 7th, 2019 20:00

Hi, 

You can only use the OC settings if you have an overclock-able K series processor, please check which type of processor is in your system configuration. 

2 Posts

August 9th, 2019 22:00

Hi, thanks for your post, solved my problem as well. Seems the 2015 and later MS Visual C++ Redistributables are different from all previous versions:

https://support.microsoft.com/en-nz/help/2977003/the-latest-supported-visual-c-downloads

In my case, I removed the 2017 packages and installed the 2015 (not the 2015, 2017, and 2019 combined, as per link above)

Now Command Centre detects my keyboard and mouse again and I have the FX option for lighting available again.

Before I came across your post I tried everything and nothing seemed to work (uninstalls, reinstalls, MS Store installs, different sequences and reboots, etc...)

Might try the latest 2019 package (rather than the 2017 that was causing the issue) and fingers crossed that it works as well as the 2015 package.

Thanks again.

2 Posts

August 9th, 2019 23:00

Just an update; The 2015-2019 Redistributable also works for me. When installed, it replaced the 2015 that I had installed to fix the earlier issue. Hope this helps someone else. Cheers.

1 Message

November 18th, 2019 14:00

It works for me!! thanks

No Events found!

Top