
Solved!
Go to SolutionD
DmitriKuznetsoi
14 Posts
0
2776
December 23rd, 2011 05:00
Event based retention (Failed to commit XSet: = -10158) anomaly
Hi, I just have encountered a weird anomaly with our in-house centera servers.
I have implemented a feature for saving files with event based retention (this is the core requirement) and it can be set at any time (during creation, or after creation)
When I tested my implementation on EMC test clusters, my solution worked correctly, however with our in-house servers I have encountered an error when doing commit (Failed to commit XSet: = -10158).
Now what is even worse than that, is that once I get this error, every other test case fails with other errors. Test cases are executed as one-by-one as usual, so it seems this error has an impact on server stability ! If i run these test cases again, but without running the first one, they work.
The code itself works this way (just simplified)
- Connect with centera server
- Write field with string value - just for verify it later
- Create retention policy "event"
- Set enabled flag
- Set duration
- Specify retention start
- Commit xset - FAILS!
Anyone has any clue what is going on ?
Responses (0)
Solutions (0)
