Start a Conversation

Solved!

Go to Solution

Closed

30 Posts

111328

September 22nd, 2020 15:00

Screen Black After Dell Logo

Hello Dell,

When I start my laptop, screen goes black after dell logo. F2 and F12 nothing key works only screen black

 

March 18th, 2022 05:00

First of All Download Downgrade Bios Version rcv (recovery) file "BIOS_IMG.rcv" from dell drivers and download section. after that make a bootable usb drive

boot now with USB and downgrade the bios easily

Moderator

 • 

25K Posts

March 18th, 2022 06:00

Appreciate your help so much.

 

Thank you.

September 14th, 2022 06:00

I recently hit this problem, but it was the Dell 19" monitor (12 years old as of 2022) that actually was turning the screen off after being at any resolution for a few seconds, which is why this problem appeared after the loading BIOS screen.  We tried new video card and same issue, but once we hooked up to different monitor, it 'stayed on' just fine in BIOS menu and in Windows 10.  The fact it was working fine for 12 years is actually pretty impressive.

1 Message

November 21st, 2022 08:00

To make it a bit easier to use this simple fix, first hit F2, open the Maintenance item, and click "BIOS downgrade."  Then on the right, unclick the checkbox at top and allow the downgrade.  Simple and it works!

1 Message

May 4th, 2023 07:00

I finally figured this one out. If you just get a black screen after the dell logo flashes on the screen, but you can still access the bios via F2, or F12, but if you go into the flash bios option from the F12 but then you still get a black screen, or a black screen with the arrow in the middle, then remove the hard drive and try it again. once I removed the SATA hard drive, I was able to downgrade the bios, and re-flash it with the newest BIOS update from dell's website. After flashing it with the most up to date bios, I had to use a different SATA hard drive because the original one was dead and gave me the same black screen once I put it back in. I put in a different hard drive then re-installed windows on it, now it works fine.  

No Events found!

Top