I have installed the Isilon powerscale in VMware fusion and I have created an NFS export. But when I try to mount it from the client host am getting the below error.
Isilon host IP: 192.168.237.52
external network pool IP: 192.168l237.71
Error from client host:
showmount -e 192.168.237.71
clnt_create: RPC: Program not registered
~# showmount -e 192.168.237.52
clnt_create: RPC: Program not registered
# mount -o vers=3,udp 192.168.237.71:/ifs/k8s-az /tmp/nfs-isilon -v
mount.nfs: timeout set for Wed Jan 19 14:40:26 2022
mount.nfs: trying text-based options 'vers=3,udp,addr=192.168.237.71'
mount.nfs: prog 100003, trying vers=3, prot=17
mount.nfs: portmap query failed: RPC: Program not registered
mount.nfs: requested NFS version or transport protocol is not supported
The first link is not working for me getting "This article is permission based. Find another article." error and the second link doesn't have any information about Isilon NFS configuration or the issue which I mentioned.
When you try to mount the cluster via NFS, you receive an error similar to the following:
[udp] :/ifs: RPCPROG_NFS: RPC: Program not registered
This can occur if there are Network File System Datagram (NFSD) issues on the node. This article provides some troubleshooting steps that you can perform when NFS clients are unable to mount directories from an Isilon node.
The steps apply to all versions of OneFS, and all Unix or Linux clients.
Resolution
Procedure
Open an SSH connection on any node in the cluster and log on using the "root" account.
Run the following command to confirm the NFS service is enabled:
isi services nfs
If the service is enabled, output similar to the following will display:
Service 'nfs' is enabled.
NOTE If the NFS service is disabled, run the following command to enable it:
isi services nfs enable
If the NFS service was disabled, enabling it might resolve your issue.
To determine the ports used by NFS daemons, run the following command:
rpcinfo -p
The output should contain entries for all of the NFS daemons:
portmapper
nlockmgr
mountd
nfs
IMPORTANT! Record the port numbers for each of the daemons. You will use the port numbers in subsequent steps.
If the rpcinfo command does not return any information for NFS, perform the following procedure.
Run the following command:
killall -9 nfsd
Wait 20 seconds and then run the following command to confirm whether NFS is now bound to port 2049:
rpcinfo -p
If the rpcinfo command returns information for NFS, try mounting the cluster again.
NOTE For the remaining steps, <IP_address> is the IP address of the cluster node which you are testing.
If a step fails, address that issue and then retest the NFS mount before proceeding to the next step. For example, if you cannot ping a node, address the node ping issue and then restest the mount. If the mount still fails, proceed to the next step. If the mount succeeds, then no further steps are necessary.
Attempt to ping the node from the client computer, using the hostname of the node, then the IP address of the node:
ping
ping
Test connectivity to the portmapper daemon by making a telnet connection to the portmapper port:
telnet
For example, assuming port 111 in the rpcinfo output above:
telnet 123.456.789.12 111
Output similar to the following will display if connectivity fails:
telnet: Unable to connect to remote host
Test connectivity to themountd daemon by making a telnet connection to the TCP mountd port:
telnet
For example, assuming port 676 in the rpcinfo output above:
telnet 123.456.789.12 676
Test connectivity to the nlockmgr daemon by making a telnet connection to the TCP nlockmgr port:
telnet
For example, assuming port 834 in the rpcinfo output above:
telnet 123.456.789.12 834
Test connectivity to thenfs daemon by making a telnet connection to the TCP nfs port:
telnet
For example, assuming port 2049 in the rpcinfo output above:
telnet 123.456.789.12 2049
On a Linux/Unix client computer, attempt to mount /ifs/ (assuming that there is an export entry for /ifs/ which allows access by the client computer; if not, create one):
mount :/ifs /mnt
To to create an /ifs/ export, open the Isilon web administration interface and do one of the following:
In OneFS 7.0.x and later, clickProtocols > UNIX Sharing (NFS) > NFS Export > Add an export. See the OneFS online documentation for the procedure, Add an NFS export.
In OneFS 6.5.x and earlier, click File Sharing > NFS > Add Export. See the OneFS online documentation for the procedure, Add an NFS export.
Repeat steps 4-9, above, while performing a packet capture of all traffic between the Linux/Unix client computer and the cluster node. The packet capture can be used by Isilon Technical Support for further troubleshooting, if needed. Below is an example packet capture (tcpdump) command run on the cluster node, using the em0 network interface. Note the"-s0" tcpdump argument, which indicates to not truncate any packet data.
tcpdump -ni em0 -s0 -w tcpdump.OUT host
If you complete all of the steps without discovering the cause of the mount failures, contact Isilon Technical Support for assistance and send them the packet capture.
DELL-Sam L
Community Manager
•
8095 Posts
•
34547 Points
1605
0
Posted January 19th, 2022 13:00
Hello rayanp,
Here are a couple of links to kb’s that maybe of assistance.
https://dell.to/3FIOkJO
https://dell.to/33SCRKn