Start a Conversation


This post is more than 5 years old

4 Operator


783 Posts


June 27th, 2017 13:00

Dell M.2 FAQ regarding AHCI vs RAID ON, Storage Drivers, M.2 Lanes, Performance and more

Good day Dell Community,

Over time I’ve received a lot of questions about M.2 drives so I wanted to share some of what I have learned. I will explain in a kind of question/answer format:


What is Dell’s scope of support for the Samsung and Toshiba/OZC NVME drivers posted on these Manufacturers’ websites?
Toshiba/OCZ: (To get the NVME driver select OCZ RD400/400A in the drop down)
Note: Samsung’s explanation of what their NVME driver actually does is on page 22 of the following document:
Keep in mind:
• There exists Dell branded OEM Samsung and Dell branded OEM Toshiba M.2 drives as well as               non-Dell-branded Samsung and non-Dell-branded Toshiba retail drives
• The drivers in question linked above will load for both Dell OEM drives and retail drives alike
• The Samsung and Toshiba/OZC drivers in question can only be used when running in AHCI mode
• These drivers do not apply when running in RAID ON mode as the M.2 drives will be operating under IRST in RAID on mode
Dell does not support the Samsung and Toshiba/OZC drivers for use in AHCI mode. Dell systems with Dell OEM Samsung or Dell OEM Toshiba drives running in AHCI mode will use a Windows inbox driver called stornvme. Stornvme is the driver Dell supports in AHCI mode. Use of the Samsung and Toshiba/OZC drivers will ultimately be decided at end user discretion.

What are some differences between AHCI and RAID ON modes?
Keep in mind:
• Dell systems ship from the factory with the SATA operation mode set to RAID ON
• There exists M.2 SATA and M.2 NVME ( PCIE ) drive types
• Some Dell system models will support both M.2 SATA and M.2 NVME ( PCIE ) drive types while other     Dell system models will only support M.2 SATA drives
• If a Dell system’s M.2 connector supports NVME there will usually be backwards compatibility with         M.2 SATA drives
• The RAID ON controller and AHCI controller each have different hardware IDs and therefore each controller will require different INFs in order to point to other needed files and resources

  -RAID ON drivers = IRST drivers with naming standard iaStorAC
  -AHCI drivers = naming standard iaAHCIC

Dell’s PreOS IRTS and AHCI drivers can both be found in the following package:

Extracted view:

Note: The above downloadable package also has an installer EXE in case you want to update to 15.2 on systems which have an OS already installed.

A new host interface known as NVMe was launched together with Gen 7 (Intel CPU) platforms. This new host interface was built from the ground up for SSD. The host detects on boot up if the storage device is a SATA or PCIe device and then switches the software stack accordingly. Since the host cannot assume all storage devices implement the AHCI host interface the necessary controller is then pushed to the device itself and loaded at boot time. The illustration below describes this.
RAID ON mode: enables the port remapping hardware in the Intel CPU. The remapping hardware is necessary for the Intel RST driver to load the NVMe controller provided by the SSD against the Intel AHCI controller in the CPU. This is required for the Intel RST driver to enumerate NVMe SSD. Also enables support for RAID 0/1/5/10 ( RAID level availability varies by system model ).
AHCI Mode: In this mode NVMe SSDs are enumerated by StorNVMe which is the Windows inbox driver. Implying that in this mode the NVME drive does not work with the motherboard’s AHCI controller, shown in the below illustration:

Below, I have outlined what the storage devices and drives look like in device manager for both M.2 SATA and M.2 PCIE drives, in each operating mode.
M.2 SATA drive when running in IRST RAID ON:

M.2 SATA drive when running in AHCI mode:

M.2 PCIE drive when running in IRST RAID ON:

M.2 PCIE drive when running in AHCI mode:


Is there any performance difference between running an NVME drive in RAID ON mode VS. AHCI mode?
Answer: Based on the explanation on differences between RAID ON and AHCI above, I believe the answer to this is ‘no’. I’ve taken benchmarks below using CrystalDiskMark.
Benchmark Conditions:
• Precision 3510 with a Dell branded Samsung PM951 PCIE 4x drive
• Windows 10Px64 1703 (Creators edition)
• All system drivers updated through Dell Command Update
• One test in RAID ON running IRST 15.2 driver
• One test in AHCI running default stornvme driver
• One test in AHCI testing with Samsung NVME driver
• Power plugged in and all performance and power options at Windows defaults

RAID ON Test results with an NVME drive:

AHCI Stornvme and NVME drive:

AHCI mode with Samsung’s driver:

How can I tell how many lanes my M.2 PCIE drive is running on?
Keep in Mind:
• Some M.2 ports will support only 2 PCIE lanes of bandwidth while other M.2 ports can support 4 PCIE lanes of bandwidth
• The amount of M.2 PCIE lanes a system has available can depend on processor and/or motherboard
• 4 lane capable M.2 drives are typically backwards compatible with 2 lane ports but will suffer performance loss as a result of fewer lanes of bandwidth
You can find out how many lanes a PCIE drive is running by using a program called HWiNFO
Note: Dell does not support this HWiNFO program. This is just a utility I’ve personally found/used and wanted to share.


When I go to the Dell website to purchase a PC I see ‘drive classes’ when selecting an M.2 drive. What does each class mean?
Keep in mind:
• The drive class standard as seen on the Dell website and below, is a storage device identification standard created by Dell
Below is a chart of what each drive class means:

Why can’t I set a hard drive password on my NVME drive?
There are 2 types of M.2 drives. M.2 SATA and M.2 PCIE ( NVME ). HDD password availability for each type is as follows:
M.2 SATA drives are provided hard drive password support from system BIOS.
M.2 PCIE drives are not provided hard drive password support from BIOS. This is working as designed.
Note: M.2 PCIE drives can operate normally even when SATA operation in BIOS is disabled. Hard drive password support is also not provided to M.2 PCIE drives in this mode. (Figure 1)

Where can I find more information if I want to upgrade my Dell to M.2?
The following post contains Dell M.2 / NVME Specifications And Upgrade Requirements For Latitude, XPS, Precision Mobile and Optiplex:
Included in this document you'll find:
• needed part numbers in order to upgrade
• number of total internal drives supported for mentioned models
• how many M.2 PCIE lanes are available on mentioned models

5 Posts

November 2nd, 2017 01:00

Hi, I have Dell 7577 with 256GB NVMe ssd but the write speed is slow 

this is my system info 

can anyone explain why in my system NVMe ssd is not under PCI Express x4 Bus , but the OP had it ?

1 Message

November 10th, 2017 11:00

Seems to be very interesting

4 Operator


783 Posts

November 13th, 2017 09:00


Thank you for your question.

What is the number of lanes shown when you click on the actual drive itself, within HWiNFO?

3 Posts

November 13th, 2017 10:00

I have encountered the same problem that i couldn't see sdd in the list

refer the below screenshot:

I have even tried the above things of irst files copied to bootable driver and this is the screenshot

the new folder from the above picture has both irstorac files and also the rapid storage driver.exe file .

but whenever i click on load driver i gives me an error

refer the screenshot for the error:

i have downloaded the os from microsoft official site

made bootable using rufus tool

System model : Alienware 17 R3

Processor:i7 6700k Skylake

Ssd: pm951 Samsung 1024GB

Hdd : Hitachi 1024GB

I even tried calling the technical support they have suggested me to change to ahci mode.could i use the raid mode in my laptop.if yes , please get back to me at

Thanking you ,


4 Posts

November 17th, 2017 19:00

Hey Justin C

I have an Alienware 17R4. HWInfo report [View:/cfs-file/__key/communityserver-discussions-components-files/3518/DESKTOP_2D00_H4J3BG7.LOG:550:0]

My problem is that when i got my laptop it was running in the "raid on" mode in the bios.

After wanting to do a clean install with the latest updated Windows 10 Pro OS i found that when going through the setup that i cant see my Toshiba 512 NVME drive. I loaded the latest IRST drivers on a flash drive....clicked on the "have drivers" or whatever the button is called and pointed it to the drivers on the flash drive......NO LUCK. 

I followed the "How To" in the following link

This also made no difference to my problem......i tried it all.

my only option was to turn raid off and install windows using AHCI mode. This seems to work but unlike you i can clearly feel the speed difference. 

Now that windows is loaded under the AHCI mode some strange things are happening. My system thinks my drive is Mechanical and not even an SSD. In the IRST software the NVME drive is not even visible. The only drive visible is my 1TB 2nd drive.


I would really like to use my system the way it was when i received it but i have spent hours on the phone with dell support and even they are stumped. 

Please if anyone can help it would be much appreciated. 

Regards Capulet

3 Posts

November 19th, 2017 03:00

@ capulet

download the irst drivers from the

in the alienware forum site they have given old driver link which is of 2015 year.

the above which i gave is the new intel rapid storage technology drivers 2017 , try downloading it and keep it in seperate usb not the "os usb" and repeat the same procedure, at first time it may say that failed to load drivers and at the secound time it may  success but remember this , you have to extract the driver and copy to the usb.

extracting the driver IRST:

extract till you get the iaAHCIC files

only these files are recognized at the time of installation.

even i have the same problem.

4 Posts

November 19th, 2017 04:00

Hi Gtabhuvan

Thank you for your advice. Unfortunately i have already tried this method with this driver and and i still cant seem to get it to show. Dells solution is to replace the drive with a Samsung PM961 or 960 Pro. I believe this is a win for me but i don't think it will solve my issue. It seems they have a way of injecting the driver when you use their custom image. I have no idea what my next attempt should be.

1 Rookie


4.3K Posts

November 19th, 2017 05:00

@Capulet, I was looking at the thread and noticed some things.  Your reference instructions for installing are for a R3 system.  From what I can tell, it only has a SATA interface, where the R4 has the PCIe interface.

Is there any difference on which M.2 slot you use?

When you downloaded the IRST drivers, you downloaded the x64 Floppy version?

I have the Toshiba drive in my system and running as SATA.  I have not tried to clean install on it but I did test trying to install on a NVMe drive.  My system could not see the drive in that configuration but I did not try to use the IRST drivers.   I do not know how Dell images the OEM drives but I assume that is done prior to being placed in the system.

As you probably know, a Samsung 960 Pro can be installed as a PCIe drive as long as you are installing in the UEFI configuration.  On my system, it is very fast when using the Samsung NVMe driver .  It is slow if using the Microsoft one.  I do not know about an Alienware system.

The F6 IRST drivers should allow the Toshiba drive to be seen during an install but something you could try is install the Toshiba as a NVMe drive and once Windows is running and the IRST Windows driver has been installed, use the msconfig.exe method to change the controller for the drive.

4 Posts

November 19th, 2017 06:00

Hey Saltgrass

The instructions given by that user on that forum was used by another R4 user and he had the same did not work. I have tried to use different NVMe slots but it also makes no difference.

I did download both the floppy version and the other version......but the result was the same. I have found the NVMe drivers for the PM961 but it seems al lot of users have another problem with that drive. Apparently you cant use the Samsung driver magician software. And can only install it as AHCI and not with RAID turned on in the bios. According to what io have read in some forums is that when it runs as AHCI it only utilizes 2 of the 4 lanes available. I'm not sure if this is true but it kinda makes sense.

I see you mentioned the F6 during startup. I actually went into the windows setup and when it came to the drive management section i clicked on the "have disk" button.....browsed for the drivers on the extra USB i created.....unzipped and fully extracted. But nothing happened. Will the F6 before boot make that much of a difference?

My biggest concern is that most of my drive management software detects the NVMe drive as mechanical or at least treats it as one. The IRST software does not even detect the drive.

Strange Stuff we are dealing with here lol

1 Rookie


4.3K Posts

November 19th, 2017 06:00

The F6 is just a holdover term from the days when a Floppy drive was used for the drivers.  As you mentioned, during an install in Win 10 you just need to point to the drivers at the appropriate time.  Back in the days of Win 7 when I was loading USB 3.0 drivers, I had to load both the basic USB 2.0 drivers and the 3.0 version.  I do not know if any such situation occurs in this instance.

Windows has the drivers necessary to do normal installs.  I think the problem comes when the NVMe controller is recognized and confuses the system so the correct drivers are not seen/loaded.

The downloaded Intel drivers does have the RAID version of the driver?  I might download and check unless you know for sure.

Maybe you should start a separate thread if you think it would be worth it..

I found an Intel site which seem to describe the process.  It states you choose the iaStorAC.inf file and let it install the drivers, then continue the install.

274.2K Posts

November 21st, 2017 00:00


I have a Latitude 5580 with Toshiba M2 (THNSN5512GPUK) NVMe. I am trying to install Windows 10, but I can't because of Windows not seeing drivers. I've tried to load the mentioned drivers but nothing seems to work. The Toshiba i've got is Toshiba RG4 from what is says on Dell website.

Any help would be appreciated.

4 Posts

November 21st, 2017 03:00

@Dell-Justin C

Can you please provide me any info you possibly have on the Samsung PM981 MZVLB512HAJQ-000D1

I have googled this drive and after about 2 hours of some to no results i gave up. Dell is replacing my NVMe drive with this model. And there is literally no info available about this drive. Another thing if you can advise me on is that on Samsungs own site there is no driver support for any drive past the Official Samsung 960 NVMe.



November 26th, 2017 01:00


I recently got myself a new Inspiron 7577, but I'm getting the exact same issue as vikram0136 is having. The drive in question is also a KXG50ZNV256G NVMe Toshiba 256GB. The drive is rated to do roughly 2700 MB/s sequential read (no problem there), but it's also supposed to do about 1050 MB/s sequential write. The latter of these two drops to about 350 MB/s max, but it's not consistent. It fluctuates from time to time, and I've tested this across a good dozen tests with CrystalDiskMark, which shows it generally going down to 350 MB/s (I did have one test that shows it briefly at 17 MB/s for the first of 5 runs for the test), but as high up as ~1100 MB/s (due to some variance). The thing is, if I do a factory reset, I can guarantee that it'll be at the tip-top of its capability for a bit, then randomly, it'll drop down, even if I do nothing. No additional updates either. Just letting it sit idle. Here's the general difference between when it would write at the appropriate speed and when it wouldn't.

When using HWInfo, the PCI Express Root Port #1 shows  a Max Link Width of x4, but Current Link Width is "Not Negotiated". Clicking on the SSD under Drives shows no mention of PCIe lanes. However, if I open up the Intel Rapid Storage Technology program, it sees the drive, and under Advanced, it says the controller type is NVMe, PCIe link speed at 4000 MB/s, and PCIe link width at x4. The organization under Device Manager does match what you have when running in IRST RAID ON (when the view is ordered by connection).

Besides CrystalDiskMark, I also did a test of copying some large files under Win10 from one directory to another (within the same NVMe drive), and I found something interesting about it. When it was actually writing at the appropriate speed, the graph was generally smooth. But, when the write was not performing as it should, the graph shows waves, like it attempted to go higher, then tripped downward, and repeated this up and down throughout the copy.

4 Operator


783 Posts

November 27th, 2017 16:00


It would be a rather involved process to troubleshoot that issue over a forum. You're welcome to send me a friend request with your service tag and we can work together. A quick work around may be to simply switch to AHCI mode, as stornvme is native to Windows 10 and doesn't require installation. Meaning, the drive will just show up as normal during Window installation.


I responded to your friend request.


Thank you for your detailed description. Please send me a friend request and we'll work to figure it out.

3 Posts

December 4th, 2017 21:00

@DELL-Justin C

i have the same problem which DiscostewSM is facing now.

Can you tell me the solution for this.

I have already send you a friend request.

please help me,

my data transferring speed is between 150-250/MBPS  as it is very slow

SSD Model : Samsung NVME 951-1024GB

No Events found!