Start a Conversation

This post is more than 5 years old

Solved!

Go to Solution

1558714

March 19th, 2013 22:00

XPS 13 Ultrabook battery not charging

Hi My year old XPS 13 Ultrabook's battery is not charging when plugged in. I measured the voltage of the power adaptor at the plug (the end that connects to the Ultrabook) and the voltage level seem fine at 19.4V However when I plug and unplug the power when the Ultrabook is off, the LED turns on and off accordingly. My Ultrabook is L321x, running Windows 7, and has BIOS A7 installed. Does anyone have the same issue, and is there anything I can do to check what wrong? Thanks for any help Ka

9 Legend

 • 

87.5K Posts

March 5th, 2014 15:00

The battery won't charge with an unrecognized power adapter - if you've already tried another, the fault is with the power jack or mainboard.

March 5th, 2014 17:00

I had the same problem with my dell AC adaptor. It worked for a while then it stopped working. They sent me a new one and it works fine. If you bought a new adaptor then maybe the manufacturer will send you a replacement.

1 Message

August 4th, 2014 01:00

I'm having the same problem, AC adapter is not recognized and I can't charge the battery.

4 Posts

August 4th, 2014 08:00

I had Dell send a tech out twice. Replaced two separate ac adapters, two motherboards and a keyboard before I had to send it back to Dell. They again replaced the motherboard and wiped my hard drive. Now my XPS 13 overheats, the fan makes noise and the computer will not go into sleep mode.

2 Posts

September 2nd, 2014 11:00

my xps 13 laptop that I pay 2500$ (for 2.5gig solid state) have this *** charging problem 1 month after the warranty died.....I change the power supply, the battery, the moterboard, I try everything (Im a computer ingeneer)....I've just been hang off on the phone by the dell support staff after 30 min of waiting and giving them my service tag 3 times....It's the last *** dell I buy .......

1 Message

December 1st, 2014 13:00

I have been having the same issues and i ended up buying a new charger wich worked for a while, but now the issue is back. Might i ask how you remove the battery on a dell xps13 321x?

March 11th, 2015 03:00

@zoolog

you'll need to open the back of the laptop with a torx5 screwdriver.

then it's a matter of unplugging the battery.

easy with the right tool.

Now about me...

I obviously have the same problem with a L322X XPS13. It is a REAL problem since now some airport security officers won't let you get to the plane with a computer you can't turn on...

I tried a brand new Dell adapter at a shop, didn't solve the problem.

I had the laptop plug and cable changed, didn't solve the problem.

I changed the battery, didn't solve the problem.

I drained the residual power, updated everything, reinstalled drivers and even windows. Guess what? Yep, didn't change a thing.

I now have an XPS13 that is at 9% from a brand new battery that is going down each time I have a security check at the airport... It's a matter of time until I have to leave it home because it won't charge.

I have now ordered a brand new mainboard / motherboard because it actually is the only thing that is involved in charging the battery I haven't changed...

I'll let you know, what happens with it, guys...


But now, what I can say is Dell laptops sux big time if you are stupid enough not to buy the extended on site support.

2 Posts

March 26th, 2015 11:00

I remove the little screw.

Guest what IT WORKS!!

You make my month.

I lost my battery icon status but I think that it's because I didn't buy my battery from Dell.

I have no information in the battery information 

Didn't seems to regonize the battery.

But I can disconnect the power and the xps still running on battery.

Thanks again.

March 27th, 2015 12:00

glad I helped!

it seems that the screw is not the source of the problem but the socket touching the metallic frame.

I will try to put some insulator tape around later to confirm the theory!

I hope more people will come and contribute!

April 7th, 2015 05:00

mine seemed tight but I guess it is a matter of a tenth of millimeter!

I changed the plug and wire too, with a cheap eBay too and it works fine!

13 Posts

May 25th, 2015 01:00

Nope, I replaced the $7 plug connector and still does not charge.

I also purchase a NEW Genuine Dell replacement battery and it recognized the battery in Battery Health as Normal but would not CHARGE.    I ordered a second battery, thinking I got scammed on the battery purchase and was shipped a Used Battery which was DEAD.  But the second Battery from another genuine Dell supplier also did not CHARGE, although the TaskBar ICON say "connected and charging".

I think the FAULT is inside my DELL's motherboard circuits ... God forgive me on this LEMON.

This is all after replacing the Keyboard for a bad UP and DOWN arrow keys.  What a wreck!

13 Posts

May 25th, 2015 01:00

Yes, I tried that ... but the cheap screw broke, making more problems.    I had to order a new $7 plastic AC adapter socket. 

In my XPS13 I7 ... I'm just about finished getting it to CHARGE.

Like others, I replaced the inside A/C socket, replaced a NEW genuine DELL battery Li Ion actually 2 of them, plus a Keyboard for another issue.   I also had purchased the Extended Warranty and my problems all started about 2 months after expiration.   I think DELLs have a internal clock to start a destructive cycle which is paired to the Out of Warranty chip inside.   Because it seems that it immediately calls Dell Service Contract dept to start asking for $239 warranty upgrades.

But that another complaint.  Right now, my Battery Health Check is Normal, the A/C Adapter is pumping out 45W and the Battery Desktop ICON says "Plugged in and Charging" but the battery stays at under 10%.   I have ordered 2 Dell Batteries (genuine $55 ones) and both fail to charge. 

I think the Motherboard changing circuit is BAD but after $140 into this repair, I'm not inclined for pour more money into the Chinese Dell. 

I'm hoping someone this this FORUM has some good tips, or maybe tell me of a Recall which I don't know about.  

I BUY 1-2 laptops a year for my small company ... Dell is not a preferred supplier anymore.  I'm going back to ASUS I think.  This XPS13 i7 was $1700 ... w/o even the Ext Warranty and it lasted 2 years, while the CHIP still have many useful years left in it.  The QUALITY totally failed in this computer, which was purchased to last 5 years.  My company took a 5 yr depreciation on it ... and boom the Dell dies in 2 yrs

3 Posts

August 22nd, 2015 04:00

Hi, my Dell XPS 13 battery is not charging, tried two different adapters, same message. Tried draining the battery, didn't solve it. Because I'm now at 0% battery, I can't install a BIOS update. Could you please suggest what to try next?

6 Posts

September 14th, 2015 13:00

I have tried everything in this thread plus what I could find on google.

The issue was persistent even after a new ac adapter and upgrading the bios to A08 through a windows 98 dos shell!! (i had less than 10% battery) i still got the warning "plug in a dell 45w adapter" before booting into windows.

after updating to A08 bios I did however leave my laptop unplugged for a weekend, over this time I think the battery must have completely drained, when I came to it today i plugged it in and turned it on expecting the horrible beep and the warning message to be displayed, however, this did not happen and it's charging!

I had already tried completely cycling the battery but that was on the old BIOS so I'm not sure if cycling it on the new one had some affect, but fingers crossed its back to working again! I'm glad I only spent  £11.99 on a new style adaptor and not £250 on motherboard which i was close to doing!

3 Posts

September 14th, 2015 23:00

Hey, I had the same issue. Running the diagnostic mode in BIOS helped.

I now have a different issue - Battery health after 1 month, drop by 8,5 %, that means that in full charge (which I also cannot do - only up to 99 %) the capacity is 49433 mWh.

I had a drop first by 2,3 % then 5,6 % and now 8,5 %... in only 4 weeks. Do any of You have this issue ?

Is there a way to reset the battery or fix it ?

How to perform any sort of battery calibration ?

cheers

Lukas

No Events found!

Top