Start a Conversation

This post is more than 5 years old

Solved!

Go to Solution

1558490

March 19th, 2013 22:00

XPS 13 Ultrabook battery not charging

Hi My year old XPS 13 Ultrabook's battery is not charging when plugged in. I measured the voltage of the power adaptor at the plug (the end that connects to the Ultrabook) and the voltage level seem fine at 19.4V However when I plug and unplug the power when the Ultrabook is off, the LED turns on and off accordingly. My Ultrabook is L321x, running Windows 7, and has BIOS A7 installed. Does anyone have the same issue, and is there anything I can do to check what wrong? Thanks for any help Ka

August 1st, 2013 21:00

Hi Occompond

Thank you for the update. Once the service call is completed let me know the status.

4 Posts

August 1st, 2013 21:00

Nope. Called Dell and they sent a new A/C adapter. Then had two home service calls where they replaced the motherboard twice. Now about to send it back to Dell for tech center repair or replacement.

2 Posts

August 14th, 2013 09:00

My battery is down to 0% so I can't run the BIOS setup since it requires a minimum of a 10% charge.  I am on BIOS A06 and am using the original power adapter.   Any help would be appreciated.

Thanks!

-ed

4 Posts

August 14th, 2013 15:00

My XPS is in the exact same situation and after running some tests, Dell support team said that to fix my issue I will had to replace my battery. Cost of battery replacement, almost R$600 (BRL).

Still evaluating if this is a good idea....

 

:emotion-12:

7 Technologist

 • 

7.1K Posts

August 14th, 2013 18:00

Hi ed_salgado,

I would like to know if you are receiving any error message when you connect the AC adapter to charge the battery on the computer.

In addition, please follow the steps mentioned below to check if the adapter is detected properly in the system.

1. Start the computer by pressing the power button
2. Press the F2 key 2-3 times
3. You will now be on the BIOS screen
4. Under the Main Tab look for the option that says AC Adapter Type
5. If the Adapter Type says Unknown or None with the adapter plugged in.
6. Reconnect the adapter to the machine and if the status now shows as Unknown then please update the BIOS again on the system.
7. Also, please check for Battery Health status under advanced tab in the BIOS.

4 Posts

August 14th, 2013 18:00

Indeed says unknown in the BIOS, but can't perform BIOS update - as you mentioned, can't run the BIOS setup since it requires a minimum of a 10% charge!!!

On windows right after start, I get an error saying that to connect to an adapter of 45w or above.

7 Technologist

 • 

7.1K Posts

August 14th, 2013 19:00

Hi rcmurad,

The issue may be related to the AC adapter or the system board on the laptop. Please click on the link below to check the warranty of the system. In case the system is under warranty, send me a private message with the system service tag to assist you further.  Please click on my name and click Start Conversation to send me a private message.

http://dell.to/12Bz4Il

5 Posts

August 14th, 2013 20:00

Hi rcmurad and ed_salgado,

with your ultrabook power off, when you plug in/out the power adapter, is the LED light (below the touch pad) respond on/off? if not, you may want to check the power adapter with a volt meter.

4 Posts

August 14th, 2013 21:00

Hey kc.yyz, yes it does respond on/off. I also have purchased a replacement AC adapter and still no luck. :(

5 Posts

August 15th, 2013 00:00

Hi rcmurad,

if the LED responded then the power adapter is good, and that the system is recieving the power. just that the power is not getting thru the charging circuit.

for my case, letting the battery drain completely did fix it, and i think that caused this charging circuit to maybe reset.

by the way, before i drained the battery, i also power cycled a few times (total power on/off), with the power adapter unplugged. And also made these setting changes:

Goto Control Panel\Hardware and Sound\Power Options\Edit Plan Settings, and click on "Change advanced power settings" link near the bottom. A "Power Option" window will popup, expand the "Battery", and changed the followings:

- critical battery level to 0%

- critical battery action to shutdown

After the system shut itself down, because the bettery is drained, i waited a few minutes and try to power it back on (just to make sure the battery is really drained). When it failed to power up, then i plugged in the power adapter.

you may want to try the above and see if it can help with your problem. good luck!!!

2 Posts

August 20th, 2013 11:00

Thanks to everyone who responded.  Unfortunately, none of the suggestions worked.  I did get lucky yesterday and for the entire day the laptop charged without giving me any problems.   I was able to charge and update the BIOS to A08.   When I booted again this morning, I got the same message that the A/C adapter could not be identified.   This leads me to believe that it's either the A/C adapter itself, or the connection on the laptop.   I'm going to go ahead and order a new adapter, which I was planning to anyhow, and see if that fixes me.   If it doesn't then it's probably time for a service call.

Thanks Again!

-ed

November 5th, 2013 23:00

I'm having the same trouble. I'd like to hear how things went with you before investing more in this laptop which may be a lemon. I wonder how many others are in this situation. Thanks for your help.

1 Message

February 10th, 2014 23:00

XPS 13 stopped charging literally two weeks after year warranty expired.

My wife is convinced it was programmed to die this way.

Bought a new Dell 45W power supply no change.

This is such a common problem why is there not a recall?  Laptop that reliably dies after one year? Probably a $5 part in there is faulty but support seems to be happy to swap mobo without looking further. Anyone out of warranty is up the creek.

1 Message

February 15th, 2014 04:00

I downloaded del Bios, but its not installing ....giving error battery should be above 10%

March 5th, 2014 14:00

Hi,

I am having the same problem. Battery status is fine. 

BIOS is A08

Adaptor says Unknown. 

I have changed the adaptor too, and I am having the same problem.

No Events found!

Top