Start a Conversation


Go to Solution


4 Posts


December 18th, 2021 11:00

Latitude 5320 System BIOS Update 1.14.3 Blue Screen & Booting Issues

After upgrading my 5320's BIOS to the new 1.14.3 version today, the laptop will not boot. When pressing the power button, the light on the button will show for around 10 seconds and then turn off again. Occasionally the whole keyboard lights up but the laptop will shutdown shortly after, but sometimes the laptop will turn on and display a "Time-of-day not set - please run SETUP program" error, and upon pressing "Continue", the laptop will then shutdown again. A few times it has booted but then shown a blue screen for a while before shutting down.

Should I downgrade my BIOS by using an external USB, or should I do something else e.g. BIOS recovery?


4 Posts

December 20th, 2021 11:00

I found a solution (by downgrading the BIOS), but it was tricky since I couldn't do this within the BIOS menu by using a USB (since the USB wasn't being detected), and the laptop wasn't booting into Windows:

My 5320 had to be plugged in otherwise the laptop just wouldn't turn on.

I kept trying to turn on the laptop and after many attempts I was able to go into BIOS. 

Even when I had a USB plugged in containing the BIOS version 1.13.0, it wasn't being detected in the BIOS menu so I couldn't downgrade within the menu.

So when in the BIOS, I clicked on SupportAssist OS Recovery.

When that loaded, I clicked on the three dots in the top right corner and clicked restart.

I then pressed F12 again, went into the BIOS and now "Windows Boot Manager" was appearing on the left hand side in "UEFI Boot Devices" which wasn't appearing before.

I then clicked on that and the laptop booted into Windows.

Twice the laptop just blanked out and shut down at random times after this, but on the third time I was able to quickly download BIOS version 1.13.0 from Dell's website and then execute the program. I could have also just used the version on my USB, but any interruptions in the BIOS installation and the laptop could be permanently damaged, so using a USB is potentially risky. The laptop then installed BIOS 1.13.0 and restarted, but it still wasn't booting, so I had to do one more thing.

I followed the instructions on someone else's post who had this same 1.14.3 BIOS issue who said do this after downgrading BIOS:

1. open bottom cover

2. unplug charger and remove battery

3. push power button for 15 seconds

4 plug in battery and charger

5. push power 

After this, the laptop was fine again with BIOS version 1.13.0


Finding older BIOS versions isn't very clear on Dell's website, so go into drivers and updates, manually search, search in the BIOS category, click the dropdown arrow next to the download button, and the older BIOS versions are there.


I hope this helps, and Merry Christmas!

Community Manager


2.2K Posts

January 20th, 2022 10:00

Hi everyone,

Please install the new BIOS and check if it solves the Blue Screen issue.

1 Message

December 19th, 2021 10:00

me too dell 5520

December 19th, 2021 17:00

I also have this same problem on 2 x Latitude 5320's. Any answers or updates?

2 Posts

December 19th, 2021 18:00

I have the same problem on latitude 5320 with 1.14.3 bios.  Nothing on the screen. It’s totally black  Power button lights for few seconds then shut down

1 Message

December 20th, 2021 04:00

Same problem here, we have about 180 5320 laptops. Updated 3 laptops with the newest BIOS version and it's hard to power them on right now.

Tried downgrading to 1.13 but it fails constantly...., can't do anything now.

11 Posts

December 20th, 2021 05:00

I can only boot with the internal battery disconnected at the moment.

11 Posts

December 20th, 2021 06:00

New motherboard seems to be the only way to roll back the BIOS version..

2 Posts

December 20th, 2021 06:00

I found how to deal with this problem. I can turn on my labtop again now. I reinstalled the old BIOS by connecting the external USB flash drive. You can follow the instruction of the video at this link 

4 Posts

December 20th, 2021 11:00

Just another note:

When removing the battery, after you have unscrewed the 4 screws, you have to take out the battery connector by lifting it UPWARDS, not straight out. It can be a little tricky and you have to be extra careful.

December 20th, 2021 14:00

I have recovered form this situation the same way as others, by downgrading the bios. On one machine I had to remove the battery first so it would boot again, but after that it has been fine.

9 Posts

December 21st, 2021 06:00

Just want to add to this to the thread. Had a device update to 1.14.3 today and refuse to boot after. Once it eventually booted it would lock up on the log in screen if I touched the screen or plugged in a USB. I was able to get it booted and BIOS downgraded via dell's website. It would still not boot until the battery was disconnected and power discharged. After these steps it booted and functioned properly on 1.13.0.

2 Posts

December 22nd, 2021 00:00

BIOS version 1.14.3 has been removed from the Dell Latitude 5320 2-in-1 Support page. Which makes 1.13.0 the latest stable version. Best option is too downgrade to 1.13.0 (if possible) and otherwise indeed a motherboard replacement is the best course of action.

4 Posts

December 22nd, 2021 08:00

For the 5320 you have to unscrew 6 or 7 screws, then carefully release the plastic clips to remove the backcover. An old credit card or plektrum will help.
Don't remove the battery (4 extra screws), just unplug the connector and wait for some time before plugging in the power suppply (we connected the battery after the BIOS downgrade, so the restart of the pc went much faster...).

At the first boot after disconecting the battery, hold STRG+ESC and plug in the power supply. With some luck, this brings you to a recovery bios menu where you can try to downgrade to the earlier BIOS version. But there is no chance, if the keyboard and touch-display aren't recognized.

This shi**y update almost bricked 5 of our 50 5320s and took several hours to fix. Better QA next time, please!

1 Message

December 22nd, 2021 13:00

I work in my company IT department and we have around 15 5520 laptop that refuse to turn on. We managed to save a couple of them by downgrading to 1.13.0 but they still have some booting problems.

No Events found!