Start a Conversation

Unsolved

Q

8 Posts

177093

September 9th, 2019 17:00

WD19 docking stations - network dropout, USB dropout across multiple models

We are facing issues with WD19s losing Ethernet connections pretty consistently and also USB dropping out randomly throughout the day.

This happens with our latitude 5400 laptops.

The issue persists after we had the motherboard and other parts replaced, 3 new WD19's, and fresh installs of OEM image and latest BIOS and drivers on laptop and dock.

The issue does NOT occur with the WD15 dock and 5400 latitude.

Dell indicated moths ago there would be an August update of the docks firmware. This has not been released.

Has Dell acknowledged this as a known issue ?- there seems to be multiple posts with this same issue with other laptop models.

We were planning on purchasing this model for our fleet...

Dell, any comment? 

1 Message

August 7th, 2019 13:00

We have several 7490 and brand new 7400 laptops and we are using the WD15 and WD19 docks with them. There is a rather annoying issue that we've been seeing where someone will try to dock the laptop and the light on the USB-C plug does not come on and the displays will not come on. Occasionally we will also see a message on the laptop stating that the incorrect power supply is connected. The only "fix" that we have found for this is to take another known working WD15 or WD19 and connect it to the laptop and then reconnect the non-working dock and it will light up and work normally. I have the latest BIOS and firmware updates on all the computers that I am seeing the issue with. Has anyone else come across this and found a permanent fix? Thanks in advance.

1 Message

August 8th, 2019 10:00

I am running into a similar problem. Our brand new Latitude 7490s are connected to WD19s after we had a very high failure rate on the WD15s. The WD19s are losing ethernet connections pretty consistently and occasionally USB connections and rarely others, such as the display. These issues don't seem to happen when the users are working on the machine, rather after a long period of inactivity and the machine has gone to sleep or after a restart. The only fixes we have found so far are to unplug and plug the dock back in to the thunderbolt connection on the laptop or to perform another restart on the machine.

 

Edit: We are also running the latest firmware and BIOS on these machines.

5 Posts

August 9th, 2019 09:00

We also have the new 7400.  We are seeing a similar issue where the system screen just goes black. With the system set to "do nothing" when closing the lid, if you re-open the lid, the screen is black.  The backlight is on but no output from screen.  Sometimes happens when disconnecting from the dock as well (WD19).  

87 Posts

August 14th, 2019 12:00

Ditto.

In some cases, just reconnecting the USB-C cable will do the trick.

In other instances, we'll disconnect the USB-C cable, then the power to the Dell Dock...  Reconnect the power to the Dell Dock, followed by the USB-C cable.

3 Posts

September 4th, 2019 11:00

Having similar issues here. Trying to fully use the WD19 docking station doesn't work. A Precision 7540 WD19DC docking station and three external 4k displays. The mentioned workarounds have worked for me at times and sometime not. BIOS and video drivers, firmware are all updated. The only constant workaround that I have found is to run two DP from the dock and the third visual display from the HDMI cable port on the laptop itself. Also, having the ethernet cable connected to the laptop works with no issues.     

8 Posts

September 9th, 2019 17:00

We are also facing issues with WD19s  losing Ethernet connections pretty consistently and also USB dropping out randomly throughout the day.

This happens with our latitude 5400

The issue persists after we had the motherboard and other parts replaced, and fresh installs of OEM image.

We have also updated all BIOS and drivers.

September 11th, 2019 17:00

I have this issue too and after finding this thread, I've found this possible fix for Window 10.

Open the Settings panel and point your mouse to the USB section in Devices. Then untick the last box where it says Stop devices when my screen is off to help save battery.

Hopefully this fixes the issue. I'm trying to find an GPO to apply it to all of our computers.

1 Message

September 19th, 2019 09:00

PullingMyHairOut1, I am curious if this fix has proven to help and if so did you find a GPO for the setting?

September 23rd, 2019 08:00

Same problem here with Latitude 5491 on WD19: After more than 10 minutes on lock screen, it loses network connections.

Apparently the function "stop devices..." under Settings > USB is no longer available in Windows 10 1903.
Instead, I went to Device Manager > Network adapters > Realtek USB network controller and changed the following:

- "Advanced" tab > Idle Power Saving > Set to Disabled.

- Power Management tab > Uncheck "allow this computer to turn off this device to save power".

 

8 Posts

October 1st, 2019 06:00

I am also having this issue with the Latitude 7400 model.

3 Apprentice

 • 

1.2K Posts

October 1st, 2019 06:00

@medavies thanks for getting in touch. When this issue occurs do you get an error message like this image.png

And this in the device manager

image.png

What troubleshooting ave you attempted so far - i.e is the system running the latest drivers and BIOS revision?

I'll drop you a private message to get your tag details

Alan

8 Posts

October 2nd, 2019 11:00

I'm not aware of issues with USB connections dropping. The issue we're seeing is that users who need to remote to their docked laptops from another location are having their remote sessions dropped intermittently. When I was able to recreate the issue, I observed that the wired network connection had dropped and it had switched over to wifi. My assumption is that users are not noticing when they are working locally on their machines because the switch from wired to wireless is happening without interrupting their work. I have not had reports of USB devices disconnecting as of yet which would definitely affect users working directly on their machine versus remotely.

I tried the latest 10.33.0419.2019 Realtek USB GBE Ethernet Controller Driver for Dell TB16/WD15/DS1000/TB18DC/WD19/WD19TB/WD19DC Dock driver as well as 10.28.1002.2018 and another version that was installed by Windows 10 when I uninstalled and deleted the existing driver. So far these changes have not resolved the issue. Last night I switched one user to a WD15 dock (which we were previously deploying) using the10.33.0419.2019 driver and she reported no drops in remote desktop during her shift.

All other drivers and BIOS are up to date on the machines I've been troubleshooting.

3 Apprentice

 • 

1.2K Posts

October 3rd, 2019 03:00

@medavies thanks for the additional details. I have feed this back to engineering for further investigation.

Alan

3 Apprentice

 • 

1.2K Posts

October 3rd, 2019 06:00

@medavies is there a way to potentially rule out the remote connection being at fault here?

Could you get a user to use the system but without the remote connection to see if it still loses the connection?

If a user used the system connected to their home network at the weekend without the remote connection for example.

Alan

8 Posts

October 3rd, 2019 13:00

These users work both on their docked laptops locally as well as remotely and there have been no reported connection drops (or USB drops) when working locally. As I mentioned, my guess is they are unaware the machine is dropping wired and picking up wireless as it's relatively seamless to the user. Switching the two users I'm currently working with to the WD15 dock appears to have resolved the issue with remote desktop sessions dropping so the issue would appear to be isolated to the WD19 dock. They are both using the most current version of the Realtek USB GBE Ethernet Controller Driver (10.33.0419.2019).

I have also not heard of any connection drops when only on wifi such as working from home or away from their desks.

No Events found!

Top