Start a Conversation

Unsolved

K

1 Rookie

 • 

1 Message

391

September 10th, 2023 14:34

Ubuntu Installer doesn't show installation type on Dell G15 5530

Dell G15 5530

Dell G15 5530

Ok so I am trying to install Ubuntu 22.04 64bit on a new Dell G15 5530. My laptop currently only has one C drive and windows 11 installed on it.

I created a bootable usb drive using rufus (FAT32 and also tried with NTFS option) and tried to install it. Got all the usual steps in the install wizard like set the language, keyboard etc. After selecting the Normal Install option the installer dont give me as “Erase and install Ubuntu” or ANY "Installation Type"

If I click on the “Change” or “+” buttons then the installer hangs and freezes

How do I fix this? 

I turned off secure boot and tried to install again again. I clicked on the change option on the installation type screen but the installer vanished.

THe same thing happened when clicked on "+" option.

I tried the same bootable usb on an old lenovo laptop and I saw the "erase and install" and "alongside" options.

why am I not seeing this on the dell laptop?

10 Elder

 • 

23.4K Posts

September 10th, 2023 15:02

If the drive is as shipped from Dell, your boot media needs to support Intel IRST drivers.

If your system has the ability to run in AHCI mode, change to that setting in setup (F2 at powerup). Note, however that if you're installing a dual boot, this will break the existing Windows OS until it is altered to support AHCI.

More information on Ubuntu and IRST here

https://discourse.ubuntu.com/t/ubuntu-installation-on-computers-with-intel-r-rst-enabled/15347

To change IRST to AHCI without reinstalling Windows, see herer

https://www.elevenforum.com/t/change-from-raid-to-ahci.12086/#:~:text=To%20change%20from%20RAID%20to%20AHCI%20and%20not%20do%20a,Windows%2011%20USB%20flash%20drive.

More and more new systems are coming without the ability to run in AHCI mode -- which will lock you out from Linux until the Linux community comes up with support for IRST.

4 Operator

 • 

20.1K Posts

September 10th, 2023 15:02

You bought the computer with windows 11 operating system. If you change the operating system you invalidate your Dell warranty. Installing a new OS -Ubuntu- wipes out Windows 11. It's not just an app to install.

No Events found!

Top