Start a Conversation

Solved!

Go to Solution

1 Rookie

 • 

1 Message

1686

December 11th, 2023 17:59

XPS 9530 Firmware bug prevents releasing audio fix for Linux devices

Hi,

As you may be familiar, when running Linux on XPS 9530 series, audio is horrible. This is because only two tweeters (top firing speakers) work, while woofers (down firing speakers) which provide the most volume, and bass do not. Me and fellow XPS users have worked hard to add support for this, (see github thread, and discord server), and managed to make it work!

Background info:

Bottom speakers are connected via active amplifier by Cirrus Logic, which requires to be properly initialized, and loaded firmware. There are multiple patches to Linux kernel required for this (quirk was added, missing properties patch is ready but not published yet, see below) , as well as addition of Cirrus amp firmware (PR pending).

With all of these changes applied, all 4 speakers are finally working on Linux, sound is significantly louder, and there is finally some bass.

Problem:
Communication with Cirrus amp is happening over SPI, and is meant to be at 4Mhz. However, in present state, the process of firmware loading to amplifier takes ~3 minutes. During first boot during this 3 minutes, sound is extremely buggy. Even worse, upon wake up, system is completely unavailable for the same 3 minutes. It appears reason is, SPI speed is capped at 3051Hz, due to the bug in Dell Firmware (UEFI): one of registers incorrectly sets required clock divider  parameters to 0x7FFF0003; This value is picked by `intel-lpss.c` driver, which enables divider with ratio of 1/32767. As source clock is 100Mhz, diving it by 32767 results in unusable rate of 3051Hz, and bug described above.

Due to this issue, we are unable to propose sound fixing patch upstream. Solution for this is to either:
a) Create bypass in `intel-lpss.c` driver. I got in contact with Intel developer (Andy Shevchenko) and was pointed out that this is indeed a firmware bug, and normally shall be solved in firmware. Me and fellow XPS users have locally tested patch which conditionally disables clock divider in intel lpss driver, and it fixed slow firmware loading, everything works flawlessly.

b) Dell to release UEFI BIOS update, with corrected value: 0x7FFF0003 shall become 0. As also confirmed by Andy Shevchenko, Intel Lpss is currently not using clock divider for SPI mode, and thus Dell's firmware should absolutely not attempt to enable this divider. I have tested a patch that forcefully sets 0x7FFF0003 to 0, and it also works perfectly, SPI is able to operate at requested speed of 4Mhz, and with above mentioned patches all 4 speakers perfectly work on this machine.

There are more bugs in Dell firmware, eg. ACPI tables are missing SPI's chip select pins definitions for right amplifier, as well as device specific properties. All these however can be set with a simpler kernel patch (linked above), and are awaiting to be upstreamed once SPI speed issue is resolved.

It seems that on Windows, custom Realtek driver handles both the missing _DSD properties, as well as wrongly configured intel's lpss clock divider.

On behalf of all Linux users and fans of Dell XPS 9530 series, I thus kindly request Dell to look into this issue, and correct this firmware bug. I also ask all fellow XPS 9530 users to like this post, as indication for Dell moderators of how many people are affected by this issue.

This is an amazing machine, and even though Dell officially does not support Linux on it, a lot of use it as one of the best devices in the industry. We have already done enormous work to get sound fix by means of community, however it seems for particular issue, there is really required an input from Dell's officials.

Thank you in advance,
Kind Regards,

Alex Vinarskis (and others rest of XPS 9530 users)


UPDATE: As it seems Dell does not consider this an issue to be fixed, appropriate change was submitted to Linux kernel (patch1, patch2) which shall ignore BIOS's set parameters for SPI clock speed. This change is expected to arrive in kernel 6.9. If/When that takes place, it can potentially be backported to stable kernel (6.7.X). Since this is still months out, current solution is to manually apply required patches, as per this guide. With these changes, SPI and thus sound system works as expected.

Community Manager

 • 

2.2K Posts

December 14th, 2023 13:46

(Marking as solution for visibility only) 

Hi all,

I submitted this topic to the concerned team and got a response that it's not considered an issue, as the XPS 9530 doesn't officially support Linux OS according to Dell's testing and recommendations.

While we understand this might be perceived as more of an enhancement request than an immediate problem, we appreciate your feedback, even for aspects that may fall outside the official scope of support. 

(edited)

1 Message

December 11th, 2023 18:36

Would love to see this. The XPS line are great laptops, receiving a bit of attention from Dell to ensure the linux experience for users is a bit more seamless would make these a brilliant "Linux friendly" solution.

1 Message

December 11th, 2023 18:51

Totally agree! It would be great if Dell would consider fixing their firmware, especially considering how popular the XPS line is with Linux users.  

1 Message

December 11th, 2023 19:14

It's crucial for the manufacturer to address such bugs promptly to ensure a smooth user experience across various operating systems, including Linux. Users often rely on community forums, official support channels, and updates from the manufacturer to stay informed about the progress of bug fixes. ,

If you haven't already, consider reaching out to the official support channels of the manufacturer to inquire about the status of the firmware bug fix. Additionally, participating in relevant community forums or online discussions can help you stay updated on any workarounds or unofficial fixes that the community may have discovered.

Firmware bugs can be complex, and resolving them may take some time. Patience and persistence can be key when dealing with such issues. I hope the manufacturer addresses the bug soon, allowing Linux users to enjoy a seamless audio experience on their XPS 9530 devices.

(edited)

1 Message

December 11th, 2023 19:22

As a XPS 9530 owner and member of the discord group that made this fix happen (with much effort and trial & error) it would indeed be great if there comes some kind of response from Dell (at least some recognition). The fact that we have missing _DST properties for the cirrus amp and more importantly a misconfigured speed on the SPI bus should be addressed as this problem is probably also an issue on Windows.

(edited)

13 Posts

December 11th, 2023 19:34

I bought an XPS 9530 because Linux is usually well-supported on this series. I hope Dell will fix this bug asap.

2 Posts

December 11th, 2023 20:20

I have spent a lot of time trying to get the sound to work in my XPS 9530 under Linux. I hope Dell takes care of this, following the competent work of those in the discord group.

1 Message

December 11th, 2023 20:54

For work purposes, I have found it necessary to use Linux and it is very frustrating that this issue does not allow me to enjoy a full experience on my Dell 9530, I hope the Dell team can take a look at it.

1 Message

December 11th, 2023 21:24

I bought the XPS 9530 hoping for good Linux compatibility. 
Please fix it.

3 Posts

December 11th, 2023 22:36

+1 here hoping this issue will be fixed.

5 Posts

December 12th, 2023 08:06

I've just bought a 9530 and am also affected by this.

I assumed Linux was still well supported on XPS, it used to be one of the big selling points 

1 Message

December 12th, 2023 09:09

I want to buy dell 9530, but waiting until issue will be resolved

1 Message

December 12th, 2023 11:06

Would be really shame if the audio doesn't work well on such great laptop. Please fix this.

December 14th, 2023 20:09

+1 really hoping this issue will be fixed soon.

1 Message

December 14th, 2023 23:42

@DELL-Nat M​ I think everyone here understands the XPS 9530 doesn't officially support Linux, however the underlying reason the sound is broken on Linux is a Dell firmware issue, that by definition affects all systems.

The final user experience on supported Windows OS may not currently be affected, but the firmware issue affects all systems including officially supproted ones, and the technical details provided in the first post are proof this is the case.

(edited)

No Events found!

Top