Start a Conversation


Go to Solution


1 Rookie


2 Posts


April 16th, 2024 18:53

S2422HZ, no signal, no OSD Menu, only Input menu

I have tried connecting my iPad Pro, my MacBook and my Lenovo laptop via both USB-C and HDMI and none are showing on the screen. The monitor is simply searching for input but not getting any. Further, I am not able to get to the OSD menu, it will only show the Input Source menu.

Community Manager


54.3K Posts

April 16th, 2024 19:43

Dell cannot know what the seller told you, but we do not see any warranty attached to the S2422HZ via its Service Tag. It originally shipped from Dell back on October 1, 2022.

The online S2422HZ User's Guide is here. Other than providing a firmware update to M3T103 which can be installed on macOS, there is no Dell macOS Technical Support for this S series monitor.

* Turn the S2422HZ off
* Disconnect every cable including the power cable from the S2422HZ
* Press and hold in the S2422HZ power button for 8 seconds
* Reconnect the power cable to the S2422HZ
* Plug the Lenovo power brick into the Lenovo Laptop
* Restart the Lenovo Laptop
* Connect the provided USB-C to USB-C cable to the Lenovo Laptop
* Connect the other end to the S2422HZ #5 USB-C upstream port (see page 10)
* Turn the S2422HZ on
* If the Input Source prompt appears, choose USB-C
* Then look on the Lenovo Laptop for a FN + ? to activate an external monitor


1 Rookie


2 Posts

April 16th, 2024 20:20

Thanks Chris! it works now.     

No Events found!