
UNSOLVED
DB2 9.7 Scheduled Backup Failed Using NMDB2 4.0 on Networker 7.6
- Next I try to create DB2 backup job manually and try to run. But it failed. You can find errors in log file.
Below is extracted from log
nsrdb2sv: *** NetWorker Module for DB2 backup session started (1528) ***
nsrdb2sv: Found NSR_DB2SV_DEBUG_LEVEL=5
nsrdb2sv: Entering nsrdb2sv_log_program_args()
nsrdb2sv: argv[ 0] = C:\Program Files\Legato\nsr\bin\nsrdb2sv.exe
nsrdb2sv: argv[ 1] = -f
nsrdb2sv: argv[ 2] = C:\db2_legato\nmddb2.new
nsrdb2sv: argv[ 3] = -s
nsrdb2sv: argv[ 4] = nwbackup
nsrdb2sv: argv[ 5] = -g
nsrdb2sv: argv[ 6] = DB2_TEST
nsrdb2sv: argv[ 7] = -LL
nsrdb2sv: argv[ 8] = -m
nsrdb2sv: argv[ 9] = wiepd05a
nsrdb2sv: argv[10] = -l
nsrdb2sv: argv[11] = full
nsrdb2sv: argv[12] = -q
nsrdb2sv: argv[13] = -W
nsrdb2sv: argv[14] = 78
nsrdb2sv: argv[15] = -N
nsrdb2sv: argv[16] = DB2:/CUSTDB/NODE0000
nsrdb2sv: argv[17] = DB2:/CUSTDB/NODE0000
nsrdb2sv: C:\Program Files\Legato\nsr\bin\nsrdb2sv.exe -f C:\db2_legato\nmddb2.new -s nwbackup -g DB2_TEST -LL -m wiepd05a -l full -q -W 78 -N DB2:/CUSTDB/NODE0000 DB2:/CUSTDB/NODE0000
nsrdb2sv: Leaving nsrdb2sv_log_program_args()
nsrdb2sv: Entering db2_log_cfg_file()
nsrdb2sv: Logging "C:\db2_legato\nmddb2.new" file
nsrdb2sv: # A valid alias of the DB2 instance. If the node you are using is through a local
nsrdb2sv: # connection, use the Instance Name.
nsrdb2sv: #DB2_ALIAS=DB2
nsrdb2sv:
nsrdb2sv: # Mandatory. Specifies the name (not the alias) of the DB2 instance that contains the
nsrdb2sv: # database to be backed up.
nsrdb2sv:
nsrdb2sv: DB2_NODE_NAME=WIEPD05A
nsrdb2sv: #DB2_NODE_NAME=DB2
nsrdb2sv: DB2INSTANCE=DB2
nsrdb2sv: DB2_ACTION=DB2BACKUP_BACKUP
nsrdb2sv:
nsrdb2sv: DB2_USR=portaldb2
nsrdb2sv:
nsrdb2sv: NSR_DB2_BACKUP_INFO=yes
nsrdb2sv:
nsrdb2sv: #Set to the path where the DB2 binaries are installed.
nsrdb2sv: DB2PATH=D:\IBM\SQLLIB
nsrdb2sv:
nsrdb2sv: #DB2_VENDOR_LIB_PATH=c:\program files\Legato\nsr\bin\libnsrdb2.dll
nsrdb2sv:
nsrdb2sv: DB2_OPTIONS=DB2BACKUP_ONLINE
nsrdb2sv:
nsrdb2sv: NSR_SERVER=nwbackup
nsrdb2sv:
nsrdb2sv: NSR_DATA_VOLUME_POOL=STAGING
nsrdb2sv:
nsrdb2sv: #This environment variable applies to transactional log backups
nsrdb2sv: NSR_LOG_VOLUME_POOL=STAGING
nsrdb2sv:
nsrdb2sv: NSR_DEBUG_LEVEL=5
nsrdb2sv: NSR_DEBUG_FILE=c:\program files\Legato\nsr\applogs\db2.log
nsrdb2sv: NSR_LIBNSRDB2_DEBUG_LEVEL=5
nsrdb2sv: NSR_LIBNSRDB2_DEBUG_FILE=c:\program
files\Legato\nsr\applogs\db2sql.log
nsrdb2sv: NSR_DB2SV_DEBUG_FILE=c:\program files\Legato\nsr\applogs\db2sv.log
nsrdb2sv: NSR_DB2SV_DEBUG_LEVEL=5
nsrdb2sv:
nsrdb2sv:
nsrdb2sv: ## set password 'nsrdb2sv -f nmddb2_cfg -P password'
nsrdb2sv: DB2_PSWD=...
nsrdb2sv: Leaving db2_log_cfg_file()
nsrdb2sv: Using C:\Program Files\Legato\nsr\bin\libnsrdb2.dll as the path to libnsrdb2.
nsrdb2sv: Adding "D:\IBM\SQLLIB\BIN" to PATH.
nsrdb2sv: Setting value for DB2INSTANCE DB2
nsrdb2sv: Trying to set the Node number 0000
nsrdb2sv: User: portaldb2
nsrdb2sv: Password: ******
nsrdb2sv: do_command(): PRECMD not found
1528#2708 Tue Oct 18 16:53:48 2011 nmdb2_setup_jobs:
Enter
1528#2708 Tue Oct 18 16:53:48 2011 nmdb2_setup_jobs:
Calling job_worker_init() with:
1528#2708 Tue Oct 18 16:53:48 2011 nmdb2_setup_jobs:
Client: wiepd05a.dp.epd.local
1528#2708 Tue Oct 18 16:53:48 2011 nmdb2_setup_jobs:
Server: wiepd05a.dp.epd.local
1528#2708 Tue Oct 18 16:53:48 2011 nmdb2_setup_jobs:
Jobtype: 2
1528#2708 Tue Oct 18 16:53:48 2011 nmdb2_setup_jobs:
Parent job ID: 0
1528#2708 Tue Oct 18 16:53:48 2011 nmdb2_setup_jobs: Job
ID: 4672044 and Parent job ID: 4672041.
1528#2708 Tue Oct 18 16:53:48 2011 nmdb2_setup_jobs: Exit
nsrdb2sv: NMDB2_ERROR: InstAttach() failed
nsrdb2sv: NMDB2_ERROR: Unable to attach to WIEPD05A database due to attach request failure, SQLCODE : -902, SQL0902C A system error (reason code = "") occurred. Subsequent SQL
statements cannot be processed. SQLSTATE=58005
SQLSTATE 58005: A system error (that prevents the successful execution of
subsequent SQL statements) occurred.
.
1528#2708 Tue Oct 18 16:53:48 2011 nmdb2_teardown_jobs:
Enter
1528#2708 Tue Oct 18 16:53:48 2011 nmdb2_teardown_jobs: Exit
nsrdb2sv: Exiting nsrdb2sv: Return Code -1
nsrdb2sv: NMDB2_ERROR: NMDB2 backup failed.
Next I try to backup DB2 database in DB2 client. That's OK.
Using the following command
Db2 backup db CUSTDB load c:\db2_legato\libnsrdb2.dll @options c:\db2_legato\nmddb2.new
It can be backed up to the networker server's staging disk volume.
Responses (0)
Solutions (0)
