Announcement Banner
⚠️
Notice: Attachment uploads are currently disabled. This is a temporary situation and will resume as normal in the coming days.
UNSOLVED

dpinink

updated

20 years ago

D

dpinink

9 Posts

0

1569

July 10th, 2006 14:00

SAP backup weird problem

Hello all!

I'm trying to configure a SAP module backup (using brbackup), on a SUN machine. I followed all the steps on the installation guide, and and I'm getting this error:


* snesun006:backint:PD6 1 retry attempted
* snesun006:backint:PD6
* snesun006:backint:PD6 exiting nsrsapsv.
* snesun006:backint:PD6 Cannot find the file /nsr/applogs/nsrsapsv.11648_tmp: Bad file number
* snesun006:backint:PD6 Backup Failed. Cannot open /nsr/applogs/nsrsapsv.11648_tmp: Bad file number
* snesun006:backint:PD6 Could not execute brbackup
* snesun006:backint:PD6 backup: 1152565557 failed.
* snesun006:backint:PD6 Failed to rename temp log file /nsr/applogs/nsrsapsv.11648_tmp to /nsr/applogs/nsrsapsv.11648_PD6
error: Bad file number

The worst part is when I go to the /nsr/applogs folder, and I found these two files:

-rw-rw-rw- 1 root root 1333 Jul 10 18:05 nsrsapsv.11646_PD6
-rw-rw-rw- 1 root root 1333 Jul 10 18:05 nsrsapsv.11648_PD6

I cannot read any of them (using vi, more, cat etc), and even if I try to list one of them alone, I get this:

$ ls nsrsapsv.11646_PD6
nsrsapsv.11646_PD6: No such file or directory

I only can read or remove both at once, like "rm nsr*". My unix support told me something about the files may be using the same inode number, but I don't know why. If I list them (both at once), I found this message in them

Running backup process as user root
spawning brbackup process as user root ...
dup2: restoring stdout failed
dup2: restoring stderr failed

exiting nsrsapsv.
Backup Failed. Could not execute brbackup
backup: 1152565557 failed.
nsrsapsv exiting at Jul 10 18:05:57 with fatal error
Unable to execute brbackup (pid 11649)!

nsrsapsv exiting at Jul 10 18:05:57 with fatal error
Unable to execute brbackup (pid 11649)!


The biggest problem is that this machine is very like to other machine I configured before, but in that I had no problems at all. Has anyone experienced this before?

Regards,