Start a Conversation



12 Posts


June 22nd, 2022 00:00

Unable to take Oracle RMAN backup from Solaris.

Hi All, 

We have our core banking DB running on Solris 11, oracle DB 19c version. The databases are two node (RAC). Generally we take the backup from node1 every time. For the last one month, we are trying to take the backup from NMC but every time it failed showing the below error: 

                                         RMAN-03009: failure of allocate command on CH1 channel at 06/22/2022 13:20:26
                                         ORA-19554: error allocating device, device type: SBT_TAPE, device name:
                                         ORA-27211: Failed to load Media Management Library

We can take file system backup from the same server using NMC but unable to take RMAN backup. NMDA's configuration looks ok but is unable to take backup. Support case logged already but still no hope.

1. link is created several time, but still no result.

2. We can initiate oracle backup using RMAN script the node itself via networker server and take backup on the same pool which is used for RMAN backup from NMC. But somehow NMC backup is failing every time showing same error.

3. ddpconnchk showing every data domain path is successful.

4. NMDA version





12 Posts

June 22nd, 2022 00:00

@crazyrov , hope you could help.

July 4th, 2022 07:00

from the NMDA 19.3 administration guide:

If RMAN fails with the following error, ensure that NMDA and Oracle have the same bitness. Refer to the RMAN user guide for details on how to test that you have integrated the media management library correctly:
ORA-19554: error allocating device, device type: SBT_TAPE, device name:
ORA-27211: Failed to load Media Management Library
Additional information: 25

Has above been ruled out? As also stated in

Ensure that have the correct bit number as the Oracle server.  i.e. if Oracle is 32-bit, you need to have the 32-bit version of NMDA.  If Oracle is 64-bit, you would need the 64-bit version of NMDA.

We have to take you on your word, that the relinking is actually done correctly, without specifying what the link is and where it is linked to? Also stated in above KB article?

Double check that as per part of the install process you have correctly linked NMDA with Oracle.  This can be referenced in the NMDA install guide, and as an example on Linux it looks as the following.

ln -s /usr/lib/

Were you already running nw and nw nmda successful before? Or did it start failing after updating to nw19.3?

Doesn't setting a higher NSR_DEBUG_LEVEL show more info? states another possible cause in a RAC env, when:


  1. Client is configured in Networker server using the Oracle SCAN hostname.
  2. Target Database Net service name used by the backup is defined using the Oracle SCAN hostname in DB server TNSNAMES.ORA.


  1. Don t use the Oracle SCAN hostname as client name in Networker.
    • Select and use one of the node's VIP hostnames in the RAC system. (using a node physical name should work but it is preferred to use the VIP name for client indexing considerations)
  2. Make sure the Net Service Name of the Oracle target database is not defined in DB Server TNSNAMES.ORA by using the RAC SCAN hostname.
    • If that is the case, then ask the DBA to create new service name for the target DB, like  SID-RMAN   or  SID-LOCAL  and define it using the local host name, like the following example:
    (ADDRESS = (PROTOCOL = TCP)(HOST = local_host_name)(PORT = 1661))
      (SID = mySID)

  • The DBA should create the service name in each RCA node.

Additional Information

The provided resolution steps are not required for NMDA 9.2.
  • The NetWorker client can be configured using the RAC SCAN hostname.
  • The target DB service can be defined using the RAC SCAN hostname in TNSNAMES.ORA


Then again, the additonal info states, the resolution steps are not required for NMDA9.2, without stating if it can even encounter the same issue or if it would require another approach. I assume the former?

No Events found!