Start a Conversation

This post is more than 5 years old


Go to Solution


September 20th, 2015 07:00

Windows 10 Upgrade Disables Broadcom Ethernet Adapter

I recently upgrade my XPS 8100 from Windows 7 to Windows 10. Since the upgrade, the ethernet adapter is periodically getting disabled.  I can use the Windows troubleshooting wizard to re-enable the adapter, but the problem comes back once or twice per day.  Has anyone else seen this problem and found a solution ?  I am not running any 3rd-party security software.

8 Posts

September 29th, 2015 19:00

I found the following instructions for installing the latest Broadcom driver, and this seems to have solved my problem.

After downloading and extracting the zip file NetLink®/NetXtreme® I Desktop/Mobile/Server (x64):

1. Go to Network Settings and click Change Adapter Options
2. Right-click on the Ethernet/Local Area Connection device and select Properties
3. Click on Configure and go to the Drivers Tab
4. Click on Update Driver and then select Browse My Computer
5. Select "Let me pick from a list..." and then select Have Disk
6. Locate the downloaded driver file (b57nd60a.inf) and select OK
7. You will now see a long list of drivers: Select Broadcom Netlink (TM) Gigabit Ethernet (about 1/3 of the way down on my list).
8. Click Next and you should be good to go!

I applied this update three days ago and my Ethernet connection has worked perfectly since then. I'll update this post if any problems arise, but so far its looking good.

1 Message

September 20th, 2015 13:00

I have the same issue on Inspiron 17.  It has the Dell Wireless 1704 adapter.

Ever since the upgrade to Windows 10, the adapter seems to be randomly going down.  the only way to jog it back to life is to disable and reenable it, but it does not always work and if it works, it only restores the connectivity for a few minutes.

I searched through the threads on Dell forums and tried all the suggested tricks, including changing power settings or even disabling Bluetooth.  No effect.  I have the latest available drivers and the model is listed by Dell as Win 10 compatible, but it seems that something was missed in testing.  The machine worked fine on Win 8.1.

I will appreciate any suggestions.

1 Message

October 3rd, 2015 13:00

I tried this but I was not successful at opening the downloaded file. Any instructions on how to open and install the downloaded file would be appreciated.

October 4th, 2015 22:00

I updated the Broadcom driver on my XPS13, but it did not solve the problem.

8 Posts

October 8th, 2015 17:00

From the Broadcom site, select the 32- or 64-bit driver library, depending on whether you're running a 32 or 64-bit machine.  Download the file.  It will be saved as a compressed zip file, so once its been downloaded, highlight the file and select Extract from the windows menu and then select "extract all".  This will uncompress the files.  Once this is finished, you should be able to follow the instructions for updating your Broadcom driver.

2 Posts

December 31st, 2015 12:00

Thank you been looking for a fix for a while, getting fed up having to revert back to windows 8.1 till found a fix that worked.

1 Message

October 4th, 2016 19:00

It worked for me. Thank you so much!

My computer is Acer btw

1 Message

October 31st, 2017 03:00

Great! It worked for me!

Acer Aspire E1-571G.

Windows 10 x64

1 Message

December 21st, 2018 02:00

Instructions Worked perfectly to get my xw4600 Core2Quad Workstation Network Card working reliably again.  BIG THANKS! :) 

1 Message

November 9th, 2020 10:00

same problem here and is worked . thanks

No Events found!