Start a Conversation

Unsolved

K

2 Posts

64

October 23rd, 2023 16:18

RAID lost drive, Esxi fatal error, diagnostics errors.

Server: Poweredge T420

This server was moved across the country and had some physical damage happen. When I first booted it, the third drive bay was not reading and flashing and I also had a CMOS battery error. I turned the server off, reseated the drive, and got the same error. When I loaded the server up, I could see it was set to Raid 10 and though the drive was reading, it was no longer in the RAID config.  on the PERC screen, it shows Span: 1 has a missing drive then below that, there is an "unconfigured physical disk". I tried to see if I could add it back in, but the option to add it was greyed out. I started the server and got an "error loading /stat.tgz" and "Fatal Error 11(volume corrupted)" from the eSXI hypervisor. I tried removing the third drive and get the same error from Hypervisor.

I ran the diagnostic tool and got error code 2000-0151 validation 121931. 

I'm finishing the diagnostic tool and then thought of maybe moving the drive to another bay just to see if the bay was damaged in the move, but it seems to be recognizing the drive, so I don't think so. I don't want to lose any data, so does anyone have any ideas how I can proceed forward with this?

Moderator

 • 

3.1K Posts

October 23rd, 2023 20:50

Hello Kay,

 

Code: 2000-0151 is Predictive Failure indicated

Take a review of the LifeCycle Controller (LCC) log <F10> on boot up to enter the LCC. Do you see any errors or faults for drives?

 

If this critical data and you do not have a backup you may want to you look in to a Data Recovery Company if you need.

 

Did you reseat the backplane and cables after transport?

 

Could you provide pictures of PERC controller interface? One picture of each tab could be helpful.

 

2 Posts

October 24th, 2023 18:18

@Dell -Charles R

-The LLC log has a few errors:
DIAG0151/DIAG0142: Hard drive ~~1~-S/N ~~2~, ~~3~ self test unsuccessful ~~4~ and Hard drive ~~1~-S/N ~~2~, ~~3~ incorrect status ~~4~

PDR3: Disk 2 in Backplane 1 of RAID controller in Slot 6 is not functioning correctly.

VDR58: Bad block medium error is detected at block 0x695ed9c0 on Virtual Disk 0 on RAID Controller in Slot 6.

-This is critical data, so I'd like to avoid losing it.

-I reseated the cables and backplane.

-I've attached all the tabs. ​

Moderator

 • 

3.1K Posts

24-10-2023 07:04 PM

Hello Kay,

 

From the image I can see the RAID10 missing only one drive. A RAID10 should be able to function with missing only one drive.

You indicated you get volume corrupted message. That seems to point to corrupted data. You may need to consider a data recovery company.

 

Try draining the flea power, remove the bad drive and test boot:

drain flea power (shut down, disconnect power cables and Network cables, hold in power button 20 seconds with cords removed).

Remove bad drive

After flea power drain and drive removed, system has to set for 3 minutes for DRAC to reset without any power plugged in, then plug in NIC and power but wait 2 minutes before power on to give DRAC time to initialize.

 

Test for good boot.

DELL-Charles R

Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#IWork4Dell

Did I answer your query? Please click on ‘Accept as Solution’. ‘Thumbs up’ the posts you like!

No Events found!

Top