Start a Conversation

This post is more than 5 years old

Solved!

Go to Solution

114071

May 17th, 2014 11:00

b1165nfw Linux installer modifies important files, damages system

Hello Dell and friends!


First of all, thank you for offering linux drivers, it is definitely appreciated, and I wouldn't have gotten this device if they weren't offered.


However, the linux installer for the drivers makes some very strange changes to important system files, which made my computer unusable, which as far as I can tell must be a mistake, so I sincerely hope that one of your representatives can send this message on to whoever is in charge of it.

Specifically, after downloading the driver here: http://www.dell.com/support/drivers/us/en/19/product/dell-b1165nfw , I ran the autorun program, and I of course had to give it administrative privileges, and clicked through successfully. It changed the owner of the /usr folder to 8070:9999 (where it should be root:root), and this being a very important folder, broke many other programs (such as virtualbox). There were several other folders that had this permission changed: /usr/lib, and a few lib files in that folder whose names I don't remember (something like libtty).  It also created an empty /Desktop folder at the root! So something very strange is going on with the program.


Please do have them take a look at this, as depending on the skill level of the user, this can wreak havoc on their system. In my trying to fix it, I made a typing error and ended up having to do a complete reinstall of my system! I was running Ubuntu 12.04, and then I installed 14.04, reran the program since I no longer had anything to lose, and found the same behavior. I know I'm not the only one, here's at least one other person with the same problem:

http://wyldeplayground.net/usr-folder-permissions-being-changed-to-8070-9999-breaking-virtualbox/


Hope to hear from someone soon!


Dan

4 Posts

May 22nd, 2014 02:00

This is what worked for me to get printing capability in Ubuntu 14.04. These are not the most extensive instructions, I'm tired, so I apologize. Hopefully this will get you started, please keep in mind that I am no expert so follow at your own risk. This assumes you already have CUPS installed (it comes pre-installed with most distributions).

The following involves: Downloading the Dell Unified Driver, moving a few files, and adding the printer through Ubuntu's Printers application.

1. Download the Dell universal driver at the link in my first post, and unarchive the files (in Ubuntu, you could double-click and click extract), which should give you a folder named cdroot, I will refer to this folder throughout.

DO NOT run the install script. As mentioned above, it does disastrous things, and judging by Dell's response to this post (none) they have very little interest in even forwarding the email to a person who cares.

2. I had begun by going to the Ubuntu Printers app, and it told me that it won't work without "rastertospl" being installed. This file is found in cdroot/Linux/x86_64 if you have a 64-bit installation, and cdroot/Linux/i386 if you have a 32-bit installation. You need to copy it to /usr/lib/cups/filter and make sure it is executable, and sudo privileges are needed to do that. Pretending you had extracted the Dell installer package to your Desktop, the terminal commands would be these for a 64-bit system:

sudo cp ~/Desktop/cdroot/Linux/x86_64/rastertospl /usr/lib/cups/filter

(Check if it is already executable, it should say -rwxr-xr-x to the left after you run the next command. Note the "x"s):

ls -l /usr/lib/cups/filter | grep rastertospl
 
If there aren't three x's as above, run this:

sudo chmod +x /usr/lib/cups/filter/rastertospl

After running the rastertospl program (thanks to Olivier at the second link below for the tip), the program indicated that we need the libscmssc.so library. It is found again at cdroot/Linux/x86_64 or cdroot/Linux/i386. We need to copy it to the /usr/lib folder, and again ensure it is executable:

sudo cp ~/Desktop/cdroot/Linux/x86_64/libscmss.so /usr/lib
(if necessary:)
sudo chmod +x /usr/lib/libscmss.so

3. I went to Ubuntu's Printers app in settings (System Settings > Printers) and clicked Add.

(I had already set the printer up to appear on my network, so I was able to search for it and select it, hopefully it shows up for you.) When drivers couldn't be found for the printer (don't pick Generic, it won't work), it gives you an option to add a PPD file. The b1165nfw.ppd file is in cdroot/Linux/noarch/at_opt/share/ppd. I navigated to it from within the Printers app.

After that, printing worked for me. This does not address scanning. That will have to wait for another day.

Many thanks to these sources for filling in the gaps in my knowledge:

https://wiki.archlinux.org/index.php/Samsung_ML-2245
http://blog.cochard.me/2012/01/installing-samsung-ml-2950-series.html

Dell, so far very little thanks to you. This will most likely be the last piece of Dell equipment I buy. It's one thing to have something not work, and another thing entirely to make an installer application that damages people's computers. I know Linux is not a big market, but a simple response would have been decent.

4 Posts

September 22nd, 2015 23:00

I got the scanning working as well! (well, not me... it's due to the hard work of this guy: http://www.bchemnet.com/suldr/index.html ).

My research for the first question led me to the conclusion that this is a re-branded Samsung printer, or that at least they use the Samsung drivers, so I looked up more info on the Samsung driver. The guy at the website listed above repackaged the Samsung driver in a repository that will install it in a way that doesn't damage or introduce security issues into your system. Please check out his site for more info, but here are the concrete steps I took to get scanning working on my Ubuntu 14.04 system.

Note that if you are installing this for the first time, try doing this before doing the steps in my previous answer. I suspect these steps might take care of printing as well, but I'm not going to mess with my working system to test it out.

Here is the summary of the steps I'll outline in more detail below:

1. add the repository, update package list

2. install suld-driver-4.00.39

3. modify this file: /etc/sane.d/xerox_mfp-smfp.conf , adding the vendor and product id to the list.

4. modify this file: /etc/udev/rules.d/99-libsane-samsungmfp.rules , adding our printer to the list in a certain format.


More detail:

First we need to get the product id and vendor id for the printer. In a terminal run:

sane-find-scanner

I had to run it with sudo for some reason. We are looking for the line like this:

found USB scanner (vendor=0x0bda [Generic], product=0x0129 [USB2.0-CRW]) at libusb:001:004

The important numbers are after vendor= and product= . In my case they were 0x0bda and 0x0129 . If you don't have a line like this, your computer is not detecting the scanner at all, so you have bigger problems.

1. Add the repository:


- Edit this file by running this command in the terminal (you need sudo privileges, type carefully! Make a backup first by doing this: sudo cp /etc/apt/sources.list /etc/apt/sources.list.backup):

sudo gedit /etc/apt/sources.list

Add this line to the end of the file, this line EXACTLY, he has a note on his website about not changing anything because it won't work. Feel free to copy-paste:

deb http://www.bchemnet.com/suldr/ debian extra

Save and close the file. Add his GPG key so ubuntu doesn't give you warnings about untrusted packages:

sudo wget -O - www.bchemnet.com/.../suldr.gpg | sudo apt-key add -

2. Update your package list:

sudo apt-get update

Install this driver:

sudo apt-get install suld-driver-4.00.39

3. Edit this file:

sudo gedit /etc/sane.d/xerox_mfp-smfp.conf

Add this line to the end, replacing in the format 'usb , here's what mine was:

usb 0x0bda 0x0129

Save and close.

4. Edit this file:

sudo gedit /etc/udev/rules.d/99-libsane-samsungmfp.rules

Add this line above the first line that looks similar to it:

ATTRS{idVendor}=="0x0bda", ATTRS{idProduct}=="0x0129", ENV{libsane_matched}="yes"

Save and close.

After that my scanner worked! Again,  at Dell for being so absent on this. Seriously. That installer DAMAGES our installs. Just, like, write an email to the guy at that website and he will hook you up. It is not hard to support linux, there are so many people who will help you.

The dude at the site recommends that if you get it working, just disable his repository to avoid updates from him unless you need to, because these Samsung drivers are poorly made and very fragile. Add a hashtag before that line we added to your sources.list and it will be disabled.

sudo gedit /etc/apt/sources.list

change:

deb http://www.bchemnet.com/suldr/ debian extra

to:

#deb http://www.bchemnet.com/suldr/ debian extra


I hope you all are able to get it to work like I was. Hopefully I haven' t written any typos. Check out that guy's website for more detailed information, and thank him. Later,

4 Posts

May 21st, 2014 14:00

Bump, any Dell employees actually monitoring these forums?

1 Message

January 20th, 2015 00:00

Hi!

Have you found a solution to this problem?

--

Marks.

6 Posts

July 13th, 2015 01:00

Thanks for the detailed answer. This helped me as Dell did not provide any documentation aside from the download itself.

1 Message

May 22nd, 2016 04:00

HI, thank you so much for your guide, it has really saved me time and allowed the scanner to work. I use ubuntu 14.04 i believe, and my printer is over the network, not plugged in by usb.. Installing the dell drivers only made basic printing work and thats it.

I saw you post about the samsung drivers and gave it a shot, whitout the parts related to the usb. Simply installing the drivers on top of the old ones made scanning work perfectly after a reboot, and printing still works, so I'm more than happy. Only caveat is that the scan-to-pc function does not recognize my ubuntu box like it does with the windows one, but I haven't really investigated.

I second you advice to disable the repo as soon as it works, its just good practice with third party drivers.

Dell should be ashamed to give drivers in this sorry state when they could repackage the samsung ones and save us (and them) time and effort.

No Events found!

Top