Start a Conversation

This post is more than 5 years old

Solved!

Go to Solution

632868

April 7th, 2015 09:00

DELL C1760NW ERROR CODE 009-654

Searched high and low.  Seen this code come up on other printers but the solutions do not apply for the C1760NW.

Turned on and off. Turned off and on. Followed steps for other models only to get so far as the next stage isn't applicable and therefore it cannot be tested.

Is there anything that can be done on this for me to test and others who have this problem find this thread and also find a solution?

4 Posts

July 2nd, 2015 12:00

I was able to resolve the dreaded 009-654 on my c1765nfw. I downloaded/installed the usb driver for the printer and connected the printer to a usb port on my computer. I downloaded the latest firmware driver. I started the printer with a toner cartridge removed. I ran the Dell firmware upgrade program and it recognized that the printer was connected and loaded the firmware. When the firmware installation completed, I restarted the printer and everything is working again.

This solution may work on all other Dell printers that experienced the same error.

1 Rookie

 • 

1 Message

22-05-2024 06:12 AM

@pmanna​ refreshing the firmware from the Dell website worked for me. Thanks for the tip!

1 Message

July 22nd, 2020 16:00

This worked for me as well. No need to download the USB driver and connect by cable though. The update can be done through the wireless network connection as well. Simply turn off printer, take a toner out and turn it on. Now start firmware update on PC, pick network update and select the printer from the list. Update took a while but went smoothly. Afterwards printer was back in perfect operation.

April 7th, 2015 11:00

Hi Nigelrs,

Thank you for reaching out to us. The error code shows that there is an issue with the printer ADC sensor. If you have already restarted printer multiple times and the error remains then you can try cleaning the ADC sensor which might fix it.

Please ensure that the printer is turned off.

Please lower the back panel cover of the printer.

You should see two small sensors that look like LED.

Take a lint cloth and soft tissue and clean it.

Close the door.

Power it back on and check if the error remains.

If the error remains then the printer needs replacement as the sensors are faulty. If the printer is within warranty period then the same can be replaced. If it is out of warranty then we recommend you to buy a new printer.

Please let us know if this helped.

2 Posts

April 8th, 2015 05:00

Thanks, tried this and it worked before but not this time.  It is out of warranty so it went to Tombstone.

1 Message

December 13th, 2015 06:00

Thanks pmanna, worked like a charm on my 1760nw.

1 Message

February 21st, 2016 07:00

thanks a lot PMANNA, I used your method and it helped me to solve my problem ,it's ok for me.(Dell C1760nw with 009-654 error message).

1 Message

May 28th, 2016 20:00

Worked for me too .. Thx ..

1 Message

October 27th, 2016 08:00

Worked for me as well. On my Dell C1765NF. For the French version, I downloaded the firmware here: www.dell.com/.../DriversDetails

Thank you pmanna!

1 Message

March 15th, 2017 07:00

Thanks I was able to solve my problem by running Printer_C1765_Firmware_Dell_A03_WIN.exe firmware

1 Message

May 2nd, 2017 15:00

Wow!  thanks for the suggestion.  Updating the firmware saved me from giving up on my C1760NW!  I had tired everything else and thought (based on what I could find out on the code) that it was a physical problem.

You are a great help!

10 Posts

May 9th, 2017 01:00

Thanks, pmenna! Worked for me. Removing a toner cartridge is such a simple, but genious trick.

1 Message

December 4th, 2017 13:00

Although I have updated the firmware before and my printer was made in 2016, I had it reload the 2015 firmware today and the problem was resolved on my C1760nw.

1 Message

December 17th, 2017 03:00

Updating the firmware fixed it for me too, thanks you saved me a fortune :)

1 Message

January 27th, 2018 09:00

Hi, where can i find the USB driver to download? I am having the same issue. I have downloaded the update tool, removed an ink cartridge and connected the printer to the computer but when i run the update tool it is not finding my printer.

3 Posts

January 27th, 2018 11:00

Sadly this didnt work for me, I update to v1.078 (Mac OS) and this made no different on my non-wifi version of this printer 1765nf. 

Any other suggestions?

No Events found!

Top