Start a Conversation

Solved!

Go to Solution

1 Rookie

 • 

2 Posts

643

August 26th, 2023 16:08

Precision 5540 - SupportAssist - Unexpected error occurred

All of a sudden Dell SupportAssist stopped working. It giving Unexpected error during driver scan. Looks both my personal and office laptops are showing the same error.

OS : Windows 11 Pro

SupportAssist Version : 3.14

Tried all these

  1. Reinstalled app - no help
  2. .NET frameworks installed
  3. Removed C:\ProgramData\Dell respective folders for SupportAssist after uninstall.
  4. Both SupportAssist services are running fine.

Log - C:\ProgramData\Dell\SupportAssist\Agent\logs\Application\SupportAssistAgent.log show the below error. It looks weird, looks like Dell client issue. Who can help here ?

"Type": "SAConsumer",
  "Exception": {
    "Code": "INVENTORY_COLLECTION_FAILED",
    "Message": "Scan failed!",
    "Recovery": false,
    "Type": "Dell.SupportAssist.Client.Plugin.Esupport.Helper.ResponseMethods+ScanFailureException"
  },
  "OSName": null,
  "OSVersion": null

1 Rookie

 • 

2 Posts

September 2nd, 2023 04:03

Here is the solution to the issue, found this when I installed another software, and SupportAssist / Command Update started working. 

Install these, and you should be good to go.

(edited)

2 Posts

August 27th, 2023 11:59

I have the same problem with an XPS 8930 and an XPS 8940. Additionally if I attempt to run the Dell Update app, I receive an error message of "Unable to Retrieve System Inventory Information."  Event viewer shows "Faulting application name: invcol.exe, version: 10.7.2.2, time stamp: 0x64d348a4."

2 Posts

August 28th, 2023 01:15

Same problem on XPS 8950 this morning. Required services running. No issues on 22-Aug. Uninstalled, restarted, reinstalled, waited. Same error. Installed Windows update KB4023057 on 25-Aug. Cannot uninstall to verify.

1 Rookie

 • 

12 Posts

August 28th, 2023 01:29

Same problem with my XPS 8950 with Windows 11. I recall there was an update to Dell Update about a week ago.

August 28th, 2023 15:08

I am having the same problem(s) on my Alienware R15 - both SupportAssist (unexpected error occured) and Alienware Update (unable to retrieve system inventory information) stopped working last week (~ 8/24/23).

I've tried deleting and reinstalling SupportAssist (using the Microsoft Troubleshooter full uninstall) to no avail).

1 Rookie

 • 

5 Posts

August 28th, 2023 16:00

For me the resolution to this problem, which I dealt with just this morning, was a BIOS update. A manual check for a BIOS update on Dell Support's Drivers & Downloads page revealed that the current BIOS, version 1.14, which was released just earlier this month, was different from the version 1.13 that I was actually running. A BIOS update followed by an uninstall/reboot/reinstall of both the Dell Update application and Support Assist fixed everything.

Good luck

(edited)

2 Posts

August 28th, 2023 18:42

What worked for me? Reinstalled BIOS 1.14.

P.S. Device manager still reports BIOS version 1.13, but UEFI shows 1.14. 

August 28th, 2023 20:30

@Jack K.​ 

Jack K & Not Two,

That worked for me! SupportAssist (or the AW Update app) had updated my BIOS to 1.15 last week or so, and that’s when I started having the problems.

I manually updated the BIOS just now and the problem has gone away. Thank you!

Adam

1 Rookie

 • 

3 Posts

January 4th, 2024 10:20

@Not Two and @Jack K. and @adamcb_089aca 

Thank you for your posts. I was running into issues with Dell SupportAssist on a Dell Inspiron 3670 tower with Windows 11 (had upgraded from Windows 10 a couple years ago) getting stuck / stalling out on various parts of the scans and occasionally the dreaded "unexpected error". I keep all my drivers, BIOS, applications, and OS diligently updated, so I never suspected that it could be a BIOS issue. After several uninstall / reinstall attempts didn't help, I found this thread. Even though my BIOS was absolutely current, simply re-installing the BIOS update for the same exact / current version seems to have resolved the issues.

No Events found!

Top