Start a Conversation

Solved!

Go to Solution

2459

August 9th, 2022 22:00

Upgrade from 4.7 to 7.0+ Fails Pre-Check

When I run the precheck on 4 node 4.752 we receive the following error:

"Check ESXi version compatibility>. Component ESXi Upgrade Profile of node vxrailhst01.domain.com is incompatible. Current version version: 6.7.0, min_build: 17700523. Expected version version: 6.7.0, min_build: 16316930"

Why is is recommending that I downgrade to an older build?

Moderator

 • 

8.5K Posts

August 10th, 2022 10:00

You should call phone support, they will need to go through the logs to figure out why. This should be resolved before upgrading.

Moderator

 • 

8.5K Posts

August 10th, 2022 07:00

. Yes, restarting the service may help. You may also need to upgrade the firmware on each node. https://dell.to/3Qv6bKJ the firmware and software upgrade guides here may help.

49 Posts

August 10th, 2022 07:00

I received the same error for all 4 nodes. I just posted it once to safe reading time. I have restarted the VXRail Manager. Should I perform the “systemctl restart vmware-marvin” as well?

Moderator

 • 

8.5K Posts

August 10th, 2022 07:00

Hi,

Thanks for your question about the Vxrail upgrade. Did the other nodes upgrade without this error? Try the following command and upgrading again. #systemctl restart vmware-marvin

 

Let us know if you have any additional questions.

49 Posts

August 10th, 2022 09:00

Thanks for the info.  The restart didn't make a difference and the procedures for firmware update don't apply to my E560 models.

Firmware.PNG

Moderator

 • 

8.5K Posts

August 10th, 2022 10:00

Did you do the one for software upgrade procedures?

49 Posts

August 10th, 2022 10:00

I did and once the VxVerify 2.20 script finished it has 1 critical and 1 warning that read,

"Failure 182790 | node_drift: Drifted nodes found."

"Warning 45053 | vc_external: External VC vCenter Server 7.0.3 build-19717403"

I'm not sure what the "Drifted nodes found" is referring too, but all the nodes are running the same ESXi version and firmware across the entire rail.

49 Posts

August 10th, 2022 14:00

Already did.  Was performing these steps in parallel until they get back to me with scheduling.  I was more looking into for my understanding and getting ahead of the SR.

I appreciate the help.

1 Message

January 25th, 2023 14:00

HI,

Did you get this resolved?  i'm having the same issue.  Any help would be great.

Moderator

 • 

6.9K Posts

January 26th, 2023 01:00

Hello Eldorado_IT,

If you have tried all the steps listed in the post then you will need to open a support case so that we can review the logs to see what is going on.

49 Posts

January 26th, 2023 09:00

I did call support and after some exporting of logs and data the engineer was able to remote in our management console to bypass the error and allow the upgrade to proceed. Unfortunately I was not able to document what the engineer was able to perform.

1 Message

March 20th, 2023 13:00

The fix is to edit the LCM properties, do this at your own risk, but it worked for me.

SSH to VXRail Manager, (hint: username is mystic)

sudo su

vim /var/lib/vmware-marvin/lcm_advanced_mode.properties
Edit the value
lcmProperties.upgrade.advanced.mode.on=false to true
 
reboot VxRail Manger and try again 
No Events found!

Top